Lineage 18.1 - finally official

Hi, thank you for all the work and the instructions.
It is, however, not quite working for me.
I did flash the lineage recovery as instructed, did the data wipe and installed lineage 18.1 via adb sideload.
There was no error message, but it seems to get stuck upon booting. It reboots into the lineage recovery, telling me to wipe/format my data again, which leads to again getting stuck in booting.
I don’t know what could be the problem, as I don’t get any error messages and the adb sideload tells me that the installation finished.
Tried with and without OpenGApps and with different versions of lineage 18.1, but get always the same result: super long boot and reboot into lineage recovery.

it seems to be a problem with the version of openGapps: 20210929. was reported for multiple devices on reddit.
the installation works with the version 20210925.


Did anyone try to encrypt their FP2? @chrmhoffmann I get the error Cryptfs : Orig filesystem overlaps crypto footer region. Cannot encrypt in place. I found some comments on this in the forum about resizing data partition, but is there any current documentation what are the most recent and correct stepts/values to do this?


@yvmuell you were right. Looks like I didn’t boot into recovery directly after flashing the LOS recovery. I tried again directly after flashing and used power button + vol up to boot into recovery and it worked.
I think I used shell commands before to boot into recovery.

Thank you very much for the hint and sorry for my mistake here. I must say it was not clear to me how to do it correctly, neither after reading LOS installation guide nor after your post. My bad, but maybe it might help others to be more specific in this case :slight_smile:


Which seems to not work as I mentioned in this thread :-/. Any ideas?

Encryption doesn’t work? Ah, the memories :slight_smile:

Did you already format the data partition before any new encryption attempt? If so and it still doesn’t work …

I just successfully encrypted my FP2 once again.

@Singulus I am afraid that you might have wiped data last with very old recovery.

I’d suggest to take latest lineage recovery (NOT TWRP) and wipe and try again.



@chrmhoffmann I indeed wiped with TWRP 3.5.2, which would explain the hassle. At first I tried LOS recovery and hat trouble with it, switched to TWRP and got LOS 18.1 working (it’s not said that it was a problem of LOS recovery here, could also be me ^^). Is there any smooth way to resize the partition without the need for an extra wipe for making encryption work again?


I am not aware - in theory you could maybe shrink the filesystem. But smooth…


I wanted to know whether your system also needs more than half of the internal storage space?

No for me its around 6GB, I assume it depends on the Apps and the amount of Apps installed?..or do you have GApps installed and in which Version?

1 Like

Same here, nearly 6GB for System, LineageOS 18.1 and Open GApps pico.

1 Like

I think I would try to flash TWRP permanently. :grinning:

What are you referring to? TWRP is on longer supported on the FP2 with LOS 18.1, so this might lead to issues….

I have open gapps and version pico. I have not installed TWRP.

Old system upgrade images can also take up space in that category. Check under “System Updates” and delete the old ones there.


I only have the latest update, I always delete the old ones after an update.

Joined the 18.1 Party late, after my LOS 17 got too outdated (wanted to switch to FP4 - but I fear this will take some time until I find it in stores). Installed it with all precautions (data wipe etc.). Works like a charm, thanks for all the hard porting and testing work!!!


Also for latest LOS18.1 build the following is still valid, right?

  • usage of LOS-Recovery instead of TWRP for flashing LOS18.1
  • if upgrading from LOS17.1 to LOS18.1 it is neccassary to wipe data (and of course caches)
    still correct? Could anybody tell me in detail, what the consequences could be, if I would not follow this recommendation (especially wiping data e.g. in order to keep all android/app data alive)? So what I should expect with a dirty flash, despite it is not recommended? (I neither have phone decrypt nor use the lock passphrase.)

Thanks. (Until now I could make every upgrade with TWRP and as a dirty flash with my FP2)

TWRP might work, however is still not officially supported and might lead to issues (incl data loss). I recently tried to restore a LOS 18.1 back-up on another device and that did not work. If you never had any Pin etc active to unlock the screen it might work without doing a factory reset in the LOS recovery. You will be stuck in a bootloop when it fails.