Lineage 17.1 - FP2

After today’s update I had to re-patch boot image for Magisk.
Don’t know why, but somehow the survival-addon-script did not get executed.
After patching everything works as before.

After a couple of days testing: Mobile Internet reconnects every time without needing to reboot :slight_smile:! Also, it seems that my WiFi is more stable, but I can’t be sure whether that is due to the patch. Thanks for all your work on this!


About the temporary fix.
I experienced the mobile data issue on Monday (before applying the patch) under two forms:

  1. Switching flight mode on and off or switching mobile data on and off causes a bug where the phone doesn’t manage to connect to 4G.
  2. When the phone was inactive after some time, it is shown as connected (4G icon in the status bar) but no internet comes through.

For both cases (I didn’t have them at the same time, one the morning and the other afternoon), rebooting helped.
Since applying the patch (Monday evening), I haven’t had issue nr. 1 at all! Though I had issue nr. 2 on Tuesday again :confused: Seems these two issues could have different causes then.
Next time it happens again (if it does), I will try to capture a log.

Edit: Typo


Did you update OTA in between?

No. I’m still on 2020-01-15 since last friday.
We’re going to try the workaround on a second FP2 and report.


Fixed the problem for me too, no more need for rebooting to get mobile internet working. Thanks a lot.


Ok, I had problems with my system, which probably led me to not applying the patch correctly. I will detail them in a later post.

So I reinstalled the system, restored my userdata, applied the patch, and so far it seems to work! I also don’t need to wait 20 seconds for my FP2 to connect to mobile data anymore.
Will report if ever I have the problem again.
Btw., patch applied on a second device and it doesn’t have the issue anymore as well.


Fixed my problem so far. Always mobile Internet when I wish it :rofl:


I pushed the changes. So next official build should have it.



Great and again, thank you for your great work!!

Updated to the 20210129 build. All good so far. Mobile Internet behaving as it should. Thanks Chris!

1 Like

I can only second that. My problems with this were rather sporadic before the fix anyway, but now the change from wifi to mobile data seems to be a little bit quicker, too - might as well be that it’s only the excitement about this issue finally being fixed influencing my perception :wink:
Thanks @chrmhoffmann!

1 Like

First couple of switching back and forth between offline - mobile data - wireless - flightmode.
Mobile data keeps connecting.
Many thanks to all who helped to track this down.
An off course to Chris.

1 Like

No. Thanks to the guys who spotted the real issue. Shame on me.

1 Like

Sorry if I report something negative: the patch is “fake” for me. It does show in the notification bar that I have 4G, for example, but when I check to see if I actually have an internet connection, it doesn’t work on any app. After a restart everything is fine again, without having changed my location.

I’m actually under the impression that wifi stability has improved as well with this update, although it might just be wishful thinking.
I don’t use mobile data at all, so can’t judge on that.

Since 20210129 Magisk doesn’t work anymore. I did the latest updates oft the Magisk Manager and Magisk itself some days ago. Manager still works, but there is no installed Magisk displayed.
So I downloaded the latest zip of Magisk by the Manager and tried to install it by the Manager also, but it fails with
! Unsupported/Unknown image format
! Installation failed
I rebooted the phone and tried again with the same result.

Can someone confirm?
Is it an issue of LOS or Magisk?
What can I do to make Magisk work again?

Download magisk, and flash it new with twrp…

Just updated to 20210129 and magisk is still working for me :slight_smile:
Magisk 20.4 (21.4 available)
Manager 8.0.7

That’s strange to me. What was going wrong on my system? The update to 20210129 seems to have destroyed the Magisk framework, due to Magisk worked fine before.

So I will flash Magisk new, as BrFabian suggested, and hope that both, Magisk and LOS will work properly after. But I’m a little bit afraid.