English

Lineage 17.1 - FP2

I’m on Free Mobile (France) and a quick search indicates me it apparently doesn’t.
@others affected and not affected by the issue, does your provider feature VoLTE?

1 Like

I’m not affected, I’m on Congstar (Germany) and the provider supports VoLTE since July this year.

2 Likes

FYI: I removed my SD card (which was not recognized reliably anymore anyway) approximately one week ago, and I have not had a “overnight reboot” since then.

Has anyone tried out to backup the LineageOS apps and data with SeedVault that has arrived with the latest update?

3 Likes

I wasn’t even aware Seedvault had arrived to Lineage already! Will check it out tomorrow.

2 Likes

I was asking because I would like to use a SD card to backup to, but I have none available right now. Guess I will buy one next week and report afterwards.

1 Like

Ok, I tried to backup through SeedVault.

First thing, I am using Shelter, so some apps are isolated into the work profile, and when seeing that there was a possibility to choose between personal and work profile (like in other places, allowing to have different settings for both), I thought I might be able to back up my sheltered apps as well.


Disappointment: when choosing work profile, it says “disabled by admin”. Shelter probably doesn’t support it.

Second, I thought it might have options for the backup, a bit like in OANDBackupX. But no so many actually (well, there are options to choose where and what to back up, I probably just like customization too much :wink:).

Third, as @Ingo stated rightfully when he tested it:

Most of the apps I would like to be backed up don’t allow a backup, but those I don’t care much about do…

Fourth, as @Ingo rightfully stated again last time:

I think it might be possible on a rooted phone through a hidden activity you can launch from e.g app manager, or from a terminal with adb shell as described in the link, but frankly it doesn’t seem easy, and as I often copy my system from my main to my backup phone, I hoped it would be easier and implemented in SeedVault, not just a workaround.

But fifth, I don’t know if the restore of a backup works well or not since the backup went to 90% quite fast, and then stayed stuck there for the last hour (probably because I have 126 apps and that’s too much and it bugs ? :man_shrugging:).

TL;DR: It seems really good, but I wouldn’t count too much on it for the moment, there’s still some progress to make :slight_smile:

4 Likes

Well, after I implemented it in the setup wizard, it was dead easy. During initial setup you are asked if you want to restore your backup and then it does just that.
At the point I was writing the post you quoted I wasn’t aware how the thing was designed to work.

I think I read somewhere why they chose this approach. IIRC it has to do with doing the restore at a defined point with a fresh system. And not any amount of time later after already having used the phone for a couple of days.
But yeah, that information is somewhat hard to find.

4 Likes

Sure, but only once you implemented it in the setup wizard. I have very little coding experience and wouldn’t know to do it, not even how to apply your patch. That’s why I said: it’s not easy :slight_smile:

1 Like

Sounds like the implementation in the official LOS isn’t finished yet.

2 Likes

First of all, I’m sorry but I didn’t read the whole thread if my problem had maybe already been described.

Did someone already experienced a strange behavior after installing an update of LOS? It seems like that since some months the first start is much faster as in the past, but after entering my pin and unlocking my phone, the update still doesn’t seem to be finished.
When I open an app which needs internet, like firefox, it starts without showing any interface and then after some seconds the LOS logo is shown again, but this time it keeps way longer than the first time. Afterwards it seems to work properly.

I’m not sure, but it seems like the app-optimization is not included any longer in the first start after the installation of an update, but is started afterwards. Well it’s not a bug, that leaves my FP2 unusable, but it’s still bit annoying and makes the update-process a bit longer as it needs to be.

Strange indeed. I never experienced this issue and haven’t seen anyone mentioning it in the topic. Did you try a factory reset, or reinstalling the OS?

Right now, I’m a bit stressed and need all of my time for finishing my thesis, but yes that could be a solution.

1 Like

Is there any news about the mobile data reconnect problem?

My FP2 with a current Lineage 17.1 can connect exactly once to the mobile data network. Once it is disconnected a reboot is required to connect it again.

Is there in the meantime a solution or workaround?

Hi everyone,

Does someone know if LineageOS has an (un)official forum regarding their OS?
I have some questions about the software, but I cannot seem to find a place where I can ask them.

Thanks in advance,

Wouter

1 Like

Hi,
I also searched for that… but no way, even on XDA forums…

The workaround for me is to enable airplane mode for min. 60 seconds and enable it afterwards.

1 Like

I haven’t had it for the last month, though as it comes back really randomly, I don’t know whether I can call it solved for me.

That’s exactly what I had at the beginning as well, then airplane mode started triggering it as well. Do you also observe the space in the status bar between the network and battery symbols as described higher in the topic?
How long do you wait once you switch it on again before declaring the bug was triggered? I observed that waiting a bit longer (1-2 mins) sometimes helped.

Though it doesn’t work if it’s the “hard” bug, does it? It only works if it’s the “soft” bug, doesn’t it? Airplane mode and switching mobile data off both triggered the bug for me.

Rebooting the phone :man_shrugging: :slight_smile:


Quoting any of their official phone wiki pages (e.g the FP3’s):

You can find assistance with LineageOS on our subreddit, or in #LineageOS on freenode.

My new recognition is that 60 seconds airplane mode are long enough to overcome even the “hard” bug.

1 Like

Does your data plan support VoLTE or not? I do not know if not using it will trigger the bug or not, I am just asking.

I tried that and that IRC channel is … well … I had more helpful IRC experience in other channels (on different topics). :man_shrugging: