English

Lineage 17.1 - FP2

I recognized, that when I choose to save pictures on the SD Card the stock camera app saves the pictures at Android/data/org.lineageos.snap/files.
Not at the DCIM folder.
And when I want to open the folder from within in the camera app it still opens the folder at the internal storage.
Can anyone confirm this two points?

Yes I tried. I confirm both points.

1 Like

This morning just a restart after deactivating the flight mode to get LTE activated. :frowning: That is annoying!
So the problem is still not solved or the Fairphone is just junk.

Steven

I can reproduce the problem that data connection (4G) doesn’t come back after flight mode.
It seems to be random problem, as it works from time to time for me (but most often it does not).

I have no clue how to fix it - asking around…

Chris

7 Likes

It is not your fault. :slight_smile:
Somehow there seems to be an incompatibility with the FP2 and Android 10.

Otherwise, very good work on your part @chrmhoffmann

Steven

1 Like

May I point people interested in LOS 17.1 who are capable of building the ROM to Has anyone tried Seedvault backup with Lineage 17?

My PC just isn’t powerful enough so at the moment I can’t try myself.

1 Like

I noticed that when you go in Settings → System → gestures, there are 2 options that quickly disappear before you can see them. I don’t know if someone else noticed, but I managed to catch a screenshot.


How come? What is it? Why isn’t it implemented in LOS 17.1? Or is it just me?

Unfortunately I had to downgrade to 16.1, because the flight mode is an essential function for me.

@chrmhoffmann: Based on the logcat’s I had the impression that the communication with the modem driver was not working properly anymore. Thanks a lot for your work!

1 Like

By now I reinstalled the old 8MP main camera, due to the 12MP wasn’t recognized anymore an all apps were stealthy linked to the selfie camera instead. The 8MP camera works fine.

Where can I get the latest build of 16.1? I also consider to downgrade, due to me there are too much issues with 17.1 yet.

At https://download.lineageos.org/FP2, go down and choose latest 16.0 build.

2 Likes

Thanks! But maba007 talked about 16.1. Was it a mistake?

It was a mistake. I am now on 16.0.

Hi @chrmhoffmann I think this patch is causing boot issues.
Log says:
07-29 12:57:42.520 0 0 I init : Received control message ‘interface_start’ for ‘android.hardware.gnss@2.0::IGnss/default’ from pid: 225 (/system/bin/hwservicemanager)
07-29 12:57:42.521 0 0 E init : Could not find ‘android.hardware.gnss@2.0::IGnss/default’ for ctl.interface_start
07-29 12:57:42.521 0 0 I init : Received control message ‘interface_start’ for ‘android.hardware.gnss@1.1::IGnss/default’ from pid: 225 (/system/bin/hwservicemanager)
07-29 12:57:42.522 0 0 E init : Could not find ‘android.hardware.gnss@1.1::IGnss/default’ for ctl.interface_start
07-29 12:57:42.525 0 0 I init : Received control message ‘interface_start’ for ‘android.hardware.gnss@1.0::IGnss/default’ from pid: 225 (/system/bin/hwservicemanager)
07-29 12:57:42.526 0 0 E init : Could not find ‘android.hardware.gnss@1.0::IGnss/default’ for ctl.interface_start
07-29 12:57:42.527 0 0 I init : Received control message ‘interface_start’ for ‘android.hardware.gnss@1.0::IGnss/default’ from pid: 225 (/system/bin/hwservicemanager)
07-29 12:57:42.528 0 0 E init : Could not find ‘android.hardware.gnss@1.0::IGnss/default’ for ctl.interface_start

I am reverting this patch and trying. I’ll update once done. Along with this, there are lot of HAL service errors in init at bootup time.

Coming to the connectivity issues, I observe that netmgrd is continuously crashing. Because of this, battery is also draining heavily as service is crashing and restarting. Could this be the root cause?
Also not only during flight mode, I’m never getting data connectivity.

Let me know your opinion on that.

2 Likes

Confirmed @chrmhoffmann that patch was causing bootloop. I reverted and it is working.

3 Likes

I cannot reproduce that. Building and booting it works fine.
GPS works.
netmgrd does not crash here.

Do you see this in the logcat?

01-01 08:40:03.148 311 311 I ServiceManagement: Registered android.hardware.gnss@1.0::IGnss/default (start delay of 132ms)
01-01 08:40:03.148 311 311 I ServiceManagement: Removing namespace from process name android.hardware.gnss@1.0-service.legacy to gnss@1.0-service.legacy.
01-01 08:40:03.149 311 311 I android.hardware.gnss@1.0-service.legacy: Registration complete for android.hardware.gnss@1.0::IGnss/default.

Did you make a clean build (remove $OUT directory)?

Chris

See, this is what is happening to netmgrd in my case
07-30 12:21:01.489 0 0 E init : updatable process ‘netmgrd’ exited 4 times in 4 minutes
07-30 12:21:01.490 0 0 E init : Unable to set property ‘ro.init.updatable_crashing_process_name’ to ‘netmgrd’ from uid:0 gid:0 pid:1: Read-only property was already set
07-30 12:21:01.491 0 0 E init : Unable to set property ‘ro.init.updatable_crashing’ to ‘1’ from uid:0 gid:0 pid:1: Read-only property was already set
07-30 12:21:01.493 0 0 I init : starting service ‘netmgrd’…
07-30 12:21:06.577 0 0 F diag : Invalid private data
07-30 12:21:06.591 0 0 I init : Sending signal 9 to service ‘netmgrd’ (pid 30277) process group…
07-30 12:21:06.592 0 0 I libprocessgroup: Successfully killed process cgroup uid 0 pid 30277 in 0ms
07-30 12:21:06.611 0 0 E init : updatable process ‘netmgrd’ exited 4 times in 4 minutes

The GPS HAL issue, I’ll continue to use the previous one over legacy. Since it’s a local build I’ve no problem with it.

Please look into netmgrd and help me fix it. Yes I even tried fresh sync and build. I don’t see any avc denials too. Next option is to try permissive and see if it works.

Since 20200724 I notice another issue. When I open the short version of the quick settings by wiping over the status bar and then tap on silent mode, I just can toggle silent mode, but I can not do any changes to it. After that I can not open the quick settings for some trials.
To do any changes to silent mode, I have to open the long version of the quick settings and tap on the settings bar under the silent mode tile.
Can someone confirm?

I don’t understand your problem… It has always been like this in android, you have to open the long version to do changes to silent mode.

What does this mean? Trials?

It should work when you tap the little arrow next to the text “Do not disturb”.
(Edit: It is suffice to tap the text itself…)