English

Lineage-16.0 (Android Pie) Nightly

For info, in case anyone runs into a similar problem:

After updating to the latest Lineage version a Cordova app on my device wasn’t working anymore and the log showed the following error:

`'file://' has been blocked by CORS policy: No 'Access-Control-Allow-Origin' header is present on the requested resource."`

After some investigation I found the following bug report:

Issue 991107: [SOLVED - see the Summary section] cordova app could not make XHR requests from a file at the first WebView76 run.

I checked the chromium-webview version on my device: 76.0.3809.89

According to the issue this is the version which has the problem. It should be fixed with version 76.0.3809.111.

Since Aug 2 the master branch for chromium-webview is used, so I guess we have to check here for the update.

2 Likes

After some searching, I managed to find APN settings for my provider. They looked very different from what was shown in the APN settings page, I wonder why???

Anyway, after applying the APN settings I found, my mobile data connection appears to be working!! I will continue testing for a while longer with fingers crossed.

Thank you @lklaus!

7 Likes

Another question… should the FP2 with LOS16 be able to use GLONASS satellites? I’m only getting a fix on GPS, I see that GLONASS is detected but not used

1 Like

Also using LOS16, and I do have connectivity problems as well.
After the first (clean) install I had to manually add the APN because LOS
wouldn’t implement the ones retrieved automatically.
If I don’t use the Internet connection for some time I get randomly kicked out of the Wifi.
Since the last update (17th August) I encounter random app freezes (Spotify, Facebook et al) did anyone do so as well? And if so, can provide a solution?

It depends on the smartphones cpu, which systems can be used. It is the same at my Galaxy S5 with Snapdragon 801: Glonas and Beidou satelites are seen but not used. Galileo satelites are even not recognised.

1 Like

Hi,
Looks like there’s a problem with today’s nightly update (lineage-16.0-20190824-nightly-FP2-signed.zip) : when rebooting after update, my phone was stuck on the boot animation for about 3 min and then automatically rebooted into recovery.
Did it 3 times before I eventually downgraded by flashing yesterday’s update (20190823) through TWRP. No problem, my phone started nicely after that, no data lost.
Anybody else experiencing this?

4 Likes

Since LineageOS releases are being built automatically and not beta-tested, problems can go unnoticed before a release.

As a recent example, you can currently still see in the Changelog that the build at 2019-08-14 11:12 UTC is now “no longer officially available for download”. And this was not the only case.

Exactly the same issue here: No boot after updating to 20190824. Had to sideload 20190823 to fix it. What is the correct way to report broken builds so they get removed? The GitLab bug tracker?

Note to self: Only update LineageOS when you’re not in a hurry (and have a PC nearby)…

1 Like

Or have a previous working version on your SD card just in case.
Or do a TWRP backup before each upgrade…
Things we should but only rarely do… :wink:

Same issue. Luckily - or so It hought - I had a previous TWRP backup from a nightly in July.
Did a TWRP restore, it says it succeeded - but doesn’t boot. Did a restore to an older TWRP backup from April - doesn’t boot. Keeps stuck on Fairphone boot screen, no LOS 16 boot animation.
I wonder why I bother to make TWRP backups, if they simply don’t work.
Now I have to try and connect to my laptop and learn again how to sideload, pfff…

Nu luck restoring my backup. Had to reinstall 20190823-nightly.

Discovered a tricky LOS 16 bug:
When you want to restore the google apps and settings , you have to confirm with the pattern unlock of the previous installation. BUT, google only shows a 3x3 grid pattern lock.
If you had a 4x4, 5x5 or 6x6 grid pattern lock, you can’t unlock the backup with a 3x3 grid!
LOS makes different grids possible, but at least should show a big warning that this breaks the backup restore!

2 Likes

Both not possible because SD card is formatted as adoptable storage and phone is encrypted.

I had this once or twice when still playing around with different OSes.
What worked for me to get it to boot was just installing the corresponding LineageOS build again over the restored backup.

Yep, same here.
(20 chars)

That’s a bummer, I agree.
Funny the TRWP backup doesn’t work. I thought about trying one I’m made in July, but decided for the sideload first which worked, so didn’t need to try the backup

Had the same problem. The 20190823 version is the last working version for me.

1 Like

Same problem here too. I can confirm that installing lineage-16.0-20190823-nightly-FP2-signed.zip via sideload resolves the boot problem.

But who is brave enough to test all future updates to find out which version will work again. :wink:

1 Like

At the current daily update schedule, nobody, I suspect.
With some enthusiasm, weekly updates are doable.
With some laid-back realism, monthly updates are doable, and Google’s security updates only come monthly.

I can confirm the boot problem. Since version 16.0-20190824-xxx.zip the mobile does not boot up anymore …

Steven

Same with my phone. It reboots to TWRP asks for a password but my encryption-password doesn’t work.