English

Lineage-16.0 (Android Pie) Nightly

As the 16.0 isnt yet stable and there havent been any updates to 15.1 since the beginning of May, will there be any 15.1 builds with upto date security patches?

16.0 is official and works in general.
Which specific problem do you have or are you referring to?

In my understanding LineageOS officially only supports the current major version for a specific device, so … officially from LineageOS … no.

But it’s Open Source, enthusiasts may still build 15.1 themselves with whatever they are able to add to it.

2 Likes

WU runs fine on 14.1 now - at the time I wrote my question, it simply was not visible in the play store (and direct link just showed “not compatible”).
A few days later, I looked again and it showed and installed fine.
Same on a Galaxy S5 running LOS16 :slight_smile:

Just curious … You were running 15.1 already, did you downgrade to 14.1?

Did not know that official builds were not allowed once the version had been bumped. That’s a shame because 16.0 being official does not mean 100% finished, and “works in general” does not always mean daily driver. Is there a page which lists the current problems? Yes I am being cautious

It’s not so much a question of allowing it, it is just not being done by LineageOS themselves. I suspect reasons like resources and focus.
You are perfectly allowed to build your own LineageOS.

Almost no halfway current piece of software ever is 100% finished.

That’s why I asked for a specific problem, because quite a lot of users here use 16.0 as their daily driver, including me (LineageOS for microG, though, which is based on official LineageOS).

Cautious concerning a version jump, yes, but rather less cautious concerning security holes :wink: .
That’s legitimate of course, we all have our own priorities.

If it helps, I tend to check whether the basics work when I install a new build. You can have a look here.
If you miss a basic check you would like to see, feel free to tell, I’ll see what I can do.

4 Likes

does anyone here have the impression that the phone heats up more often than in LOS 15.1?

I do. I also have the impression that there is a memory leak, as it’s lagging more and more after a few days, and launcher seems to restart often. Maybe the patches from jul 1 (power profile) help a bit, but this week I’m on holidays and a bit cautious

1 Like

For me it does not heat up more than on the previous LOS builts. Although it gets pretty hot in general, as we all experienced.
I also have the impression, that LOS 16 is the smoothest of all LOS versions so far.
I do have no more reboots, and it is very stable and relative fast on this hardware.

1 Like

same here

using Microsoft launcher currently but it was quicker on LOS 15

Don’t remember that it heats up that quick when only reading in a single news app

I didn’t get this impression so far, but perhaps I’ll try to be more alert about this in the coming days.
At least I had no reason to look for something so far, phone runs totally fine.

I’m used to the phone heating up e.g. when using OsmAnd for navigation and when using JavaScript-heavy stuff in Firefox, especially in multiple tabs. This behaviour wasn’t introduced with 16.0 to me, I can’t even remember anymore when this would have been any different for me.

I can’t confirm this on my phone (LineageOS for microG, though).
Could GApps or Apps play a role?
Do you use Trebuchet (the stock launcher)?

Yeah, could totally be an app thing, though i didn’t change my app profile. But apps get updated also… I’m on gapps, which i didn’t (re-) flash for some time, now. But still, it works fine for me, except those quirks, and it is probably more stable, I also had no reboots up to now, which i had before, even I’d very seldom.
Re memory: I’m using Nova, and i had the occasional restart of the system_server, because of memory pressure.

that caused/causes the phone to heat up in LOS 15 and 16

not currently, is Microsoft but I can switch to compare.

no idea, how to track/debug and that happens only when the screen is on, so BBS is not an option isn’t?

Hi,

I saw a note of the minimum brightness being too high, I have also noted this, but is it also so that the maximum brightness is lower than before? Could also have been too sunny in Sweden lately…

Otherwise it works fine, but, I have also noted slightly higher temperatures, charging and using the phone is almost not possible depending on the app(I know it could also be the app itself, but it was less of a problem before 16.0 in my experience).

1 Like

No, the maximum brightness is still 255 (maximum possible). At least from the /sys/devices/mdp.0/qcom,mdss_fb_primary.171/leds/lcd-backlight/ files.

Unfortunately I don’t see any such file for minimum brightness, which is a shame…

to do troubleshooting we need to agree how to benchmark all this

1 Like

Not really, some applications just use a lot of resources such as navigation.

Though it has rebooted a few times I also removed the paper hack a while ago. I’ll have to put that back first.

In case you haven’t seen this.

Chris

5 Likes

No, still running 15.1, it was a typo :slight_smile:

1 Like

but some application haven’t changed around the upgrade but causing more heat now.