lineage-15.1-20180903-nightly-FP2-signed.zip feedback thread

See https://download.lineageos.org/FP2/changes for the changes, Download is here: https://mirrorbits.lineageos.org/full/FP2/20180903/lineage-15.1-20180903-nightly-FP2-signed.zip

It seems the updater isn’t throwing an error anymore, which was the case before the 20180827 release fixed it, but I’m now running into the problem that a reboot to recovery isn’t possible (a known bug) and so I still need to enter TWRP manually. But after I did this the update seemed to be queued and started directly. I’m on an encrypted FP2 by the way.

I can confirm that: once manually entered recovery the update picked up automatically. But as far as I know the reboot to recovery issue only affects phone with the new (main) camera module.

Advanced reboot with 20180903 on my FP2 finally works - that’s good news.

Edit: Purchased March '18 - should be the new camera module. Power off doesn’t work (no change there).

  • Reboot into recovery (new camera module) does not work
  • SIM PIN does not appear after reboot. Workaround: Flightmode off- and on.
  • Deactivated SIM slots are reactivated after reboot.
  • SIM slot deactivation does not work: Sending an SMS to a SIM which is in the deactivated SIM slot still arrives.
2 Likes

Sometimes not able to enter PIN for 2nd SIM Card. Input “window” just disappears while entering.

@jhohn: I noticed that the PIN-Entry for the 2nd SIM gets “whacked” by the Lockscreen. Now I’m waiting for the PIN-Entry to appear a second time before entering the PIN.

5 posts were split to a new topic: lineage-15.1-20180903-microG-FP2.zip feedback thread

Most of the time this workes but sometimes it does not pop up again. Also Flight mode does not help then, only after a reboot it comes back.

update went smooth! Interestingly I didn’t need to decrypt (put in the password) in TWRP…!

Only the system and boot partitions get touched by OTA updates and nothing is done with your data partition.

1 Like

yeah I was just surprised. As for LOS 14.1 updates I always needed to give my password in TWRP

Be carefull with imstall xposed 90-3beta, ends in an endless startscreen. Intalled lineageOS new and will investigate a bit moore…

Same issue for me !
@chrmhoffmann shall we fill a bug report on our FP2-LOS bugtracker or is it something not-device related?

Hi @Singulus + @Ingo

how do you enter recovery manually? Or how do you remain in bootloader? Anything I’ve tried for either didn’t work out?!?

… and the same for Vol - for Fastboot mode?

1 Like

Hi @AnotherElk

in fact, yes. No power + Vol+, no power + Vol-, no ‘adb reboot bootloader’, nor ‘adb reboot recovery’ works. They all reboot into OS.

Well, ADB is no surprise if you have the new camera … Edit: I guess.

But the buttons not doing the job? Wow. Do they even work as volume buttons in the OS?

Why? I couldn’t detect an open issue for this in any of the open threads. Instead, someone else opened a new thread regarding same issue.

About camera: Ok, I could try the old camera (looked for it already, but didn’t find yet).

Unfortunately not, I tried adb only after buttons didn’t work out but booted into OS as well. They’re working properly as volume buttons when not pressing power.

As I see it, ADB is partly about remote-controlling Android.
If Android reboots into the OS instead of into the recovery, I guess ADB calls the same function Android uses and has no clever knowledge of another way of rebooting.

I could be wrong of course, I guess there’s an “I guess” missing in my earlier post. Fixed :slight_smile: .

You can simply disassemble the new camera without assembling the old one. The phone works without the camera.
(I had to do this for encryption, which also doesn’t work with the new camera yet.)

Amazing. I have no clue how that can be and will be very interested in how this all plays out …

If all else fails, here’s something interesting …

http://www.mediawiki.compulab.com/index.php/Android:_Fastboot_setup#Forcing_fastboot_mode

"Normally a bootloader will proceed to booting a valid boot partition. In case there is none, the bootloader will fall back into fastboot mode.
There are a few options to force fastboot mode despite valid boot partition:
[…]
By invalidating boot partition. Destroy boot partition signature, issuing on the device (in either Linux or Android command line):
# dd if=/dev/zero of=/path/to/boot/partition bs=1 count=1"

1 Like

Thank you very much, just disassembling the new camera was too easy to hit on it (correct english?) or just try it out :wink: Also the idea with invalidating the boot partition is very interesting for more persistent problems! :slight_smile:

I’ve now successfully replaced the new camera and the phone boots nicely into recovery, and bootloader respectively and I could go flashing again :slight_smile: