LED notification not working

Hello everyone,
I’ve got a problem: I don’t get any LED notifications when recieving messages (Whatsapp/Telegram) or calls. I tried to trigger the LED with an LED Tester app, but it’s not working regardless which color I choose.
The LED is fine though, it’s red while charging (since the update this afternoon its yellow) and it changing to green when fully charged.
I was hoping this would be fixed with the “only red light”-bug fix in the current update (although my green LED was working fine when the phone was fully charged since day one). But neither the update nor a complete factory reset could fix this issue.
Maybe I’m missing something, is it possible I somehow deactivated the notifications? (Apparently not, since there are no global options for LED notifications?)
Thanks for your help
Philipp

2 Likes

The LED Tester app you linked to does not work for me either, the LED just stays black.
In fact it seems like after the update I don’t have LED notifications for mails at all… that is really weird

I´ve got the same problem. The LED notification doesn´t work at all when recieving messages or calls. LED Tester app didn´t work neither. I could live without it but since the update had the idea to fix it i´m curious if i miss something here. Any ideas or suggestions?

Hi everyone.

I shut down my phone and removed the battery. Now the LED Tester app is working for me :slight_smile:
As mentioned in the app’s help, I have to actually put the phone to sleep and wait a couple of seconds before the LED starts lighting up.
I’ll have to wait for some new notifications to see if they are working again, too.

Hope this helps!

I solved the problem before this update by rooting the phone and use the well known workaround: https://forum.fairphone.com/t/notification-led-only-has-red-light-fix-will-be-in-next-update/

After the update yesterdayt I thought first: everything is fine - there are different colors of the LED depending on charging or battery-status. But after rerooting the device or after rebooting I recocnizied one problem is the same as before: There are no LED-notifications.

The reasen seems to be they DO NOT fix one problem:
owner and group of /sys/class/leds/blue/blink and /sys/class/leds/green/blink are still root instead of system.

Therefore I put the shell commands
chown system:system /sys/class/leds/green/blink and
chown system:system /sys/class/leds/blue/blink
at the end of /system/etc/init.qcom.post_boot.sh (just before the last comment(# Start RIDL/LogKit II client))
A little bit dirty - but it works!

BE CAREFUL! I do not know what will happen if something goes wrong and the last command in this script will not be executed - anybody?

1 Like

Hi all. Same problem, only battery charging gives yellow and green notification, battery removing does not work, no time and no capabilities to do this rooting stuff. I am not amused.
fortuna

Hey, the battery removal thing didn’t work for me either. I haven’t rooted my phone (and don’t want to) so I couldnt try the other suggestion.

Hey there,
got my LED notification finally working. Seems to be an android setting problem, but I’m not sure.

First I downloaded this app which shows all settings and indeed the entry “notification_light_pulse” was set to 0, see screenshot:

Then I wrote a little app (took me all day, since I have no experience in app development whatsoever), that sets this entry to “1” with the code-line:
Settings.System.putInt(getContentResolver(), "notification_light_pulse", 1);

Then I used the app linked in my first post, put my phone to sleep - and nothing happened. But after a couple of minutes I noticed the red led started blinking - this app seems to have a huge delay.
I tried another app - if I test the LEDs with this app now every color works fine. Additionally I called my phone from my landline and a few seconds after the missed call, the red LED started blinking.

The only thing weird is, that the LED seems to be very slow. Even if I set the flash rate in the light manager app to fastest (or use some very fast personal rate like 5 ms on, 5ms off) the LED flashes in a 1s / 1s rate - is this normal?

I’m not entirely sure, if the LED issue was fixed by the battery removal yesterday (maybe I was to impatient then, and didn’t wait long enough - although I waited for one or two minutes after putting the phone to sleep) or me changing the pulse_light setting.
So maybe some of you could check your notification_pulse_light-setting with the display system settings app

3 Likes

I can now also confirm that SMS notifications trigger white LED, and mail notifications with “K-9 Mail” also work (with my own chosen colour).
Recharging in progress (red) and finished (green) already worked before the update, if I remember correctly.

I found the problem in my case was caused by flashing the old boot.img when I was rooting the FP. After flashing the right boot.img everything is fine!

1 Like

In my phone the entry “notification_light_pulse” is set to 0 as well. I would describe my experience regarding to writing apps as 0 as well. So, how did you write the app as you mentioned that you never did this before neither?

Hey,
first of all: I was definitely the false settings. If I set notification_light_pulse back to 0, there are no more notifications on my phone.

I actually downloaded the Andoid Studio and modified an hello world example. Since I’m familiar with Java it was no too hard to get started.

I build an apk, so you can install my app and change your settings as well (Download from my dropbox) - the app needs the permission to write settings and you need to enable “unkown sources” in your security settings. Use this on your own risk, although I assure you it is just changing the notification setting.

5 Likes

Thank you phiwa, i tried your app and it works fine! I hope you didn’t give anything else with it :wink:

1 Like

First of all, thank you so much for sharing! This sounds really great. I´m trying to get it fixed this weekend and i will give you a feedback by then. Thanks again!

Hello Phiwa,

are you able to solve the issue of the Battery Loading LED notification dominating the other LED notifications, either? You know, the issue where e.g. a Missed Call LED notification is not shown while the LED shows the Battery loading. I would appreciate really a lot!

Kristof

2 Likes

Thank you so much Phiwa. If you ever come to my place called Pfalz, i will invite you to a glass of Schorle :slight_smile:

1 Like

Hey,
I got the same problem, but I have no idea how to fix it. Not even sure if its a bug or a feature?

@fortuna27167 Sehr gerne, ich behalte das mal im Hinterkopf, falls ich mal in der Gegend bin :wink:

Philipp

While not having the problems you described with no notification at all, I do have the problem of the slow blinking frequency, which directly started after the Update 1.2.8.
I already asked in another thread but no help until now (see below).

I noticed it with the messanger Conversations (see link below) and I noticed it as well with the app “Prof. Reminder”: the LED isn’t influenced by the pulse length settings.

And additionally to a very low frequency of blinking (~once every 3-5sec, disregarded the settings), the LED is just slowly rising, instead of a real, digital “blink” (as it was for sure before the update to 1.2.8 for the Conversations notification…

Can anybody bring light to this behaviour?

I have rooted the phone (and used the updated boot.img) and have GravityBox running.

Link to my other post about this:
https://forum.fairphone.com/t/fairphone-2-os-version-1-2-8-6-april-2016/16328/75?source_topic_id=16363

1 Like

Hello Phiwa,

if it was a feature, it would be a really bad one! Actually, noone needs a permanent notification of their battery being low or loading, do they?
It seems that the LED issue(s!) are far away from being solved. Does anybody know wheather the Fairphone folks do share this perspective? Are they working on it?

Phiwa, thank you so much again! I installed your app today and now everything works just fine.