Keeps asking which launcher to use

You can if you install another phone app and set that as the default. I’ve done it myself just last week.

I’m on FP4 btw.


Filed support issue #538504.


Have you tried a factory reset as that is essential in basic resolutions of the OS misbehaving an almost certainly soemthing Fairphone will ask you to do.

Factory reset > Install alternate launcher > Try for a ‘while’ before installing anything else.

What could Fairphone do differently to ensure it isn not a launcher issue, and hence why would a user not do it themselves. I’m pretty sure Fairphone have their hands full of hugeley more imporatnt issues.

Sad maybe but no doubt true.

I don’t think the launcher itself can produce this issue. As with any other standard app, the OS is responsible to ask for, and to remember the app, the apps themselves can only declare that they can handle a certain task but they cannot overtake control.

In my case it clearly began with an OS update (not the latest one) but after setting the standard app anew the issue was settled. This isn’t the case this time.

1 Like

Yes that makes sense but the instalaltion of the app prompts the OS and if there is any software debris from other apps it can upset the smooth running of the OS

1 Like

hi again, I started seeing a pattern that issue occurs around my Digital Wellbeing bedtime settings (evening and morning) and started suspecting the app. I’m not clear how much this is a standalone app and how much part of the system settings, but what helps me is to go to Google Play and click ‘Uninstall’. It will not uninstall it fully, but will leave ‘Update’ button available. I don’t click it, but at some point Google will update it again. Until Google does, I no longer get launcher prompts.
The last update was released on July 28, 2022 that could match with the timing when started to see the issue.

If anyone else could confirm observing the same.


Nice work finding that, let’s hope you’ve nailed it :hammer:

Do you want the Digital Wellbing app? It can be ‘removed’

Hello Fairphoners Out there, I have the same launcher-asking-problem here in my FP3+ (A11/8901.4.A.0013.4) since a safety Update at June 5th this year.
My Launcher: Niagara pro 1.6.5.
But this issue occurs only after setting up the alarm timing function in the clock app! When I have finished the setup of the alarm timer and push the “home” Button, this meanwhile well known popup appears.



I disabled the Digital Wellbeing app (it can’t be removed on my phone) and the launcher prompt hasn’t appeared for several hours. @ajya, thanks for the tip!! I hope it stays that way and will post again if it turns out the fix isn’t permanent.

Edit: The latest review of the Digital Wellbeing app on the Google Play Store I see says this:

I thought it was an Android update issue, but after some research it turns out that the latest update of this app has caused an ongoing and VERY annoying problem. Ever since the update, every so often when I go back to the home screen it keeps asking me to choose the default launcher. My dad has the same issue on his phone now too. He’s on Android 10 and I’m on 11. Officially getting rid of this app for good!


Just a note or reminder that it can be removed if you want, which may avoid updates enabling it.

I ‘uninstalled’ it in April 2021 and no OS updates have interfered, I have also disabled Google Play Store via the Settings on the phone.

See the second and ninth posts :slight_smile:

I can corroborate that the update did not cause the issue. I still have not upgraded to the latest update. This is promising, I’ll look into this solution.

1 Like

When I go to options menu of Quickstep and set the default launcher to Quickstep and then back to Nova, the problem disappears (for several days now). However, only until a reboot, what I hardly ever do.

Looks like the enemy is located and the problem solved.
Launcher won’t remain the default launcher just automatically
I just give the post at reddit 1to1

Disabling Digital Wellbeing app works for me. Thank you @ajya. And thank you @berndi for providing a set of steps to reliably reproduce the bug (so I can know it’s gone).
After disabling Digital Wellbeing, the bug no longer occurs after setting an alarm, nor upon restart.

Thank you everyone for your contributions.


I’ve frozen Digital Wellbeing with Insular now, so we’ll see if that fixes it for me.

Absolutely ridicidink that this happens. Makes me dislike Google even more :frowning:

Whereas I have little room for google, no account etc. many of the upsets maybe more down to the programmer’s lack of awareness than an intent to mess will the launcher. ??

You’re probably right. However, Google has a history of (intentionally) screwing with Firefox to get people to switch to Chrome. Google is a weird, evil company and I just don’t give them the benefit of the doubt anymore.

Ah! so Google are very good at being bad, but can someone be very bad at being good.

Nope! google is just one of the highlights of human consumerism and we are all equally guilty :slight_smile:

I’m sure no human can be good at being good, but there’s always the possibility of being bad at being bad.

Whould be very interested in the outcome! This issue really sucks over time :frowning:

I also confirm that digital wellbeing seems to interfere with the launcher. I deactivated it and had no prompts but then reactivated it, and when I switched on sleep mode it had the issue. I let Fairphone staff know about the fix too. Thanks for the sleuthing everyone!