Jailbreak Root found on Fairphone

Wonderful: my bank wants to implement 2FA for all transactions. I have to install SecureGo on my mobile FP2.
I managed to download the app without google getting access to my mobile (hopefully).
Finally I found an apk downloader site.

NOW I cannot start the app because it has found a jailbreak or Root on my mobile.
But root is disabled.

Any hints ?

If I understand you correctly…

…you are trying to reduce the impact Google has on your phone. Did you by any chance remove some of the Google Apps from your device in that process, like for example Google Play and the corresponding Google Play Services? :thinking:
Or are you running a custom ROM without GApps installed at all?

Both of those case will prevent your banking app from working because it’s checking for the existence of the Google Play Services and it possibly checks if your phone passes SafetyNet as well.


I use the app without issues on my FP3 with all Google Apps deactivated, except for Google Play Services and downloaded the App via the Aurora Store.


Banking Apps are known for their supposedly strict security requirements, and the messages about checks for those requirements failing tend to not say what’s wrong exactly.

That would be my guess as well, @andreas1 please provide detail on which OS you use and how you avoid Google.
Else it could also be a detection of an unlocked bootloader. The bootloader of the Fairphone 2 comes unlocked and can’t be locked.


Great news :frowning:

I have no GApps at all on my fairphone. And wanted to evade it right away.

FP Open 22.02.0-rel.0 is my OS.

I asked my bank again today. And I have this TAN generator device which never worked properly via my Ubuntu PC. When I get this started I can forget about this google app… hopefully this works.

All Raiffeisen banks have implemented 2FA with SecureGo now. My bank calls itself Ethikbank…

For me it’s an insolence forcing people to use Google after all these discussions about tracking of GAFAM.

My company uses MS which sends me an SMS on my mobile in order to log in on the company laptop when I am doing homeoffice.

By the way: how do I „deactivate“ the google apps as Yvonne suggested ?

When you use Fairphone Open, no Google apps are pre-installed.
A note for the future: If you still need to use some apps that are only available in the Google Play Store, you can use the Aurora Store, which you can find on F-Droid.

1 Like

If you would have installed GApps, you could deactivate each app through settings-apps. Or you could even deinstall using adb.

OK - thanks to all of you… I’l see what I can do… all other banks also use securego… thanks to google… incredible… :frowning:

If you want to use a smartphone for banking. That’s an if.
You can choose not to and use a simple TAN generator for online banking with a computer. Sounds like you have a cardreader for computer use? Even that wouldn’t be necessary for chipTAN or photoTAN.
(Except with banks not offering sensible options because they don’t want to have informed customers … wait a minute … over time we’ll be doomed :scream: .)


don’t forget to tell your bank that you’re a dissatisfied customer because of this. If enough people complain (i.e., announce they’re informed, according to @AnotherElk), maybe they change their policy. If they don’t get complaints, they never will.

When I complained with GLS Bank, I ended up with a technical person who understood the complaint and offered another route (no smartphone banking, though).

Danke & Grüße von

1 Like

tried to change to Triodos … same shit
then I informed netzpolitik.org and got this hint:
Digitalzwang melden: | Digitalcourage e.V.
where I entered my complaint …



I don’t know what this app is detecting. To fix our issue I’m gonna give a universal fix

  1. Root with Magisk
  2. Install GitHub - kdrag0n/safetynet-fix: Google SafetyNet attestation workarounds for Magisk to pass safetynet check(Some apps use safetnynet check to do “root detection”. Or some case just locking bootloader fix it too
  3. Install microg from microg.org. This is pretending to be google in all ways possible so your app will think you have google and will work

@andreas1 What a nice hint! I’ll send that to everyone! Thanks a lot for sharing!

Danke & Grüße von

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.