Issues with the forum

Yes, I’ve got that problem too. Firefox stays at “Connection not secure”. Try reaching the forum via private mode, it works totally fine, at least for me. I’ve cleared browser data but the problem persists.

I still think it’s somehow a Firefox issue on Android. Opening the forum parallely in Firefox on my notebook works totally fine. Funny enough just yesterday I experienced this when trying to open, but it’s mostly the forum making trouble.

1 Like

Ok, will try that the next time it’s happening.

Yeah it happens only with Fennec and I think so far only with the forum. I can use Ecosia when it happens, without issues…

I have the same issue on regular Firefox (and Firefox Nightly).

Sometimes force-closing and cleaning the cache helps, but sometimes I have to switch to Chromium, which always works …

Since they also use Discourse as a forum software, might that have something to do with it? :thinking:

1 Like

Yes, probably a combination of Firefox related browsers and discourse forum. I’ve not had the problem yet on FP4 using Vivaldi (but neither on mint using Firefox).
Hope it’ll disappear after next discourse update which will probably happen soon.

Ok, private mode didn’t work for me. Bummer. An additional browser only for the this forum? Actually I like my app drawer clean and orderly. I will look for another solution, or maby it’s time to look if an other browser fits my interests.

Yes, but only with the Android Firefox app, not with the desktop version. Including accessing the Forum as a PWA. I don’t think I’ve noticed this problem with other sites, and ascribe it to the Discourse software. It’s rather annoying.

Can you reproduce the problem in Discourse safe-mode, too?

Good question Volker. Since I don’t know quite what’s causing the problem I can’t reproduce it at will and for that reason, I had so far refrained from reporting it. I’ve bookmarked Safe Mode and will try it next time it happens.

1 Like

Yes, for me it happens in safe-mode too.

edit: Maybe better try this link, otherwise you will land on a page asking you to configure safe-mode first:,no_plugins
edit: unsurprisingly no difference…

1 Like

Thanks for testing it! That’s good to know - so it’s obviously not related to the FP Discourse configuration…

I just installed Firefox Nightly and set my UserAgent to Chrome. Let’s see if this does any difference.

edit: Nope, it doesn’t.

There is the possibility to activate Remote debugging via USB in the settings from Firefox on Android. Afterwards, it is possible to link the phone via Firefox Desktop in its about:debugging tab. Like this, one can access the Development Tools for tabs on Android. Maybe this will be helpful, of course the problem didn’t occur since… :roll_eyes:


I think I got at least a step closer. Sometimes, the connection gets blocked with the status NS_BINDING_CANCELLED_OLD_LOAD.

You know an error will be fun to understand if even Google just delivers five results and three of them are the source code where it’s getting thrown… The other two matches aren’t really helpful, too. - mozsearch says:
# When browser.tabs.documentchannel.parent-controlled pref and SHIP
# are enabled and a load gets cancelled due to another one
# starting, the error is NS_BINDING_CANCELLED_OLD_LOAD.

I noticed that on my phone, HTTP:// is likely to produce that behavior, while the HTTPS version doesn’t fail that often. If I don’t open /latest, but just HTTP://, it’s less likely to fail even with just HTTP.

You could try to set HTTPS-Only-Mode in the settings and have a look if this at least reduces the problem. And maybe be so kind and play around with HTTP and HTTPS before to check if my observations fit in general.

1 Like

I have the same, mostly with Discourse fora, but infrequently also other sites. The Firefox Mobile changelog mentioned this problem a few times, that they fixed a TLS issue that caused this. But that’s a while back now. I also reported it to Mozilla since it is happening now for some time already.


Quick update: this morning (26/02) impossible to access the forum website at all, on a FP4 using Firefox. Other sites and other Internet services could be accessed. Closing FFX from the Switch apps list didn’t help, nor did the Discourse /?safe_mode option, nor did use of private browsing.

This evening, from a different Wi-Fi network, no problem at all.

Thanks Uppercase for filing the bug with Mozilla. Personally I don’t think I’ve seen this problem on a Windows system.


I noticed the same problem with the built-in browser of the discourse hub app. :sweat_smile:

OMG! I just noticed this has been fixed, apparently recently! :partying_face: :+1:
After all these years … I’ve lived to see it happen! :smile:
(apparently a Discourse bug as it’s also fixed over at

1 Like