Issue making apps work with microG

I got my FP2 and I installed Lineage directly on it. everything is working fine. I installed the microg/unifiedNLP as i want to avoid any google services.

In some apps I get some warnings like “Slack won’t run wihtout google play services, whic are not supported by your device.” but still the app works well. however I havent i havent been able to make Whataspp work. I download the apk file from their website. it starts well, i set my number and i get the activation sms and then i get the following warning

“com.whatsapp.appshell relies on google play services, which is not supported by your device. contact the manufacturer for assistance.”

and after that it keeps in “looking for backups” and never goes from it

I tried disabling the Privacy Guard but no difference yet.

does anyone else has this problem?


Can you describe how you installed microg? And could you post a screenshot of the output of the microg self-check?

1 Like

If you don’t need microg… I don’t have it, and WhatsApp works fine without any Google.

1 Like

I installed using TWRP queing the zip file after the LOS file. Following the instructions of the LOS with OTA updates here. It worked well.

I attached the result of the microg self check

That makes it pretty clear: Signature spoofing is not available.

You can install Tingle: to enable signature spoofing.

However, through your installation method, you haven’t installed the latest gms core version and some apps might still complain about that. You can try to update gms core through fdroid (which never worked for me due to incompatible signing keys) or you will have to install the latest gms core version as a system app manually… If you need instructions for that, let me know.

1 Like

Thanks! I’ll install Tingle, is there any app in Fdroid? I couldn’t find any way to update the gms core there. So yes, any help is appreciated.

For tingle there is no app in fdroid afaik. You need to follow the installation instructions on the above mentioned website… For the instructions concerning the latest version of gems core: I will post them later because I’m not at home right now and typing them on my mobile might be tedious :wink:

1 Like

You mean my flashable ZIP? I think I can help you, then.[quote=“Jochen17, post:5, topic:32452”]
(which never worked for me due to incompatible signing keys)

Only possible signing key mismatch is trying to update microG with UnifiedNLP or UnifiedNLP with microG (thing which you should not be able to do, anyway). Read more about that here: Strange F-Droid microG Services Core update behaviour

Before we continue, i need to ask some questions to make your e-life simpler. microG is a great opensource framework, but it has ineludible user-experience caveats regarding app and OS updates (the need to patch the OS with Tingle with every update, and to manually update microG when needed).

Why did you chose microG and not UnifiedNLP?
If you only need network location, go for UnifiedNLP. It’s simpler. Just make sure you don’t need Google push notifications (WhatsApp doesn’t need them) and you don’t use any app that relies on a Google map embedded.

If you choose to use UnifiedNLP, then don’t read the rest of this message and ping me to help you make the change from microG to UnifiedNLP.

No. Signature spoofing patch need to be done with a computer. Tingle is a command line utility for computers for patching Android devices. Check the official Tingle guide:
Please note that you need to re-patch your device with every system update.

Disclaimer: there are in fact some proof-of-concept on-device patching utilities, but they take so much time and/or are not reliable or untrustworthy yet.

F-Droid by default only updates the UnifiedNLP app. You need to add the microG repo to F-Droid to get microG updates (although you need to manually select every update, because they are not marked as stable). Check instructions in the official microG site (, or right from your phone click this link and F-Droid will popup:

1 Like

Yes!,I downloaded the microg, the recommended one. Why did I choose that one? Because it was the recommended one. Im not completly aware of my choices. First time doing this things so im following success cases. What would I miss having only the UnifiedNLP?

Not ideal, but i can live with that.

I already added the repository and updated the gms core

Thanks for all the discussion and clarifications.

A post was split to a new topic: Issues updating microG apps in LineageOS

Hmm… ok! I understand your position now. I’ve reworded the recommendation to better reflect what I wanted to recommend. From your first post, I can extract that you need Gobble Push Notifications at least to get Slack notifications working, so this justifies the whole patching thing. I think microG fit your case better, so you chose well from the beginning.

Did you succesfully patched your device with Tingle already? It’s the last step you need to do, then (after a reboot) your apps will work and learn to be less intrusive, :slight_smile:

Im on my try, but dealing with some errors:

If i want to try with manual then it asked me for a specific file.

Oh. Try to Mount -> System (and make sure Mount system read-only is disabled) in TWRP before running Tingle

the error persisted. should I have MTP enabled or disabled? i tried both anyway…

It shouldn’t matter.

Could you run adb devices in your terminal (the black window)? It may be a Windows-related issue (I don’t run Windows)

that works ok

   C:\Users\osilv\Desktop\ADB>adb devices
    List of devices attached
    f580b700        device

From your above screenshot, you’re running Python 2, but AFAIK Tingle requires Python 3.
(To be honest, this is a blind shot, because I’ve always ran in with Python 3 in my machines)

I think is something with the drivers, because even when i have installed the universal drivers im not being able to browse on the phone, and probably Tingle either.

If I choose MTP or PTP I can browse those things, but if I choose charging mode then I dont see anything. But i have tried Tingle with all modes without success.

I honestly don’t know what happens. If the System partition is mounted in TWRP and ADB is working, then it doesn’t need more and should work right away (I guess it shouldn’t do the “Automounting /system” thing, because it should be already mounted). Yeah, it need Developer options enabled and root access for ADB, but read my Edit below for a simpler method.

ADB is a logical interface to the phone. It is a completely different mode apart of MTP, so ADB works whether or not you are able to browse your files.

Edit: Oh, you’re trying to patch the system from the system itself! (because you can select the charging mode) Could you try to run Tingle with your device in TWRP? Don’t forget to:

that is done.

I in TWRP nw with the System mounted and read-only disabled. but the ADB can not see the device, :unamused:

C:\Users\osilv\Desktop\ADB>adb devices
List of devices attached

nothing there…

EDIT: i disabled the MTP ad then adb could see the devices but when trying tingle same error persist.
I tried with last python version also