Is it possible to upgrade a rooted FP2 without first unrooting it?

Hi, you overlooked 2 lines above mentioned “Get fastboot running as described in Step 1 here”. It is a portion of Android developer tools.

With the mentioned activities you flash a new image which does not require the Google way which works only with regular, non-rooted devices and leaves you without root afterwards. If you have not missed being root before, you won’t need those extra steps.


hi amber, thank you for the answer! i didn’t skip the fastboot step. i really just dont know how to start the flashing process, i tried some different commands like “fastboot flashall c:\Users…\flash.bat” but nothing seemed to work. so i juat need help with getting the flash.bat running!
thank you in advance!

It’s because ADB is not fully installed/configured on your computer.
You have to look there for example:

thank you! ill try this later!

You are my hero! :slight_smile: Many THX!


Good to hear that it works with ADB and the binaries.

But how will it be possible to make the update process with TWRP only as we know it until now with <1.13.0?

Should we just wait, until the “autobuild” will find the correct file and then it is the same again?

The problem is, that the FP devs didn’t deliver a full OTA-Package yet (and I don’t think they will), only incremental images (which don’t work with rooted devices). I don’t know why.

I don’t think this will happen for 17.04.8, but maybe for the next version. Then yes, my autobuild-server only works with the full OTA packages.

I managed to install Android 6 and the rooted boot.img with fastboot now. I also have twrp recovery back, and now i wonde rif its possible to install gravitybox MM? Does someone have experiences?

Sure. Works fine. Don’t forget to use correct XPosed version (You’ll need sdk23 now). :wink:

Yeah, i noticed that :D, Thank you very much for your installation guide!

1 Like

@retsifp:from which version did you upgrade? I’m still on 17.04.1 (rooted, XPosed and so on :P) and I wouldn’t like to loose time going through 17.04.3 if I could directly jump to 17.04.8.
Thank you :slight_smile: Bye!

From 17.04.3 or so. Doesn’t care if you use the images. I think it could be any FPOS-Version. :wink:

1 Like

Thank you, just upgraded flawlessly :slight_smile:
Bye! :slight_smile:

I renamed the rooted boot.img to boot.img and placed within the extracted folder so all went fine and seamless :slight_smile:

1 Like

Ok, I’ve tried flashing it with retsifp’s instructions, but something isn’t working.

I tried to fit all the relevant information into this screenshot:

I downloaded the .zip, opened with Editor and deleted the last two words in there. Now the “a” is the last letter.
As you can see I’ve managed to connect my device via fastboot but like others here I wasn’t quite sure what this step means:


I assume that I’m just supposed to connect my device via fastboot and then run the “flash.bat” and it will automatically detect my fastbooted device and start flashing?

Anyways as you can see in the bottom left of the screenshot I got some kind of error message when running flash.bat. (Hope the german isn’t too confusing, it says: "The command “fastboot” is either not written correctly or couldn’t be found.) It looks like it had problems with connecting to the fastbooted device, still I was able to reboot my device by typen “fastboot reboot”, so I would assume that it was connected corretly!

It’s because ADB is not fully installed/configured on your computer.
You have to look there for example:

I followed these instructions (as you can see in the top right corner of the screenshot) and added the user variable for Minimal ADB in my advanced system settings. Do I need to edit the path to direct to the “adb.exe” or is it supposed to be the path to the whole programm directory?

Hope you guys can make somthing out of this? I’m not sure what went wrong :confused:

As you’re using windows, don’t worry about If you want to root again and/or install Xposed, you will need to remove the reboot line from flash.bat (if you haven’t done so already).

This technically should work, but you may need to log out and back in again, or at least start a new shell. If it doesn’t, an alternative way of setting this up for just the window in which you are working is by running the following in that window:

set PATH="%PATH%;C:\Program Files (x86)\Minimal ADB and Fastboot"

Hey, thanks for the quick reply!

I rebooted my PC, but the same errors accured when I ran the flash.bat.

If it doesn’t, an alternative way of setting this up for just the window in which you are working is by running the following in that window:

set PATH="%PATH%;C:\Program Files (x86)\Minimal ADB and Fastboot"

Where do I run this command? Do I have to copy it into the flash.bat? I’ve tried running it in the fastboot cmd and I opened a cmd for the folder where the .zip data is in (via shift+right click) and ran “set PATH=”%PATH%;C:\Program Files (x86)\Minimal ADB and Fastboot" (is the single " at the end part of the command?), but nothing seemed to do anything…

Edit: I just noticed that the cmd that opens when I run “flash.bat” doens’t even look for the ADB direction, so I’m guessing it doens’t now where to find the fastbooted device?
Do I need to copy data I unzipped to the Minimal ADB directory? Or do I need to set the path in the cmd? If so, how do I do this?
And last question for now: Can I also just flash the whole “” without changing anything? I know there is a fastboot command to flash a .zip file and I don’t mind the reboot…

In the terminal/shell that you’ll use to run flash.bat later. So this should be the right track:

And yes, the double quote at the end is part of the command, it closes the quotes that are opened just after PATH=. The trick is to keep this cmd open, and to run flash.bat from within that cmd window. To do this, just type flash.bat and hit enter.

As far as I know, this doesn’t work due to the different images included in the file.

really appreciate your help, but it seems like I’m still missing something :confused:

what I am doing now:

  1. downloaded & installed Minimal ADB and Fastboot
  2. download & unzipped “” somewhere on my hdd (different folder & partition than ADB, does the direction of this matter?)
  3. set up ADB with these instructions
  4. opened flash.bat in the Windows Editor, removed the last two words and saved it
  5. rebooted my phone into fastboot (vol-) and connected it to my PC
  6. opened the “Minimal ADB and Fastboot” and typed in “fastboot devices” (result)
  7. double clicked “flash.bat” in the direction I previously extrated it (this shell popped up)

I tried to run this command

set PATH="%PATH%;C:\Program Files (x86)\Minimal ADB and Fastboot"

in the first and second shell, doens’t seem to do anything. I’ve also tried various commands in a shell which I opened in the folder the flash.bat is in via shift-rightclick-open command shell

I don’t understand at which point and in which shell I am supposed to tell either flash.bat where the device can be found or how I can tell ADB where to look for flash.bat

Perhaps in this case it’s going to be easier to paste this command:
set PATH="%PATH%;C:\Program Files (x86)\Minimal ADB and Fastboot"
as the first line into flash.bat. The original contents of the flash.bat should then start on the second line (i.e. we’re adding a single line at the top). After this running flash.bat should give the desired result.

What the command does, is tell flash.bat where it can find the fastboot program on your system. Fastboot is able to find your phone (judging by your previous screenshot), so that’s all good to go. What you’re getting stuck at, is the cmd only knowing about the fastboot command when you’re in the exact folder it is installed in. As said, the command just adds the folder where you’ve installed fastboot to the places to look for commands that aren’t in the folder in which you’re working.