Invalid IMEI prefix on registration page

This is a heads-up for anyone looking to register their FP4. You’ll need to enter the final 5 digits of your IMEI on the registration page, but the prefix they give - the previous 10 numbers are fixed on the form - is incorrect and does not match the IMEI on my phone.

I’ve reached out to Support via email and will let you all know what the response is so that anyone having that problem in the future can find an answer here.

The form has been altered today to require entering 7 digits. However, first reports indicate it still creates an error message [UPDATE 17/11/2021, 15:40 h: remaining issues sorted out by now]


Thanks @urs_lesse. I’ve replied to that post now, and have also successfully registered my FP4, so this post can now be set as Solved, I think.


Let’s see if @Bapf can now register, too.

still not possible unfortunately. I have one of the 35587009 - 02XXXXX IMEI1. I already checked very carefully if I truly inserted the correct 7 digits, tried different browsers and even checked if my IMEI1 is consistent (calling *#06#, checking in my settings and physically under the battery) - it is. The error message : “The IMEI in not correct. Please check and try again.” still appears. I already contacted the support.


No, not possible


Would be interesting, if it has something to do with the 35587009 - 02XXXXX IMEI1 pattern

1 Like

And still got no answer to my support case from official site yet

@Phragmites Does your IMEI1 include the 00901 string?

I’ve updated my support case.
Let’s see what happens…

Yes, it does include the 00901 string.

As I said, I had no issues with my registration after you’d mentioned that the form had been amended, but I did do it on a desktop browser (Vivaldi, which is Chromium-based), not on my phone.


The problem appears to be fixed now. Everything worked for me!


Yes fixed
Registred now


bei mir ging es nun auch.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.