Internal SD card gets partially corrupted when bulk data is copied

Firmware 10 (8901.3.A.0045.20200905)

Hi folks,

I just bought an FP3 a week ago but I am not really sure if this is a specific FP issue. Maybe there is something wrong with the SD card slot. Let’s go for the details.

To hold my data from my previous phone, I have inserted a new (!) SanDisc SD card (200 GB and as an alternative 128 GB later) and formatted it for internal use. I also let the phone transfer data from the internal storage to the card. That worked so far. I started using the phone e.g. installing apps without problems.

Then I tried to copy bulk data (lots of GB e.g. photos, videos, music, etc.) back onto my new phone in different ways. All of them failed while copying masses of data (smaller amounts usually work). After that, the corresponding target folder (e. g. DCIM) does not seem to have any files in there although there have to be some (e.g. in Windows Explorer or TotalCommander (Android)).

Also it is neither possible to create new files in there nor to delete the folder itself (“not empty”). TotalCommander (Android) reports “su error: rmdir: /storage/emulated/0/DCIM: Directory not empty”. When trying to create a new folder within that folder, TotalCommander (Android) reports “su error: mkdir: /storage/emulated/0/DCIM/Camera/newfolder: Structure needs cleaning”.

I tried transferring data these ways:

  1. approach: MyPhoneExplorer
    (error message: OBEX Errorcode D0 - Internal Server Error)
  2. approach: Windows 10 Explorer via USB cable and MTP mode
    (stops copying i.e. seems to copy forever)
  3. approach: SyncThing
    (just seems to pause synchronising somewhere in between and never finishes)

I also tried the following:

  • switched cards from new “SanDisk Ultra 200GB microSDXC” to new “SanDisk Extreme microSDXC 128GB”
  • physically tested both cards with H2testw 1.4 => both are alright!
  • repeated all approaches several times from scratch i.e. removed card, re-inserted and formatted it resulting in an empty card (except for standard folders such as Music, Download, DCIM,…).

I could not find anything similar on this forum. Most of the tips on the internet refer to corrupted SD cards but as they are obviously OK, I am quite frustrated while wondering what is going on here. Does anybody have a clue? I will appreciate any suggestions!

Hi bami, and welcome,

not sure if it helps: I have seen a few forum members mentioning, that formatting SD as internal storage causes issues.

I have only used my SD (sandisk 64GB) as external memory, and never experienced any issues whatsoever.



Thank you, Sebastian @swhcz!

Maybe I give it a try! Are you also able to store apps there? For photos and videos, this seems to be possible as I have tried it with OpenCamera. And how can I get rid of that permanent notification regarding the SD card?


I think the internal storage formatting is probably the culprit, I agree with @swhcz. Forum topic and explanation about this problem here.
You can also have a look at the #sdcardguide.

I don’t think storing apps on an external storage is possible (I may be mistaken though). But do you really need to store apps on the sd card? Aren’t the 64GB of the FP3 enough. I can understand you want to store the data of your apps on the sd card, because this can eat up quite a bit of space, but you really need to have your apps on your sd card?

1 Like

Hi Michael,

I don’t think there’s any app on my SD card, but plenty of App data (like you mentioned, images and podcasts). Not sure if that is even possible, haven’t seen any options pointing me there, ever.

The startup-notification went away when Android 10 came, before that I had to wipe away the notification at every boot (though, my muscle memory was taking care of that :slight_smile: ).



While I wholeheartedly agree with the suggestion to format SD cards as external storage, I recently realized there are apps that simply make it hard or even impossible to “outsource” app data to an external SD card. I think WhatsApp is such a case, and I guess it is very likely that WhatsApp will eat tons of (internal) storage space (just think of all the photos, videos, GiFs etc. that people exchange every day) unless you use Google Drive or let the app auto-delete everything after a set period of time. Theoretically you can actually locate and move WhatsApp media folders manually to an (external storage) SD card, but from what I know, the app will then no longer find and display these.

I don’t want to suggest going back to the old approach of formatting SD cards as internal storage, but I just wanted to point out this problem that is hard to solve either way.


Thank you, Alex @Alex.A, for the helpful information!

No, I guess you are right. It’s more like something I used to do until now. :wink:

Same goes for me. I have not found anything. But it does not matter (anymore) because I do have enough space now as @Alex.A pointed out.

Alright, that worked for me as well. I did not know that it will just pop up once. Excellent!

Thanks, Urs!

Formatting SD cards as internal storage was kind of logical for me because I had this working before on my previous 6-year old smartphone with recent LineageOS (Android 9). But I have learned that my SD card as internal storage caused all the pain although I do not understand why. Now that I formatted it as external storage it works for me!

Thank you all @swhcz @Alex.A @urs_lesse for your prompt support! I am very happy now! :smile:



Using sdcard as external storage instead of internal storage is a nice workaround but I would not call it as a solution.

You are perfectly right. But as I said elsewhere…


Build no is 8901.3.A.0066.20201119. Is this the latest? Ticket #408838 has been created.

Even if the SD card is the issue the OS should check whether copy was successful (by comparing file name and size at least) and delete the source only after a successful copy.


The thing is, it’s probably not the SD card the issue, but the OS which has a undetermined bug, making the contents of the SD-card inaccessible.

The sdcard worked properly in the phone, I’m not sure it had any issues. Did it copy the files of the work profile (none) ignoring the files of the personal profile?

No, I guess there is just a bug that hinders the access to the files on the SD-card and that creates storage issues. I believe we won’t know why just by guessing.
And anyway, I think the work profile doesn’t have access to the SD-card (but not quite sure).

I should be most grateful if you would send me a link to the source code of the “move to sdcard” function which is called right after formatting the sdcard as internal.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.