Instant voicemail when calling home number

I instantly get voicemail when i call people on their home number, and they won’t even get a missed call notification. I am sure it has something to do with my new phone, (ff4) for my friends don’t have this problem when calling the same number, and my previous phone didn’t have this problem.
Calling mobile numbers works fine luckily.
What can i do?

Welcome to the Fairphone community.

Which software is running on your FP4? What exactly do you mean with ‘voicemail’? Did you import your contacts from your old phone? Or are you dialing manually?

Hi, Thanks for the reply.
it is running Android 11.
I put in my contacts manually (didn’t know how to import from my old phone so i just filled in each contact by hand.)
When i call let’s say my parents’ house, by selecting the contact in my phone, i instantly get their voicemail: “please leave a message” that kind of stuff.

And this ‘voicemail’ is a device in their house or a service of their provider?
Android 11 means the default software of Fairphone? No /e/ or Murena?

What happens, if you dial the number manually?

Their voicemail is from a provider. They have to call a number in order to access their voicemail.
I altered nothing to the software to my knowledge, so i think i use the default software, with latest updates.
When i call manually the same thing happens.
I just tried something: it turns out when i leave a message, they do receive it, but their home phone does not notify them of it. It normally does so by blinking a small red light on the device.

Does this happen with any number you try to call or only with specific ones?
Are you sure that the number has been typed correctly? You write that you entered them into the new phone manually. Any chance there is a typo and you’re actually calling a different number?

1 Like

Another idea: Is there some kind of allow- / blocklist implemented with that voicemail provider?
More specifically, did you also get a new phone number with your FP4 or did it work with this number before? :thinking:

3 Likes

It’s with all home numbers. Or whatever you call non-mobile numbers. No typo, proof is i get their voicemail spoken in my dad’s voice.

I use the same number as my previous phone. That phone worked fine.
So a blocklist should not be the problem here i think.

1 Like

Very odd. Just to be clear: It means that when you call mobile numbers the call works as expected, namely the other person can answer after it rings there?

Exactly. Mobile number work fine. They can answer no problem.
It is a very strange and specific problem indeed!
If i won’t be able to fix it with the help of you guys, i will reach out to Fair Phone.
I wasn’t even sure if Fair Phone has anything to do with this problem, so i tried this first.

One final question: Are all the people you are trying to call using the same provider?
If so, could you tell us the provider? :pray:

1 Like

Another idea: Is it possible that you are calling without Caller-ID and those home phones just send it straight to voicemail because there is no number with the call? I recall such functionality existing at least…
This could also explain why the called number receives no notification: There is simply no information to convey if they were called from an unknown number and no message was left.

3 Likes

Well i’m not sure what that even means. But it sounds like something that could be the problem.
Is there something i could do about this? Can i check if i have such a caller ID? If so, can i turn it on or off?

Caller ID just means that your phone number (or contact name) is shown in the display of the called phone.
That can be switched on or off in the phone menu or you can predial #31# when calling to switch it off, or *31# to switch it on temporarily.

3 Likes

You can change the setting in the phone app settings individually for each SIM in the “GSM call settings”. For me the default was: “default operator settings”. So depending on your operator it may well be set to “off”.
To verify if your number is transmitted you could call some mobile phone that actually receives your calls and check if it shows your number.

1 Like

Just adding the complete UI route here (since this setting is buried quite deep down):
Phone app → ··· → Settings → Calling accounts → “Name of your carrier” → GSM call settings → Additional settings → Caller ID

3 Likes

This is all a bit beyond me, i haven’t been able to find any of these settings so far. I’ll call Fair Phone tomorrow for extra assistance. Thanks y’all helping me out so far. I think you guys have pointed me in the right direction. I’ll post an update when i know more or when it is solved. :+1: (I’m not ending the discussion by any means just so you know)

@hirnsushi’s instructions are spot-on. Where exactly do you get lost?
Also, did you try my suggestion of checking if called mobile phones show your number?