Installing Calyx OS fails

Hello guys. I tried installing calyx os for the first time on my fairphone4. When the device flasher tries unlocking the bootloader nothing happens on the phone screen. Do you have any ideas what I might be doing wrong?

i think it might be a driver issue? As I am getting the below Code 10 error when I check the ADB Interface driver in the device manager


I uninstalled and reinstalled the android adb several times via different channels but dont seem to get it running.

Can anybody help me I really want to install a more privacy focused OS

Welcome to the community :wave:

I’m not a Windows user, so can’t really help you with specifics, but from quickly skimming some similar reports, this does seem to indicate driver problems or an issue with one of your usb controllers.

Since you already de-/installed the driver several times, general adb / fastboot troubleshooting rules apply. Try different USB ports / cables, especially ports located away from the one you tried before, that might be connected to a different USB controller.

If none of that helps, consider downloading an Ubuntu live image. You should be able to use that to install Calyx. If that fails as well, we might be looking at hardware issues.

Is this not done in fastboot mode?

To check if its a fastboot driver problem:

Open Windows update
Search manually for updates
Got to addiitonal
And install anything fastboot related

1 Like

It is and it isn’t, the device-flasher uses adb to reboot the phone into fastboot, that’s the only adb part.
The flasher will run fine with the phone already in fastboot mode.

Thank you for the pointers, keeps me from booting my Windows partiton, very much appreciated :pray:

1 Like

I did update the drivers several times via windows updater as well but the only thing that really changes is that they are now categorized under “LeMobile” but still gives the Code 10 error


As advised the device flashers starts fine but it doesnt manage to open the unlock bootloader window on the phone.

I also tried to manually unlock the bootloader with the instructions provided by FP but the “fastboot unlock flashing”

but the fastboot flashing unlock command doesnt work for me either


Allrighty, fastboot is working, that’s enough to continue.

If you get “unrecognized command”, that usually means you are in the wrong fastboot, check if there’s fastbootd in big letters on your phone screen. If that’s the case, select reboot to bootloader (or similar), that’s where we want to be.
Nope, that’s not it, then it would show up as fastbootd under fastboot devices.

Did you enable OEM unlocking when you followed the instructions? :thinking:
Have you tried different ports / cables already? fastboot is notoriously picky about the USB connection.


first off all thank you that your are on this with me I am really at a loss

1 Yes I went to the store today and bought an expensive high throuput usbc to usba data cable. Since then at least I dont have the Code 10 for the driver anymore but now the drivers Android bootloader interface (active when phone is on fastboot) and Android composite ADV interface (active when phone is switched on normally) seem properly running.

Attached pic of my fastbootd which seems alright with me. This is the screen I hv on when I try running the device flasher

2 I did enable OEM unlocking and USB debugging

3 I tried all two available ports on this laptop and 3 more at home -no changes

That’s the wrong fastboot (fastbootd, we need the proper one), select Reboot to bootloader in that menu and run the device-flasher from there.

Follow the device-flasher instructions and whatever you do, don’t lock the bootloader manually, if you have problems run the flasher again.


HI hirnsushi

yeah now it worked fine from the bootloader and I have installed calyx os. Seems the new cable did the job with the drivers because yesterday I tried from both and didnt work.

I was uncertain now at the end the device flasher asked me if I wanted to relock the bootloader and I didnt do that was that right or can I lock it via the device flasher but not via other means?

That’s great news :tada:

If you want to lock the bootloader, run the device-flasher again, the part where it asks you to, is safe.

What you should never do, and I could perhaps been clearer about that, is not locking it during installation, then booting into Android and locking it after that.

From your current state, the only safe way is to run the device-flasher again and lock it in the end. That’s what I would recommend you do.

Edit: One caveat though, did you alread update to Android 12 before? If that’s the case, you might not be able to lock the bootloader, or rather you’ll have to unlock it again to get it to boot. I’ll check if there is a new Calxy version out in Beta already, that has the proper security patch state.

1 Like


I didnt update before. I ran the flasher again and everythings is fine for the moment :slight_smile:

Again thank you for your support! Much appreciate this community already


Allright, that’s good to hear :metal:

Have fun with Calyx :slightly_smiling_face:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.