Install /e/ on a Fairphone FP4 - “FP4” (beta)

TWRP misses the internal storage (/data/media) in the phone whatever the device. My hack allows to integrate internal storage in TWRP data backups.
But currently TWRP can’t decrypt at all the data partition of the FP4 (i.e /data), so there is nothing my guide will change to that. Using adb won’t be enough, you will only be able to save the internal storage manually (/data/media/0), and copying /data from a switched on phone with adb is a bad idea (and very probably won’t work).
Currently, no backup of the whole device such as TWRP does is possible on the FP4. Apps such as Titanium will work with root for backing up apps, and to use adb backup is a bad idea IMO, as it’s deprecated.
Hope it clarifies.

System settings are on the data partition, as all the user data.


Thank you for helping me out here - there’s a lot of new stuff to wrap my head around coming from the fruit of convenience…
So there is no reliable way (without root) to backup and restore system settings running /e/ on a FP4 at the moment? I can only document and restore everything manually as long as TWRP doesn’t support decrypting the data partition?
Is there something in the pipeline I can be looking out for?

AFAIK, indeed.

The TWRP topic I guess, to check for updates when it’ll support decryption.

NO it isn’t

Therefore you have to ask the /e/ developers.

I would add, be sure you actually want to switch to /e/, as it is a one way street for now:

It should be possible to get back to vanilla FPOS with properly backed up partitions, but so far no one has tried…

1 Like

there’s no way back, but there’s a way sideways to iodé (:

I did and if I may share the response:

We have several things in the pipe regarding backups and we hope to be able to roll out something later this year.


i do have that issue, too (as described by TFTD). Everything worked fine until step 6.
adb recognizes the phone, fastboot won’t. (fastboot = )

after entering recovery mode and selecting ‘enter fastboot’ the command fastboot devices -l shows the device. unfortunately fastboot flashing unlock is not possible, i get

FAILED (remote: ‘Unrecognized command flashing unlock’)

then I tried fastboot oem unlock and got

FAILED (remote: ‘Command not supported in default implementation’)

after executing adb reboot bootloader ‘Fastboot Mode’ is in red letters (as DEVICE STATE - locked).
Is Fastboot Mode disabled?? How to enable it? It would be very helpful to have some comments on this within the manual as well.

very confusing… any ideas how to get this working?
thanks for any help in advance.

using macos montery + homebrew

That’s already benn said last year (2021) :wink:
The discussion about backup was already held and exactly this statement was part of it at that time. Here or in the /e/ forum.
Therefore, it can really take longer. Must remain patient

1 Like

This has to be entered in bootloader mode. Not recovery mode
And it is fastboot flashing unlock for FP4

Thanks for your reply, FairphoneHulk!

I tried another cable - and it worked.

First try was using the cable from my macbook.

Now I used a cable for external SDD and everything worked fine.

Maybe helpful information, how to check wheather the cable is suitable…


Did you ask Murena (/e/) or Fairphone?

1 Like

… finally I have installed it! :slight_smile: And, yes, almost without problems.

Now it would be nice if I could transfer as much as possible of my system settings and apps (and their settings…) from my FP2 with /e/OS (connected to a self-hosted Nextcloud instance) to the FP4.

But I’ll probably have to do that myself, right?

Is seedvault integrated in e/OS? That could at least backup and transfer some Apps, but only during initial setup. Settings-System-Backup

1 Like

Thanks for your hint about “seedvault” – had not heard of it.
… and found @Ingo in this thread; [HOWTO] use Seedvault early to understand Android backup - #5 by Ingo_FP_Angel - HOWTOs - /e/ community – maybe he knows more :wink:

Hmm, just found:, seedvault seems to be integrated only in the /e/OS version for FP4:

… not for FP2. There is no backup option in the system menu.

But it’s too late now :wink: >> Thanks for your response!

1 Like

Sorry, I don’t know. I don’t have the time to follow what happens with /e/ anymore.


No problem. I’ll do it step/app by app/step : )

News: Today there is a new stable release of e/OS/: with this release OsmAnd on FP4 will run again as we are used to.


And also the german CoronaContact Tracing App