Incoming caller ID blocked - how can I change this?

Incoming calls are all unknown despite the fact that Network settings allow caller ID to be forwarded and the phone I am testing this from has caller ID active.
Vodafone suggest this to be an issue with phone settings but I cannot find any place to modify incoming caller ID settings.
Any hints and suggestions?

Sounds like an odd issue.

Unfortunately the only settings I’m aware of relating to caller ID are for outgoing calls and not incoming calls.

Are you able to try a different sim card to see if that works?

Problem solved. It was a Vodafone setting after all. It took 4 calls to customer service to eventually find the right person who knew what they were doing:-)


Glad this is sorted for you!

This topic is now closed. New replies are no longer allowed.