🇫🇷 Impossible d'envoyer des photo de mon FP2

Bonjour, j’ai un FP2 avec un OS 19.11.2 (mis à jour)
Je passe sur le fait que j’ai renoncé à mettre des cartes SD 32Go dans mon Fairphone 2 puisqu’elles ne sont pas reconnues… Heureusement, j’arrive désormais à téléphoner avec et à échanger des sms… pour le reste c’est une catastrophe mais je n’ai pas une grande utilisation ludique du FP2 et heureusement ! Pour en venir à mon problème que je renonce à aborder avec l’équipe Fairphone qui est répond de façon stéréotypée… voilà ce qui me pose problème à l’heure où on me demande professionnellement d’envoyer des clichés :
Impossible d’envoyer même des petites photos. J’arrive à les recevoir en activant les “données mobiles”.
Ce que j’ai essayé de faire : 1) Activer le mode “données mobiles” ; 2) Réinitialiser avec les opérateurs de Sosh (Orange), ceux-ci me disent que cela vient du réglage du Fairphone 2, désormais. 3) J’ai essayé à plusieurs correspondants dont moi d’envoyer des petites photos prises avec on FP2.
4) La vérification de l’APN dans : Plus > Réseaux Mobiles > Noms des points d’accès > APN > Orange World… Je note que même si on paramètre “Orange MMS”, il est impossible d’obtenir le petit cercle sur le côté droit qui permet de cocher ce mode d’APN.

Je ne vois plus quoi faire ?

Merci d’avance de votre réponse et de votre aide

Bonjour,
Es-tu sous Fairphone Open OS ou Fairphone OS (es-tu avec ou sans la couche Google) ?
Utilises-tu l’application sms de base ? Utilises-tu l’applicaction galerie de base ?

Du peu que je sache sur le sujet, le Fairphone 2 ne peut recevoir des photos que par les données mobiles, et non par Wifi.
Les données mobiles fonctionnent-elles quand tu utilises internet ?

Alex :wink:

Merci pour la réponse. J’utilise Le Fairphone OS de base (je ne sais pas si c’est sans la couche Google, ce que je peux dire c’est que je refuse toute inscription aux services Google). J’utilise en effet l’application de base qui est “Messages” version 5.9.101 (Wyvern RC12…). J’utilise en effet l’application “Photos” (Galerie de base ?) qui est installée de base avec Android.
Comme je l’indique dans mon “post”, le problème n’est pas la réception des photos qui m’arrivent en effet avec l’activation des données mobiles mais mon problème est l’envoi des photo depuis mon FP2…
Y compris quand je suis en wi-fi, je n’ai pas de possibilité d’envoyer des photos…
Une idée ?
Merci d’avance

Je cherchais simplement à obtenir plus d’information pour mieux comprendre le problème :slightly_smiling_face:

Quel message d’erreur reçois-tu exactement lorsque le MMS s’envoie (ou plutôt ne s’envoie pas ?

Tu peux essayer ces étapes, jusqu’à ce qu’une fonctionne, ou pour voir si aucune ne marche.

  • RedĂ©marrer ton tĂ©lĂ©phone.
  • Enlever et remettre la batterie.
  • Supprime rles donnĂ©es en cache :
    • Va dans Paramètres → Stockage → DonnĂ©es en cache
    • Les supprimer

Télécharger une autre appli de SMS (telle que QKSMS).

Peut-être peux-tu essayer une autre carte SIM si tu en a une sous la main. Si cette autre carte ne marche pas non plus pour envoyer des MMS, cela confirmerait que c’est lié au téléphone.

Tout d’abord merci pour l’aide, l’intérêt et les suggestions. J’ai déjà fait le test avec un autre téléphone et ça ne vient pas de la carte SIM.
Je vais suivre vos conseils et vous tiens au courant des résultats.

Bonjour,
Le test dans l’autre sens serait intéressant: en utilisant la carte SIM de quelqu’un qui n’est pas chez le même opérateur.
Je ne m’y connais pas assez pour t’aider, mais je suis étonné que tu puisses recevoir des photos, mais pas en envoyer. J’avais découvert il y a quelques années que sur un feature phone (les téléphones non smart) on peut envoyer et recevoir des mms sans avoir de forfait données, mais que sur un smart phone, il faut passer par les données.
Est-ce que ça viendrait du fait qu’il faut payer pour envoyer des MMS mais pas en recevoir? Donc qu’il ne suffirait pas d’activer les données, mais qu’il faudrait avoir un forfait ou la possibilité de payer les données au ko? Peut-être que les données sont bloquées par l’opérateur sur ton forfait?

Sinon, ça vaudrait peut-être la peine de regarder comment ça se passe avec d’autres applications comme QKSMS (c’est open source et il n’y a pas besoin de compte Google pour la télécharger).

Pour avoir utilisé pas mal un feature phone, et en ce moment également, je peux dire qu’envoyer et recevoir des photos avec demande des données mobiles. Mais à la différence du smartphone, le feature phone se met automatiquement en 3G, donc pas besoin d’activer des options. Je trouve étrange que cette personne dont tu parles avec un feature phone puisse envoyer sans forfait mobile.
Aujourd’hui, la plupart des forfaits offrent SMS/MMS illimités sans surcoût, je ne pense pas qu’il faille payer pour envoyer des MMS.
De plus, s’il est possible de recevoir des photos mais pas d’en envoyer, cela ne me paraît pas lié à la carte SIM.

Merci pour la piste QKSMS, je passe en effet par F-Droid pour les applications…
Autrement, l’activation des données mobiles permet de passer par le réseau 4G donc en principe, je devrais pouvoir envoyer des photos, cela m’a été confirmé par mon opérateur.
La façon dont ça indique que ça ne marche pas est que ça lance “envoi…” et au bout de 20 mn, ça indique que le message (MMS, photo donc) n’a pas pu être envoyé avec un petit élément rouge indiquant l’échec de l’envoi.
J’ai réinitalisé le cache comme indiqué par Aex, avec enlèvement de la batterie, redémarrage : toujours impossible d’envoyer une photo…

Ca a l’air d’être un problème assez commun chez Orange et plus particulièrement chez Sosh. Sur ce forum, il y a plusieurs témoignages. Je te laisserai lire toutes les pages si tu as le courage… En les parcourant rapidement, il semblerait qu’Orange ait fait des modifications en 2018 qui permettaient d’envoyer et recevoir des mms sans prendre sur les données de ton forfait, mais que ce n’était pas encore passé chez Sosh. Regarde si tut trouves plus d’infos. La page sur laquelle t’amène mon lien montre aussi un paramètre à modifier (appels wi-fi) sur certains téléphones pour que ça fonctionne.

J’ai utilisé de vieux téléphones pendant des années sans aucun forfait (avec prépaiement) et sans aucunes données. Je pouvais envoyer et recevoir des MMS. Les vieux téléphones qui ne fonctionnent pas en 3G pouvaient déjà envoyer des MMS. Même le plus récent Nokia 225 fonctionnait ne fonctionnait pas en 3G, par exemple, et il permettait d’envoyer et de recevoir des MMS sans avoir de données dans son forfait.
Apparemment, ça a changé, d’après ce que j’ai lu sur Internet, mais franchement, je ne suis pas spécialiste, donc je te fais volontiers confiance sur ce point et dans tous les cas on est en train de s’éloigner de la question posée et notre discussion ne va pas aider @cyra.

En fait, je crois que c’est ça le problème: d’après le forum auquel je renvoie en début de message, il y a des configurations (et Sosh semble être problématique pour cela) où la connexion automatique pour envoyer/recevoir les MMS ne se fait pas. Il faut donc le faire manuellement et c’est décompté du forfait données (certains utilisateurs expliquent que les données sont décomptées de leurs 100mo). Les gens cherchent donc comment faire pour que les MMS ne soient pas décomptés des données ou comment faire pour envoyer/recevoir les MMS par le wifi.

Comme j’ai dit plus tôt, je crois que le FP2 ne peut pas envoyer ou recevoir des photos par le Wifi, seulement par les données mobiles. Du moins c’est ce qui m’a été dit quand j’ai voulu essayer.

Je pense que le FP2 n’a pas ces option.

Si tout ça ne marche pas, et que le problème persiste, il te reste la remise aux configurations d’usine (factory reset), qui pourrait aider.

Merci pour vos commentaires et réponses. Je l’ai dit : j’ai activé les données mobiles qui permettent de recevoir les photos mais, cela ne marche pas, pour les envoyer. J’ai donc tenu compte du fait que l’on ne peut envoyer des données ou les recevoir qu’en activant les données mobiles (100 Mo, en effet). Le wi-fi ne fonctionne pas pour envoyer les photos comme me l’a indiqué Sosh.
Je crois donc que c’est vraiment lié à la configuration du FP2…

Bonsoir, J’ai contacté le service de Sosh. Ils m’ont envoyé une nouvelle configuration mais cela ne marche pas.
J’ai testé ma carte sim (à leur demande) sur un téléphone Samsung et la carte SIM peut avec le samsung envoyer une photo… C’est donc bien un problème de configuration du Fairphone 2.
Je viens de faire une demande au “support” de Fairphone… mais je ne m’attends à rien.
Je n’ai jamais réussi à faire marcher en module externe un mini carte SD de 32Go, pourtant qui fait partie de la liste de celle qui sont en principe compatible avec le FP2… (j’avais racheté une carte SD mais… pas de réussite de fonctionnement).
J’ai remarqué que dans > Paramètre >Point accès > il est impossible de cocher Orange MMS, il n’y a pas de rond qui permet de valider la configuration même après sauvegarde et redémarrage…
Je ne sais plus quoi faire…

Aussi si vous avez une idée… je suis preneur. Merci d’avance.

Bonsoir,
Une idée (mais c’est seulement une idée et je ne suis pas du tout spécialiste): comme tu reçois les mms, mais que tu ne peux pas les envoyer (en tout cas pas les photos), et comme ça fonctionne avec le Samsung mais pas avec le FP2, est-ce que ça viendrait pas de la compression des images?
La taille des mms est limitée. Je crois que c’est 600ko max. Or, les photos prises avec un FP2 doivent faire 800ko-1.2mo avec les configurations de base et l’appareil photo original. Ca sera même plus avec le nouvel appareil-photo.
Une idée serait d’envoyer une photo plus légère, comme celle-ci que tu peux télécharger depuis le site de Fairphone. Une autre idée serait d’essayer d’envoyer des messages avec des émojis (je ne sais pas quel est le comportement par défaut de l’application sms, mais il y a des chances pour que le sms soit transformé en mms).
Avec un peu de chance, si ça fonctionne, on pourra faire d’autres tests par la suite, comme l’utilisation d’une autre application (tu as essayé QKSMS?). Ou un factory reset comme le proposait @Alex.A. Ou encore le passage à Lineage ou /e/.

Est-ce que tu pourrais déjà tester

  1. une image légère comme celle que je propose
  2. un sms avec des Ă©mojis
  3. en utilisant QKSMS (et l’image légère d’abord, puis, si ça fonctionne, d’autres photos faites avec le FP2.)

Merci pour le pistes. J’ai déjà envoyé une tout petit fichier image, 56ko, cela ne vient pas de la taille donc.
J’ai refait configurer mon téléphone par un opérateur SOsh et on a vérifié l’APN qui est bon mais qui ne peut être sauvegardé (pas de “cercle” qui permette de choisir l’APN ORANGE MMS orange.acte.).
Par défaut j’ai le choix entre Orange entreprise, Orange Internet, Orange World (celui retenu) et Tele2 WAP…
Je crois vraiment qu’il s’agit d’un problème d’APN… j’ai contacté le service Fairphone qui, comme d’habitude, vous donne des réponses “bateau” sans tenir compte de votre problème spécifique.
Je n’ai pas encore téléchargé QKSMS mais je pense vraiment que ça vient du réglage APN… Quand je regarde sur le Samsung qui a le même opérateur, il n’y a aucun des Réseaux Mobiles > Nom de Points d’accès qui sont cochés et de plus le “Orange MMS”, également, n’est pas utilisable (pas de cercle) alors que l’utilisateur envoie et reçoit parfaitement des MMS… !!!
EDIT : J’ai installé QKSMS même résultat… impossible d’envoyer la même petite photo.
Quels sont les avantages de QKSMS par rapport au “Messages” D’Android ?
Merci de la réponse.

Merci de la préoccupation…

Personnellement, je trouve que l’application est plus agréable à utiliser. Mais c’est très subjectif. Je trouvais qu’il y avait quelques problèmes avec l’application d’origine. Je trouvais par exemple que l’espace pour écrire était ridiculement petit, ce qui fait qu’il fallait scroller pour relire le début du message.
Le reste est surtout esthétique.

Pour en revenir à ton problème, je n’ai pas non plus de cercle pour choisir l’APN pour les MMS. Il n’y a un choix que pour “Internet” (j’ai le choix entre 2 APN différents du même opérateur). Pour les MMS, aucun choix. Je ne suis donc pas sûr qu’il y ait un problème de ce côté-là.
Ce qu’il faudrait plutôt vérifier, c’est les paramètres pour les MMS dans le Samsung et dans le FP2. Quand tu es dans le menu “Nom des points d’accès”, clique sur la ligne MMS.
Fais une capture d’écran du Samsung avec la carte SIM dedans (si possible après avoir vérifié que l’envoi de MMS fonctionne). Ensuite vérifie si tu as les mêmes paramètres dans le FP2 (avec la carte SIM dedans). Chez moi, il y a 18 paramètres à définir (mais beaucoup sont sur “non défini”.

Merci pour la piste mais j’avais déjà vérifié avec l’opérateur Sosh… et là je viens de re-vérifier le point d’accès Orange MMS… sur les 2 téléphones ils sont en tout point identiques ! En effet beaucoup sont sur “non” mais c’est normal m’a dit la personne de chez Sosh… et puis sur le Samsung l’envoi et réception de MMS fonctionnent parfaitement…

Bon, je n’ai plus d’idées sur ce que tu peux tester.
Par contre, en ce qui concerne Fairphone, je te conseille de téléphoner, car j’ai lu sur le forum que c’était plus facile de discuter de vive voix.
J’imagine qu’ils vont te dire que ça vient de Sosh (comme Sosh dit que ça vient de Fairphone), donc si tu as le temps d’essayer avec une autre carte SIM (d’un autre opérateur), dans ton Fairphone, ce sera déjà ça de gagné, car tu pourras leur dire que ça arrive avec 2 opérateurs différents. A moins que ce soit lié à Sosh sur le Fairphone…

Juste un truc encore. Je ne sais pas ce que tu as fait exactement, mais je pense que ça vaudrait le coup de complètement réinitialiser les APN. Pas juste modifier, mais de faire un reset des APN, comme expliqué ici (ancien système, mais ça devrait t’aider):
https://www.helpforsmartphone.com/public/en/fairphone/fp2/android-5-1/guides/27/Set-up-MMS-Fairphone-FP2
Ca vaut peut-être aussi la peine de vider le cache (paramètres du système / applications / sms / stockage).

Ensuite il y a quelqu’un qui a aussi eu des problèmes avec Sosh et à qui Sosh a aussi dit de renvoyer le téléphone à Fairphone, mais qui a réussi à tout faire fonctionner. Est-ce que tu avais vu ce post?

ça marche !!! Alors j’ai suivi scrupuleusement la démarche du lien de Chrisse que je remercie chaleureusement. J’ai en effet effectué un reset des APN (ou restauration des paramètres par défaut) dans le Paramètres > Réseau mobile > Nom des points d’accès. [en haut de l’écran à droite] Puis j’ai fait une sauvegarde du Orange MMS (non coché) et je suis arrivé à envoyer une petite photo… donc ça marche. Je note que le “type d’authentification” est resté “pap” mais ça fonctionne.
Je garde en tout cas la suggestion de Cellular et les réglages proposés.
Merci encore de votre intérêt et de votre aide sympathique et persévérante…

1 Like

Excellent! C’est toujours frustrant quand quelque chose qui devrait fonctionner ne fonctionne pas.