IMEI f*cked by "FP3-REL-Q-3.A.0033-20200815.010936-user-fastbootimage-repack"

*tested /e/ didn´t like it
*also had a file data transfer issues; couldn´t get file transfer to work again even though it worked fine before
*decided to get back on the original fairphone os with “FP3-REL-Q-3.A.0033-20200815.010936-user-fastbootimage-repack”
*everything ran through OKAY
*phone reboots normal
*I set it up (phone settings wise); turned it off to insert sim
*inserted sim; rebooted; DIDN’T get asked for sim unlock; I was confused
*thought maybe the sim was gone so I tried a different phone; sim is fine and works!
*checked fp3 “about”: IMEI unknown on both sim slots etc.
*can´t OEM-unlock cause code validation fails with unkwon IMEI


Sounds like this might be the same issue as discussed here:

…ähm. thx. but this is one of the typical useless forum points farming replies I so do love. kappa.
if you would have read through the “post” he was obviously able to install an older version, wich means he was able to flash over fastboot. wich I CAN’T! cause why the f*ck so ever the bootloader is locked again!

after 7 years with my “jfltexx” hundreds of Lineage-OS “flashes” on dozens of s-phones, this is the first one that actually got “bricked”. and why? cause I trusted a fucked up one number enter script-shit somebody threw together in their lunch break…

Well, usually I don’t answer to aggressive and unpolite postings, but perhaps there are other people reading this thread and having the same problem.
I didn’t have to re-enter the validation code. I just switched off my phone and pushed [Power-Volume down] to enter fastboot mode. After this, I could unlock the bootloader via adb and flash Android 9.

…sorry, for my temper. but this one gets me “steamy”.
…none the less, thx for the input!
well that is more or less the core of the problem. I also figured I should not have to enter that code again but in and-deb oem-unlock is “locked”.
wich leaves me with “FAILED (remote: ‘oem unlock is not allowed’)” in fastboot.
and cause I can´t OEM-unlock without an IMEI & band in and-deb I´m screwed.
you see, if this had happened on any other phone, I would be like…yeah I screwed up…I knew the risk…but that is not the case! I downloaded a manufacturers software, coming from an official software partner ( /e/-OS ) and end up with a bricked device that isn´t even half a year old?

You can try to run: fastboot oem 8901_unlock
Thich seems to be able to unlock a device where oem unlock fails, see e.g. this topic: [Solved] HUGE problem - Boot and update to Android 10 or search for 8901_unlock in the forum.

1 Like

If you have a Fairphone account, you can find your phone’s primary IMEI in “My account / My serial numbers”.

…it’s not about me finding the IMEI, it´s about the phone doesn’t have IMEI and other band related stuff info… if I check IMEI on sim slots: unknown…
that “kinda” helped…I’am now able to “install” OS’s again…went back to /e/…but still no IMEI and etc.
…is there anywhere a download from the previous OFFICIAL Fairphone OS?

found one…seems legit.

YAOU ARE A LIFESAFER…at least for my fp3 ;p
rolled back to the OS “Lorenzo1” posted, and I really got all the info back on track…IMEI is back…band Info is back…I am really astonished this worked…I personally felt like “hard/firm” corruption…also already filed a support ticked…wich I hopefully can turn down if I now get rid of already known issues (reffering to “the_moreira’s” post)…
…even I barely found info on what “fastboot oem 8901_unlock” really does…

THE WAY TO THE FIX (for future people :upside_down_face:)
*enabled dev-options
*adb reboot bootloader
*fastboot oem 8901_unlock
*rebooted and noticed that the device was locked again; obviously “fastboot oem 8901_unlock” seems to be some temporary unlock; so I did this:
*adb reboot bootloader
*fastboot oem 8901_unlock
*fastboot flashing lock
*wich took me to the lock/unlock decision on the phone; there I simply choose to unlock again!
*rebooted and this time the phone stayed unlocked
*double checked that with another reboot and I was good to go on
*updated to the latest version OVER THE PHONE ITSELF
*everything seems to be as it was before…


Or just start or reboot the phone while keeping Volume - pressed :wink: .

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.