I muted Search Engine Selector and now I need to kill it every boot

I have run into an issue with my new FP5. I am using the stock OS but want to remove as much google as possible.
This thing popped up Search Engine Selector. I muted the notification.

It starts at boot and sits there untill I kill it.
I do not know how to “select my search engine” or how to turn it off.

I just want it to go away, with or without my search engine selected.

I think this is related to this post.

Have you deactivated the Google App? If not I would start with that.

1 Like

Yes, I did.
I have also disabled nearly all the apps from google that I could. It is still there.

so what you see is a notification, correct? Normally you can disable notifications, by holding it you should see options and a link (gear icon) to settings which should allow to turn off…
I dont see this notification and have disabled several Google Apps and dont remember if I had that notification or not.

The thing is that there is no notification. There would be one but i have muted it.
If you swipe down frop the upper edge of the screen twice, on the bottom you will see “X apps are active”.
If I go there, the app shows up as active, eating upp my battery. I can kill it but it comes back after restart.

I am looking for a way to stop it from running or to get the notification back and do what it wants.

It is not what you ask but why don’t you install/e/OS if you want to be rid of Google as much as possible?

1 Like

@fp_spter Settings/Apps/AllApps, in 3dot enable “Show system”, find “Search Engine Selector”
and you can reenable Notification…
but Disable button is greyed out, anyway you can Disable it in example. App Manager with Freeze button (same function as stock Disable button), after this is in Settings/Apps/… show as Disabled with non-greyed-out Enable button :wink:

1 Like

Well thats weird I dont see such notifications or whatever you see, havent disabled notifications only the Google App which is related to the search bar, which means I dont see a search bar nor weather widget (at a glance widget)

So with Google App I mean this one just to be clear

@k3dAR thanks for the tip. I have reenabled it to have a notification to kill it.
I tried installing the app manager, but I did not root my device yet and I do not see the Freeze button. Does this solution require rooting?

@yvmuell right now I have all google apps (but the play services) disabled and I still get the notification. If you reenable Google do you still get the notification?

No when I re-actvate the Google App I only get the Google Searchbar back… Can you post a screenshot of what you are seeing?

yes i have rooted, but found in “Settings/Mode of Operation” where besides “Root” is also:

tested this and Freeze/Unfreeze work :slight_smile:
(after disable root for AppManager, relaunch it and select Mode ADB over TCP)

EDIT: or you can without Root use internal pm command over ADB from PC:

adb shell pm disable-user --user 0 com.google.android.apps.setupwizard.searchselector

and for reenable:
adb shell pm enable --user 0 com.google.android.apps.setupwizard.searchselector

be sure above command is oneliner, with space between 0 and com…

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.