Howto install Calyx OS on FP4

AAHHH okay that makes sense!! When i should uninstall magisk then? Because one thing is sure, I have to use magisk to set unlock_ability = 1.

Or maybe can’t be locked?

Just follow the tutorial I linked to before and use the newest Magisk and this patched boot.img:

If you flash the image instead of just booting it, you modify the boot partition, changing it’s hash and breaking Android Verified Boot in the process. In that state you indeed can’t lock your system, as is to be expected.


I am not very lucky… I tried beta version without success. Now I just used this new method device-flasher.linux from Install on Fairphone 4
When I run it (with OEM unlocked and USB-debug) I get:

Android Factory Image Flasher version 1.0.6
1. Connect to a wifi network and ensure that no SIM cards are installed
2. Enable Developer Options on device (Settings -> About Phone -> tap "Build number" 7 times)
3. Enable USB debugging on device (Settings -> System -> Advanced -> Developer Options) and allow the computer to debug (hit "OK" on the popup when USB is connected)
4. Enable OEM Unlocking (in the same Developer Options menu)

Press ENTER to continue

Detected  **my-S/N**. No matching factory image found
No devices to be flashed. Exiting...
Press enter to exit.

Looks like a fastboot issue to me, do you get anything for fastboot devices (after adb reboot bootloader)?

If you don’t, try different USB-cables / -ports, fastboot can be a bit picky sometimes.
Running the flasher as root might also help, if you don’t have the right permissions set up.

For some reason I just tried again and it went to unlock the bootloader. Now I got stuck in the next step bootloader (critical) - this is new to me.

Unlocking FP4 6551379f bootloader...
5. Please use the volume and power keys on the device to unlock the bootloader
Unlocking (critical) FP4 6551379f bootloader...
5.1. Please use the volume and power keys on the device to unlock the bootloader (critical)

My phone just restarted in factory reset after bootloader was unlocked. No Calyx, the installer shows no error or progress.

That’s a known issue, the FP4 doesn’t reboot into fastboot after unlocking the bootloader / critical partitions. The devs are looking into it.

If your phone booted to userland (normal Android), keep the device-flasher running and reboot it to fastboot by holding Power+Vol. Down, let go of Power as soon as the screen turns black.

If you have stopped the device-flasher, or you have further issues, just run it again.

I tried to follow the advice when i ran ./ the laptop stopped recognizing the phone and i can no longer get the laptop to ask the phone to go to fastboot, what do i do? I would seriously appreciate any help

Welcome to the community :wave:

In what state is your phone right now? :thinking:

Don’t follow the steps above, that’s the old way, the FP4 is now supported by the (much safer) device-flasher, have a look at the official instructions.

When i originally tried to follow the original instructions i after running device-flasher i just got Android back as a factory reset like when i first bought it.
So i tried to do something else and found this article. Thank you for the response i really hope for some guidance on how to solve the specific problem im facing right now. It used to be able to go to fastboot menu but my computer doesnt even recognize the device anymore after running the command / on step 8. it only lasts turned on for a few seconds (im attaching a picture from using a friends phone) but then restarts over and over again. I dont know what to do. Living in the American continent getting this phone was not easy. id appreciate help i cant find anyone around that has experience with this.

i can only add one picture at a time so ill try to reply twice

Unplug the USB cable, turn the phone off, hold Vol. Down while plugging it back in. That should get you into fastboot.
Check if your laptop can see it with fastboot devices, if it doesn’t, try different USB-cables / -ports until it shows up.

Next step, stop using, use :point_down:

Make sure there are no spaces in the path you’re running the device-flasher from, it doesn’t like that :smirk:


Its beautiful! It works! Thank you :orange_heart: :yellow_heart: :purple_heart: :green_heart: :hearts:

1 Like

I installed Calyx OS on the FP4 back when this guide was still the way to go and you couldn’t lock the bootloader. Two questions:

  1. Does the new device-flasher way allow to lock the bootloader now?
  2. Can I use it on my FP4 with Calyx OS already installed to properly set it up with a locked bootloader, do I need to first install the stock image again first or what is the best course of action now?

Welcome to the community :wave:

  1. It does, and it includes checks to not lock it if there’s a problem. Whatever you do, don’t lock it manually, especially not after you have booted into Android.
  2. The best course of action would be to just use the device flasher to reinstall Calyx, no need to flash stock images beforehand.
1 Like

Thank you very much for the help! I’ll try it out as soon as I have backed up my data.

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.

Hi! Thank you all for responding!
So, I have tried to unlock the phone with an usbc to usb adapter (and the fairphone cable then from usb to usbc. It looked as funny and stupid as it sounds; BUT IT WORKED! the bootloader is unlocked!

But now I have another struggle. (tell me if i have to open a new question)
I want to install CalyxOS and they tell me to:
Step 1. Connect the USB cable between the computer and the Android device.
Step 2. Run device-flasher
Open a terminal, change to the directory with the firmware image, and run:

chmod +x device-flasher.darwin

Which i find rather confusing. I Put my device in bootloader, then opened terminal on my mac and typed "cd <location of the file with .darwin and the .zip> and then just typed “chmod +x device-flasher.darwin
./device-flasher.darwin” but then it says again “no such file or directory” and when I type
./chmod +x device-flasher.darwin
It says “command not found”
Also for adding:
sudo cd <location of file with the .darwin and the .zip>
(giving my password and then)
sudo chmod +x device-flasher.darwin
It keeps saying the same.

I also tried to do it on linux on the same computer runned on parallels desktop (Linux was so much less of a hussle! Great!) There CalyxOS advices a different method. So I followed. It runned:
“sudo apt update
sudo apt install android-sdk-platform-tools-common”

But I got stuck at:
“sudo dnf install android-tools”

Because it said “no such file or directory”.

Anyway I was not able to install CalyxOS, nor /e/OS with the easy installer.

Oh and I am working on a MacBook Pro Quad-Core Intel Core i7 from 2017. And it is running MacOS Ventura 13.4.1.
So no M1 or M2 Mac.

Can’t help you with the Mac part, but lets see if we get the Linux route working for you :crossed_fingers:

Sounds like you are following the instructions a bit too closely, the second command is for a different distro. If the first one ran without errors you are probably on a Ubuntu/Debian system.

Try running sudo fastboot devices in that terminal to see if your phone gets picked up.

1 Like