Howto install Calyx OS on FP4

Thank You! I just watched this video and followed every step. How to install CalyxOS on Android using a Mac (Google Pixel) - YouTube
That worked! But now my (triodos) banking app is not able to log me in :sweat_smile:

1 Like

Hello,

A couple of month ago I tried to install CalyxOS on my FP4 but I bricked it in the process. I got it repaired by Fairphone but haven’t used it since. I still like to use the FP4 without Google. But as I have some very busy month behind me and I am more or less happy with the old Pixel with Graphene OS that I got as replacement phone, I haven’t tried again to install CalyxOS. Now, I would like to do that but before bricking it again, I would like to double check a few things and I would highly appreciate your comments/help.

I think the issue that I had was that I just installed the new Fairphone OS before I tried to install CalyxOS.

Question 1a:

Am I correct that installing CalyxOS from a Fairphone OS Version that is not included in the CalyxOS Image results in bricking the phone? If so, it would be great to mention this in the installation guide for CalyxOS.

Question 1b:

If I will try now to install CalyxOS version 4.15.0, my FP4 can have the Fairphone OS version C.073 but not C.079. Is that correct? Does it matter if I have the C.073 version or anything older that is Android 12 based?

If I remember correctly, also had some problems unlocking the bootloader. I guess my timing for unplugging the cable was not perfect. I also had a somewhat short USB-cable and I think I lost once connection where it was not intended.

Question 2:

Could these problems with unlocking the bootloader result in serious problems (bricking the phone)? If so, is there any reason that I cannot simply unlock the bootloader before by using Android Studio and start the installation of CalyxOS when the bootloader is already unlocked?

Thanks and best regards

No, if you use the CalyxOS installer and don’t lock it manually it’s generally very brick safe.
The installer checks for get_unlock_ability and refuses to lock if it isn’t 1, so even with the wrong version on your phone you could just unlock it again.

Yes, and I personally would just wait for the next release in that case. It’s A14 based and should be right around the corner.

No.

You can just start the phone in fastboot mode with the bootloader already unlocked, but the installer will do that for you as well.
Just make sure you have a good cable and try different USB ports if you have issues, fastboot is notorious for being a bit picky. Other than that there’s not a lot that can go wrong, just don’t lock the bootloader manually, and don’t ever boot into Calyx and lock it afterwards!

Oh and welcome to the community BTW :wave:

4 Likes

It is really simple with the CalyxOS device flasher.

I just did it like that:

It also downloads and uses the correct Android tools (v33.0.3) for you, so no need to have a full Android Studio installation (In general if you just want to flash custom roms you just need adb and fastboot afaik).

1 Like

Thank you for the quick and detailed answer, it is highly appreciated and I will be definitely more eased when trying again!
Waiting for the new release is a good suggestion, but I will probably use the unbusy time between Christmas and New Year to tried it again.

1 Like

Thank you for your reply. Android Studio is already installed from my last attempt when I was running into problems and tried to solve them.
But I will try to just follow the instructions on https://calyxos.org/install/devices/FP4/windows/.

Hello,
I have installed CalyxOS a few days ago, it worked flawlessly. In step 5 after unlocking the bootloader, I had to try a few times to disconnect the cable when the device boots and power it off (5a) and hold volume down and enter the cable to enter fastboot mode (5b). But at after turning the phone off for three times or so, the installation proceeded. I am very happy with the OS, and even apps where I had a few minor problems with GrapheneOS (banking etc.), seem to run perfectly. Thanks again for the help!

For everyone considering to install CalyxOS: Don’t get scared because of my comment that I bricked the phone in the process of installing CalyxOS. Although I am still not 100% sure what happened, that comment was not fully accurate. Probably because my Fairphone OS was too new, I was stuck in the fastboot mode after the installation, but the phone wasn’t bricked at that point! Here, I should have asked for help, but I tried on my own. Somehow, I got out (I don’t remember how), and I think, I bricked it at some point when I tried to go back to Fairphone OS and at a time when it would have been wiser to just go to bed :sweat_smile:

4 Likes

I asked for an old identifier, that made me able to login.