English

How to use banking apps on FP3 with LineageOS 16.0?

When I installed my banking app it would not start because of LineageOS. I found that Magisk shall have an option to hide that it is not an official Google OS, so I booted into recovery and installed it via adb sideload Magisk-v21.1.zip directly after installing LineageOS 16.0. I locked the bootloader afterwards and the OS did not start and tell me that it is corrupt. What other possibility do I have to run banking apps or similar apps?

Leaving the bootloader unlocked, if your priority lies on getting Magisk to run. If you consider this, be sure to set up a screen lock.

I know that /e/ is not the same as Lineage, but in their forum they have a banking app howto, maybe that helps?

I’m rooted, so it may be a bit different, but i hid root with magisk for banking apps, and they do work

1 Like

Isn’t this a security risk? I don’t really understand what happens when the bootloader stays unlocked.

From what i have read, leaving the bootloader unlocked means that your children, friends and enemies can override your OS if they get physical access to you phone :slight_smile:

2 Likes

There is a topic about it here:

2 Likes

This is what I tried but it crashed my phone. How did you root yours? How did you install Magisk?

I temporarily booted twrp, and just installed the zip. I had no problem. I think there’s also a description somewhere, i try to find it again

Edit : from the unofficial LOS 16 thread:

It seems to be possible at least with Magisk. This has been tried by another person with success:

boot twrp from fastboot
I formatted /data here, don’t know whether this was necessary here, but anyway
install LOS
boot twrp via fastboot (this switches slots)
install Magisk
boot twrp via fastboot
install OpenGapps (arm64)

Reboot to system. You should be all set

1 Like

DId you lock the bootloader then?

Ok, it seems unnecessary to lock the bootloader if you can unlock it that easily without any permission: How to unlock bootloader when OS won't start?

1 Like

No, bootloader is still unlocked

I tried both of your tutorials now. The only problem seems to be that the banking app requires the Google Play Store, but I don’t want to install any Google apps! Is there any workaround?

Usually the unlocking process involves a device reset or you at least you lose the ability to decoded the user data. Hence any normally skilled attacker should not be able to access or manipulate your data through this channel. That’s at least a tiny reason.
Although I have to admit that I usually never re-lock the bootloaders, once unlocked.

2 Likes

Some might work with microg. But then, this are very traditional apps, with (IMHO) dubious tries at “security”, so you might be out of luck here (dubious, because for one I consider a patched and knowingly rooted phone more secure than a lollipop based system with year old patches. Same snakeoil story as everywhere)

1 Like

I use 2 banking apps on my FP3+ and both work very well.

Well, if you really want to use the app the method that works for me is using Island or shelter. The only limitation is that, at least using my bank application, I cannot use fingerprint to log in but only SMS otp or whatever is available

This is what things look like from your point of view. The banks, though, have to deal with a vast majority of users who are not technically savvy, not interested in diving deeper into the innards of their phones or just want their devices to work. So for them (the banks), requiring an unmodified OS and using technical measures to check the integrity of the OS and their apps is the only way do deal with the mass market, I suppose.

Best wishes,
Thomas

2 Likes