English

How to unlock bootloader when OS won't start?

I installed LinageOS 16.0 on my Fairphone 3 successfully, went to the settings and disabled the “oem unlocking” option. Then I started the device into recovery mode and installed Magisk via adb install Magisk-v21.1.zip. This made my phone crash and gave me the error message “Your device is corrupt. It can’t be trusted and won’t start”. I tried to completely reinstall FairphoneOS, but the bootloader is locked and I do not have permission to unlock it. Is there a way to unlock the bootloader or to make any android OS boot?

I’m afraid that’s not the right way. Where did you get this command from?
The right way is booting in TWRP, going in Advanced, ADB Sideload and then running adb sideload Magisk-v21.1.zip.
Alternatively you can push the .zip file to an SD card with adb push Magisk-v21.1.zip /sdcard (or you can do it manually from your computer’s file explorer) and then in TWRP going in Install and choosing the .zip file from the SD card.

Start in Fastboot mode and run adb oem unlock fastboot oem unlock. If that doesn’t work, run adb oem 8901_unlock fastboot oem 8901_unlock

1 Like

I got it by trial and error. Thought that might be correct… Thanks for correcting me!

I tried your solutions but it did not work:

$ adb oem unlock
adb: usage: unknown command oem
$ adb oem 8901_unlock
adb: usage: unknown command oem

When I am in fastboot I cannot access my device via adb. adb devices -l is empty.

adb install is only for .apk files, not for .zip or .img :wink:

You’re welcome!

Oops, my bad! Sorry… Of course adb won’t work in fastboot mode… :man_facepalming:
Start in Fastboot mode and run fastboot oem unlock, or fastboot oem 8019_unlock fastboot oem 8901_unlock

$ fastboot oem unlock
...
FAILED (remote: oem unlock is not allowed)
finished. total time: 0.020s
$ fastboot oem 8019_unlock
...
FAILED (remote: unknown command)
finished. total time: 0.010s

I cannot unlock bootloader, because I disabled the “oem unlocking” option and I cannot enable the option because no OS is starting :sweat:

Opps, I have to be careful with my typos…

Actually it’s fastboot oem 8901_unlock
My bad again.

$ fastboot oem 8901_unlock
...
FAILED (remote: unknown command)
finished. total time: 0.020s
1 Like

Are you in fastboot mode? What does fastboot devices output?
Otherwise, I’m afraid I don’t know how to help you further. I hope someone will!

Yes

$ fastboot devices
A209KYD10202	fastboot

Thank you nevertheless

1 Like

I believe the 8901_unlock command has been removed in recent firmwares.
You can try Fairphone 3 unlocking without oem unlocking

4 Likes

It worked! Thank you very much!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.