How to share internet connection via Bluetooth tethering

My question is almost equal to this one:
In my case, I have an FP2 with the latest Android 7 distro.
I disable flight mode and enable bluetooth. Then, seemingly, I can create a hotspot with the FP2. However, if I want to access this hotspot with another device, a password is required, which I don’t know.
How can I set the password or at least learn about it?
Can I change the name of the FP2-hotspot?


To me it sounds you’re mixing two things. The title is about “Bluetooth tethering” but the text speaks of “Hospot” which AFAIK refers to WiFi.

So what exactly are you doing?

1 Like

You can change the name and password of the hotspot in the settings … should be somewhere near network, WiFi etc.

If you want to share your mobile internet connection from your simcard:
Go to Settings’
Go to ‘More’ (fifth option, just under Data usage)
Go to ‘Tethering & portable hotspot’
Go to ‘Set-up Wi-Fi hotspot’
here you can set-up the name and password
Go one step back
and turn on ‘Portable Wi-Fi hotspot’ and this action will automatically disable your ‘normal’ Wi-Fi until you stop the Portable Wi-Fi hotspot.

(Should you turn on flight mode before you begin, then the simcard won’t work, thus the Portable Wi-Fi hotspot can’t work.)

1 Like

If I long-tap on Hotspot in the “Fast Settings” menu, I get forwarded to a menu called “Wireless & Network” (this is what Lidwien describes as “More” (fifth option)).

In this menu, I tap on “Tethering & portable hotspot”.
Then I reach this menu:

which is only about bluetooth tethering.
What Lidwien calls “Set-up Wi-Fi hotspot” is not present.
If I turn on the switch “Bluetooth-tethering”, nothing happens.

It may be related to the fact that you have turned WiFi off (just guessing).
Can you try again with WiFi enabled?

I tried it, but without success.
If I turn WiFi on, the “hotspot” button in the “Fast settings” menu, gets inactive. Besides this, nothing happens and the menus do not get additional options.

Not sure what’s going on :open_mouth:

In the screenshots there are quite some icons active in the status bar. Especially two left from the Bluetooth icon. What’s that? Is that some kind of screen mirroring over WiFi? Would that prohibit a wifi hotspot?

I see that you have only one SIM card inserted. I remember that a one-SIM-card-setup caused some problems with unavailable settings in the past. Could you please insert a second SIM card and try again?

@ Ingo
The second icon on the left-hand side of the status bar is an icon of the MyPhoneExplorer Client. I often use MyPhoneExplorer to synchronise the FP2 with the PC over USB cable. Moreover, the icon in the status bar two left of the bluetooth icon is indeed screen mirroring via USB. I sometimes control the FP2 from the PC. This is the reason why the screen mirroring icon is visible in the status bar.

To be able to use MyPhoneExplorer at all, one has to enable “USB debugging” in the developer mode settings.

It seems to me, that (for some reason) “USB debugging enabled” prohibited the displaying of the correct “Tethering & portable hotspot” menu.

I (for test purposes) disabled “USB debugging” and rebooted the FP2. After that, strangely enough, “USB debugging” was enabled again (although I did not enable it) and the setting menu “Tethering & portable hotspot” looked different from the above shown screenshot. Actually, it had all the options displayed, that you mentioned above to define a hotspot name and password. Then I have chosen a hotspot name and password according to my desire. I can now create a hotspot with the FP2 and successfully access this hotspot with another device.

However, as soon as I connect the phone with the PC via MyPhoneExplorer, the additional options in the menu “Tethering & portable hotspot” have disappeared again. If I reboot again the menu is again with the additional options but as soon as I use MyPhoneExplorer they are gone away.

@ TobiasF
At the moment I don’t have an additional SIM card. However, I will keep this idea in mind.

To conclude, I have reached what I wanted (to create and access a hotspot). Even though, there is still this issue with the different looking menu, which however doesn’t state a problem to me any more. Thank you for your advice!


Not quite.
USB debugging is necessary for connecting via USB, that’s true.
However, MyPhoneExplorer alternatively supports connecting via WiFi and Bluetooth, both don’t require USB debugging according to the FAQ …


If you want to use Bluetooth tethering, you need to pair another device to the phone using Bluetooth. That other phone/computer will then offer a network connection once you enable that switch - I can confirm that this works on computers. I do not know whether other phones support using this.

As said, Bluetooth is completely unrelated to the wifi network that the ‘Hotspot’ button enables. It is just (confusingly) in the same menu, because it is another method of sharing the phone’s internet connection with other devices. Bluetooth has no password, it uses PINs for pairing.

Let me list the three ways of sharing your internet connection on the FP2:

  • Wifi hotspot. Uses a network name & password.
  • Bluetooth tethering. You have to enable Bluetooth and pair to another device.
  • USB tethering. First connect a computer with USB, then enable this option.

I hope this clarifies what’s going on. Which one do you want to use?

This is true. You cannot share a wifi connection over wifi as the phone has only 1 wifi radio. You can use Bluetooth or USB to share your wifi connection with other devices.

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.