How to root the FP5 and OTA update - at your own risk

There is only the way through support.

They do it for the FP4 I think, so would hope they will do for the FP5 as well moving forward…

Overall my phone isnt rooted so my comments are rather theoretical trying to transfer FP4 knowledge from others more knowledgable to the FP5 as my expectation is, that the FP4 instructions apply to the FP5 the same way.

2 Likes

Unfortunately this would be extremely insecure. SHA sums are inside that huge archive, so nobody would be able to verify that it is original boot.img and nobody tampered with it.

Cool. I’ll write to support to push this a little, but I suppose they are overwhelmed, its still early after FP5 release.

2 Likes

Oh, right! I forgot about those. Nefarious thinking just does not come natural, when being enthused about tech. :sweat_smile:

I took a small write up of the rooting process I used here:
https://xdaforums.com/t/rooting-fp5.4634181/post-89111662

1 Like

Previous month i doing OTA v106 on rooted without problem (with classic: MagiskApp restore images, Doing OTA without reboot, MagiskApp install to other slot)

But with yesterday 112 update this not work, after reboot, is try load new update from slot B, but after ~15s reboot againd back to A slot with previos 106 system version…

First with Magisk 26.3 as in previous month…

Second i try with latest Magisk 26.4 and result same…

Thirt time i doing this (as still 112 not avaiable for download, but previous 106) :

  • in Magisk restore images (in actual slot A)
  • doing OTA update (to other slot B), don’t reboot
  • in ConnectBot local connection make:
    su -
    dd if=/dev/block/by-name/boot_b of=/sdcard/boot112stock.dd.img

And with /sdcard/boot112stock.dd.img make as first rooting procedure succesfully
(patch file in MagiskApp, via fastboot boot patched , in MagiskApp direct install)

BTW: although on download link is for FP5 still show as last previous 106, is already avaiable 112 for download on direct link: https://fairphone-android-builds.ams3.digitaloceanspaces.com/FP5/A13/FP5-TT3P-factory.zip (this is same official link as for 106 but change TT3L to TT3P in url :wink:
So not need grab boot.img from partition, can be from this zip…

1 Like

Just for peace of mind for anyone wanting this, I thought I’d report that the FP5 with the new manual install of Murena/E functions properly when rooted.

It had been my practice until now to use Magisk v23 on all my rooted devices, as it is the last one that natively supported MagiskHide. I can confirm v23 does not work. Magisk v23 will patch the current Murena boot.img, but doesn’t detect root when booted from the patched image. This was unsurprising since Magisk v23 already had problems on the FP3. However, the latest (v26.4 as of right now) Magisk works, and the addon MagiskHide replacement module also works well on the FP5/Murena.

I don’t know if there are any regional differences, but my FP5 is the UK version (and thank heavens Clove ships to Canada!)

1 Like

To not have multiple topics about root I merged them

1 Like

with current v127 update i have same problem with on-phone reroot and work same method

EDIT: anybody here with succes on-device reroot without problem as i have?

Just got the phone last week and got it setup. I’ve seen the update for the past few days and been unable to update. When I try it gets half way through “Downloading and installing” and then just says “Installation failed” with no other error messages.

I have Magisk installed with a few modules (LSPosed, Systemless Hosts, Pixel Xpert, and F-Droid Privileged Extension), and I previously had /e/os installed, followed by a DerpFest GSI, before moving back to stock due to issues.

Has anyone else had issues updating, or is it likely caused by something I have installed? I’m not used to dealing with updates given my last phone went 4 years without one

Hi and welcome, moved your post here.

Assuming you are on pure stock. The update instructions from the OP are still valid. I just followed them like I did with the previous updates. And I also have multiple magisk and lsposed modules installed.
If you want to see the exact error install a logcat reader and filter for update_engine.

2 Likes

Can anyone expand on this? I followed the Magisk guide, which said that I can also flash vbmeta with disabled verification, however I’m getting a checksum mismatch when the OTA is checking vbmeta_b.

I’m not sure what the significance of disabling vbmeta verification is and the language in the Magisk guide is really making it sound like it’s not necessary. (Why even mention it then?)

Since flashing vbmeta wipes data, I’d rather not repeat the effort someone else has put into this before.

with current v131 (same as with v127) update i have same problem with on-phone reroot and work same method

EDIT: anybody here with succes on-device reroot without problem as i have?

Just a short info:
Installed /e/OS on my FP5 yesterday and rooted it. The FP4 rooting method (as described in the first post; which I also used that time on my FP4 with CalyxOS)
is useable and went fine for the FP5 as well.

OTA Updates to be tested when the next /e/OS Update arrives.

2 Likes

Hi
I successfully rooted my device and the OTA updates worked more or less out of the box (v106 → v112 → v127).
But now I don’t get the notification for the update to v131. “Sytem update” still shows my system is up to date with Android security update November 5, 2023…

Maybe I have debloated too much stuff… but at the moment I have absolutely no clue why my FP5 doesn’t see v131

I have the same problem :confused:. Shows me only the November update. Doesn’t matter, if I try it with mobile data or WiFi.

Switched to iodéOS before I started to use the FP5 as my daily driver (mainly because I can uninstall preinstalled apps there more easily) and rooted it again - same procedure.

OTA Update procedure still to be tested.

Hi FairPhone Community,

as the title states, I am trying to root my FairPhone 5 with Magisk and would appreciate any help I can get.
I already tried rooting it by patching the boot image with Magisk and then booting the image in Fastboot mode.
This did in fact install a stub Magisk app on the phone, but when I used it to bootstrap to a complete Magisk app and rebooted the phone it still showed:

Installed N/A

The full description of what I did
  • Unboxed phone
  • Updated to version FP5TT40.A.131.20231130 via phone updater and over Wi-Fi
  • Enabled OEM Unlocking and USB-Debugging
  • Successfully tested adb connection
  • Installed Magisk and patched the boot.img I got form the FP5-TT40-factory.zip from the official website
  • Transferred the patched boot.img to my PC (and renamed it to “boot.img” for convenience)
  • adb reboot bootloader
  • fastboot flashing unlock
  • (Maybe a reboot to see if it did work, shouldn’t matter, though)
  • fastboot boot boot.img (I moved the boot.img to the same directory as the adb files, again, for convenience)
My phone’s build number: FP5TT40.A.131.20231130
Magisk Version, I got from topjohnwu’s GitHub: 26.4
The instructions I followed: How to root the FP5 and OTA update - at your own risk

How should I proceed?
I could try the same process again, hoping for a different outcome (maybe I made a mistake the first time).
I could also try the custom recovery approach with installing the Magisk .apk as a .zip file.
Any advice is greatly appreciated

I moved you question to the original root topic.

1 Like