How to return from Jelly Bean

Hej everybody!

Today - I was happy to see that there is a new update for the fairphone. Trusting the team, I installed it immediately. But some problems occured and I thought … maybe I will try the android stock-version (my mistakes, I know now).
Now, I am stuck with Jelly Beans!
-> I cannot open any google apps, not even speaking of the google play store
-> the fairphone updater is just not responding in anyway, only showing me which version of Jelly Beans I installed
-> I tried to install the fairphone OS manually but Jelly Beans is only showing me signs I cannot understand and fragments of words which do not help me to install the Fairphone OS once I go in recovery mode…

I am running out of ideas what to try…

I solved it.
It has been a long day and by accident I pressed Power button + volume down instead of power button + volume up to get into the recovery mode. I am sorry!


I’m glad it works now :slight_smile:

This topic is now closed. New replies are no longer allowed.