How to remove the search bar from the screen?


I changed my Fp2 to Fp3+ and so far have been very satisfied. I have a few questions though.

  1. Does anyone know how to remove the Google Search bar from the bottom of the screen? That was possible in FP2.

I am able to remove the Google App, and now the bar is saying just “Search” instead of “Google Search”.

Optionally, I´d like to put DuckDuckGo -search to it. Is that possible?

  1. Is there a way to change what happens when I press the home button? In Fp2 pressing and holdin the home button opened the apps and made it possible to search an app. Now pressing and holdin the home button just opens Google Search and as I don´t want Google Search and have removed the Google app from my phone, nothing happens now.


That’s easy: Use an other Launcher like Nova, Apex etc.



And how does one get to use those?

1 Like

When a launcher is downloaded, it can be selected as the default launcher.

Go to Settings -> Apps and notifications -> Default Apps -> Start screen app and select the new launcher.

To change what the Home buttons does on a long press, change the assistant app.

Go to Settings -> Apps and notifications -> Default Apps ->App for assistant and select a app that should be launched. The DuckDuckGo app supports being a assistant app.


Thanks a million! I suppose I can always change the launcher back to the original, if problems appear?

Yes you can deselect Nova for example

1 Like

Thanks a lot. I just try nova launche which is great! :+1:

1 Like

I left Nova because my firewall indicates that it is constantly seeking contact through the internet, about once in 10 minutes. The Apex launcher is even worse in that respect; about once in 3 minutes. I found the ADW 2 Launcher to be a good alternative.

1 Like

Thanks for that info about Nova.

Nova Settings > Advanced > Disable Error and usage reporting

This also maybe related

1 Like

I tried Nova again and disabled error and usage reporting. (Don’t remember having noticed that setting before.)
It did improve, but every time I go to the Nova settings, even without changing anything, Nova still tries to make contact.
Maybe others don’t care, and maybe it’s something harmless, but I wonder what they’re up to, and I don’t like it very much. Exit Nova.

1 Like

Re Nova Launcher

I have never had any indication it is trying to connect, how are you aware of it?

Most of the time i use wifo calling but if i just go to Nova either when connected or in airline mode i’ve no indication of any attempt?

I wonder where you downloaded it from and what version are you using

I use NoRoot Firewall. Here is a screenshot of the logs:

I just downloaded the latest version of Nova Launcher using Aurora Store. Same version as in Play Store.

Hi at least it didn’t connect, so it’s not using much in terms of resources. I’ll look for the Noroot Firewall and see what i find. Thanks

If you would be satisfied with (only a few) less features, try the Open Launcher. I have very good experiences with this fast and light weighted launcher.

OK I have Noroot Firewall installed. Restarted the phone and got one each for contacts and calendar then 6 for googleplaystore. I’ve disabled googleplaystore since. Nothing yet for nova or anything else, even after invoking Nova. Will leave Noroot on for an hour to see what may pop up.

I will try it, but, as said earlier, I am also satisfied with ADW Launcher 2. Not too complicated, yet very configurable and complete. And it does not collect data.

Did you disable error and usage reporting? Then there will probably be less or no pop-ups - until you go to the Nova settings. You can leave these settings without changing anything.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.