How to remove eSIM and/or disable 5g from recovery mode

I have been using my FP4 in the USA on tmobile (physical sim) for several years with no major issues, and installed the latest update when it was released. On Thursday I landed in London and got an EE esim at the airport which installed successfully and worked fine for about 24 hours. Friday we got on the motorway (M25) and the phone started spontaneously restarting itself (“shutting down”) eventually leading to a boot loader message “cannot load Android system. Your data may be corrupt. If you continue to get this message you may be to perform a factory reset…”
I tried the factory data reset as suggested but the issue persists. After the factory reset, I am unable to compete the setup process due to the reboots, which usually occur when connecting to the mobile network. Sometimes at various steps of setup I get the error “ has stopped responding”
This seems similar to other issue reports on the forums:

So it seems like this may be a bug related to the esim or 5g. However, the factory reset does not remove the esim. I have removed the physical sim card so only the esim is on it (the same issue persists), but at this point I would be happy to just remove the esim to get my hardware back, which at this point is competed unusable.

I have tried contacting support through email and live chat, providing this full description of symptoms including (readable) screenshots of the recovery log, but they have only provided very basic KB articles which did not help since I’m stuck in the setup / reboot loop, and response times seem very slow (e.g. no response at all today).

Is there a way to disable 5g or remove the esim from recovery mode / boot loader menu, or using adb?
Thanks in advance.

As far as I know the eSIM can only be deactivated or removed from inside the running system, so that won’t help you right now.
If the (5G) mobile connection is indeed the problem, then you might have some luck by trying to finish the setup process in a place with no reception. A cellar comes to mind, but there might be other places shielded well enough. Once you have the system running, you could then turn off the card. Switching the settings to 4G instead might also fix the problem. A lot of the reported reboot issues were due to some sort of 5G bug with certain networks.

1 Like