How to reinstall Fairphone Open OS

Oops - I seem to have deleted the operating system from my FP2.

I was trying to get rid of opengapps, which I had installed previously. Factory reset did not get rid of it so I tried to follow the instructions for a hard reset (https://fairphone.zendesk.com/hc/en-us/articles/201134418-How-to-perform-a-Hard-Reset-on-my-Fairphone). This didn’t work - maybe because the instructions are for FP1? I never got a green robot and there was no “system recovery” option on the screen I got. I tried reset and then wiped several things - obviously, I wiped to much.

Now, when I start the phone normally, I get a start screen (Android powered by…) that never goes away, and the phone gets quite warm after a while. When I go back into recovery mode, I have a few options but I don’t know which way to go - and the phone keeps warning me that I have no OS installed. The only way out that I have found is removing the battery.

Can anyone help?

Thanks a lot!
Linda

It’s not because the instructions are for FP1, but because they are not for FP Open OS. On Open OS you should get to TWRP (Team Win Recovery Project) if you follow the instructions and there should be an option for “wipe”.

As long as you only swiped after tapping “wipe” you only did a normal hard reset.

That is probably Fastboot mode. Try to get back to recovery mode and then tap “reboot” -> “system”.

I did that (got warned that there is no OS installed again, confirmed I want to reboot anyway rather than sliding to install superuser) and my phone has been stuck on the start screen for 20 minutes now. I have to leave home soon so I will leave it plugged in and see what it looks like tomorrow evening when I get back… Took off the back cover to prevent overheating.

Not sure what you mean there. If my memory is correct, I first wiped whatever was checked but seeing that Google Play & Services were still there, the next time, I checked all the boxes in “wipe” before I swiped.

(I tend to get (very) impatient when things don’t work… I guess that’s a good reason not to root the phone or install superuser, so that I can’t do to much damage - right?)

In case other people have been looking for explanations on TWRP: there aren’t any in the knowledge base or the forum dictionary but there seem to be many articles on other web sites.

Well in that case you’ll need to download the OS from code.fairphone.com put it on your phone (via ADB or external SD card) and “install” in TWRP.

Thanks a lot!!!
I succeeded in reinstalling and updating the OS. I hope I won’t need too much help for the next steps - though I’m afraid I’ll have more questions as I go along…

1 Like

No worries, the forum is here to help. :slight_smile:

1 Like

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.