How to get access to the photos on the FP2 from a windows PC?

Hi there. I connected my Fairphone 2 to my Windows 7 PC and just want to access the photos on it but the folders where they are supposed to be are shown empty. I tried the connection types data transfer (MTP) and photo transfer (PTP) but I had the same problem in both cases. I’m actually not sure in which folder they are saved but the folders Pictures, DCIM and storage are empty. However, I have access to the files in the Download folder. How can I make it work?

1 Like

What camera app do you use to take photos? Maybe it uses an app specific location for the pictures (Camera ZOOM FX does for example and you can see it in the app setting).

If it is not a specific picture location, empty folders in general were experienced before …

I would try MyPhoneExplorer,
It was it’s own file transfer functions.
Both the FP2 and the PC should be in the same (W)Lan, then Press F1 to search and connect to the Phone, and browser the files of you phone with “Ansicht/Dateien” (View/Files)
MyPhoneExplorer wants to install an app on first connect, so watch your display!

Can you see the photos with the explorer of your FP2? I had this problem too and copied the photos from the internal storage to a folder on the SD card of my FP2. It was then possible to access the photos from my PC (with Ubuntu in my case).

When I switch my FP2 to USB-Mode “MTP”, I can see my photos in Windows Explorer under

Computer\FP2\Interner Speicher\DCIM\Camera
(German path name)

Does this path exist on your FP2?

First of all thanks for the answers.

Regarding the camera app I’m using the standard Android camera app.

I also tried the MyPhoneExplorer but it doesn’t recognize my Fairphone via USB. Wifi currently doesn’t work on my PC in general (another story).

I’m not quite sure what exactly is the explorer of the FP2 but when I go to Einstellungen -> Speicher und USB -> Erkunden (Settings -> Storage and USB -> Explore) then I see the folder structure including pictures there. Unluckily, I don’t have a SD card to copy anything onto.

When I go to the info of my latest photo, I can see the following path /storage/emulated/0/DCIM/Camera/IMG_20171231_111336.jpg. Searching for that path from the PC in the MTP mode leads to an empty folder in the following path Computer\FP2\Interner Speicher\storage\emulated\0\updater.

So you mean on your PC you see only a folder named “updater” inside “Computer\FP2\Interner Speicher\storage\emulated\0” and “updater” is empty?

I find that pretty weird. Can you make a screenshot?

well, the last resort would be to email the pictures to yourself (like my mother does…)

Discussion continues here: