[HOW TO] Flash a custom ROM on FP3 with GSI


Actually, during my tests I did that when I get the custom ROM. I’m just waiting for someone to try without these commands to erase it :slight_smile:

I did it to be sure it was in the stock version (magisk mount system and vendor)

I guess that makes sense for vendor, but you are overwriting system with the GSI anyway.
So no reason to flash the original system beforehand.

I agree, that’s why I 'd like someone to try :wink:

If I understand this correctly, it should technically work with most gsi roms?
In that case I’d like to try this with Resurrection Remix this weekend. I had it on previous phone and would like to try it out again

Yes it should! Let us know when you’ll try :slight_smile:
(The gsi is an official image of resurrection :wink: )

Hi everybody. Thanks @pigpig for the guide!
I’ve been using LOS 16 GSI all day, it’s very stable.
I installed Xposed framework (mandatory for signature spoofing, I think), with microG (packaged in Nanodroid to debloat some apps), and it’s going great!
Phone calls, LTE, Wi-Fi, Bluetooth, Cameras, GPS, AP are working fine for me.
I think that the fingerprint sensor works better with this ROM, so maybe the issues here is related to the Fairphone stock ROM?
Also, data-related problems mentionned here and here are not present anymore, so I again guess it’s a bug in stock…
Anyway, thanks again to everybody that made it possible !


I have tried all the steps and it works perfect. But how can i flash the stock rom? I have made the download as linked in post 1.


I have also uploaded a flashable ZIP for installing Stock via TWRP:


Yes I have downloaded the file. But I can’t flash it in TWRP, get an error message, just try it again.

Can you please send me the recovery.log, maybe I have made a mistake when packing the ZIP.

adb pull /tmp/recovery.log

Error message is "Invalid zip file format"recovery.log.pdf (33.6 KB) please remove .pdf

That is not the ZIP-file I linked to, you are using the dump.
Please use this one:

Oh sorry, I’m just downloading it, then I’ll test it again.

The file may be broken, I am currently uploading a new one.
Please if you can try installing it anyway and get me another recovery.log.

… i got an error. recovery.log.pdf (25.4 KB)

… the “Fairphone_FP3_8901.2.A.0105.20191217_12171325_user_release-keys_broken.zip’” i also got an error.recovery.log.pdf (25.4 KB)

I think k4y0z is building a new flashing zip. As I 've seen it is because the flashing zip is for “FP3” device and it see yours as “fp3” device…

Which GSI ROM did you try? Did it work? (for the wiki, and other users :slight_smile: )


I tried Los 17.1 installation ok, but not working (could not open apps) and Los 16 working perfect. Not did that:

fastboot flash vendor vendor.img # Not sure if needed
fastboot flash system system.img -S 522239K# Not sure if needed

1 Like

Nice ! Thanks to have try without those 2 cmds
I 've seen on xda that LOS 17 GSI isn’t really stable for the moment, but some users find out some tricks to have a better experience :slight_smile:

1 Like

Just uploaded a new version, please try this one:

@pigpig Can you grab me the URL of todays OTA (A.0110) please?
If this ZIP works, I can try creating one for todays update as well.