How to enable usb file transfers?

hallo, jsut got a second hand FP2, so excited, my first smartphone and I’m appreciating having it so far.

however I’m trying to load music on it, and I can’t work out how to transfer files via usb?

at the moment I’m limited to bluetooth transfers, which are crazy slow from my laptop. (100kbps : /)

could anyone help? when I first connected it it brought up a popup, and I selected “connect to transfer files” or something similar, but I can’t find where that option is in the settings, or how I’d change it to another option, as it doesn’t seem to work.

using GNU/Linux, Debian Sid, with Plasma DE.

any help would be great, thanks.

Maybe you find the solution here (or rather in the links on that page):


As I don’t use Linux, I have no idea what to do on this behalf.
Also you might find the information in this post helpful on selecting between internal storage and portable storage for the SD-card:

Was this on the phone, or on the computer?

If you mean the settings on the phone, the hint that the page that is linked to in the post above gives is (hidden in the Mac section):

open the notification panel on your phone, select USB connection and then “MTP” mode.

(notification panel = swipe down from the top of the screen).

MTP is, in my experience, a bit fickle on my linux system. Sometimes it works immediately, sometimes it takes a while. Often, my phone needs to be unlocked for it to work. Others have had more luck after adding custom udev rules.

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.