English

How to disable Bluetooth Audio Autoplay?

#!/bin/hi *

Always, when my FP3 connects with my car stereo via Bluetooth, Spotify starts immediately playing the last song. This is super-extreme annoying and there are dozens of complaints on their forum’s site.

I just recently found this Disable autoplay when connected to Bluetooth - The Spotify Community
suggesting, that this is an Android OS “feature” and Spotify can’t help (well, in the past Audible suffered from the “feature” too, but managed to fix this on their own…).

So: how can I disable the Audio Resume Autoplay when connected via Bluetooth on my FP3 in the OS Settings? I currently don’t see any switch in my settings.

Have you also seen this, it’s a bit old but may give some clues as to what you can try.

1 Like

Hi amoun,

Thx for the suggestion. As I understand this article, it’s about installing some Tasker XDA application and do some playing around with it. Didn’t know of Tasker. I’ll give it a try.

1 Like

Installed Tasker, configured it and it seems to work. =)

Thx!

2 Likes

Nope. Rollback. Didn’t work.

Even as Tasker is set to grab Bluetooth Media Controls, Spotify starts playing when connected to my car Bluetooth. Well, it doesn’t immediately. But as soon as I switch to Spotify it starts playing even if I stopped playing previously.

I think this is - despite what they are saying - a real only Spotify only issue.

So, sorry for the noise, but I assume Fairphone OS can’t help this.

1 Like

Reading through the link above, I would think its triggered by Android Car and Spotify has no option to interfere. I never used Android Car and have no idea if it’s useful for other things, but why not just disabling this App?

Android Car? Well no, this is very old Kenwood Radio in an even older VW Golf. Both from a time where nearly all handheld phones have been produced in Finnland, and they’ve been not very smart. This is a tech whose age is in the double-digits.

It’s just FP3, Spotify and a very, very basic old Kenwood Car HiFi radio.

Edit: you mean disabling Spotify? Why should I do that? I want to listen, but when I want, not when Spotify think I should.

Maybe the idea is that by disabling, not uninstalling you just have to enable it, or is that too much trouble? How many extra taps on the phone does it take to enable?

I don’t get it.

I can “Force Stop” or “Uninstall” Spotify. Both via Settings, which is quite a hassle, the former doesn’t help and the latter is out of the question. So both is too much trouble.

Then I just can stop Spotify from the running tasks, yes but a) why should I always before I sit in the car first check my phone, if it’s happy with this (again, this is too much trouble) and b) it doesn’t help either, since when Spotify is closed and when I’m in the car, as soon as I open Spotify, it immediately starts playing where I left it even if I stopped playing the song before.

All I want is Spotify to just do not start immediately when connected to a new Bluetooth device. Just the very same as Audible and DI.fm do on the very same device. Alas, they manage it, why not Spotify? Though Audible needed quite a user shitstorm to do it.

I see it as a Spotify only issue.

Anyway, thx for the suggestions.

I meant to disable the Android Car App on the FP3 not your Car system. Its installed on the FP3 with the system and there, so if not needed, disable and see if this helps. I have it disabled on the FP2 and Spotify does not Autoplay

Ah! I found an “Android Auto” (every time I wondered what automatic tasks this thing controls or starts), but no “Android Car” on my FP3. Also, I thought Android Car is an Android installed on the car media devices, not on my phone. Obviously a misconception…

Ok, disabled this one. Let’s give it try!

OK I was not sure what its called in EN in Germany its Android Auto and Auto is Car. Fingers crossed

Ha ha, true. I’m Austrian, so a German speaking native too. But my FP3 is set up in English. And there it’s “Auto” not “Car”.

1 Like