How do I transfer SD card data to MacOS?

I used to plug in my old FP1 into my MacBookAir and transfer files & pictures back and forth. Now, when I plug it in, nothing happens.
How does this work with FP3?

Hi there and welcome to the community forum!

Did you try another cable? It may be, that your cable isn’t a data cable.

Then, please check the official Fairphone article about connevting to a computer, you may find interesting things.

I recategorized this topic in #help:fp3 instead of #participate and gave it a clearer name.

1 Like

Hello Alex.
I took the SD card out of my old (FP1) Fairphone and put it into the new FP3. Then, using the brand-new charger cable I bought with the FP3, I plugged it into my computer, but nothing happened. Is the charger cable not also a data cable?

When I try to access any of the files on the SD card through my FP3, I am told “cannot read file”, so I need to erase those files and start again. So: how do I connect to the SD card via my MacBookAir?

Kind regards,

Did you manage to write any file on the SD card? Has your file manager the permissions to read these files?
Perhaps your SD card is not compatible with the FP3. Please check if it as been reported to work in the following thread: ✏ List of compatible microSD / SDXC cards for FP2 Edit: Whoops, that thread is for FP2.
Your cable should work. But please test another one, you never know.

My SD card is a 16GB SanDisk.
I have not been able to access it in any way.
I did not know that the file manager needs permission to read the files. When I got o the SD card I can see the photos, but cannot ready any text or .pdf files.
Do I have to adjust something in the settings?
I still cannot connect my FP3 to my MacBookAir. It dows not appear in the Finder box.

When you connect your FP3, do you have an notification saying your phone is charging? If you click on it, what happens?

Otherwise go in Settings → Connected Devices, and you should find an option somewhere where you can choose “File Transfer”.

I go that far and clicked on “File Transfer”, but when I tapped USB controlled by “This device” it said “switching” and then “couldn’t switch”.

I have a last suggestion, after I’m out of ideas. You could contact Fairphone support as well.
Activate the #dic:developeroptions and switch USB debugging on. Though it should work without.

Sorry to seem dim: how do I “activate” #dic:developeroptions?

This a link to a dictionary entry on the forum. Click on the link and you will have all explanations.

OK, got it.
However: that link says:
“Don’t play around with these options if you don’t know what you are doing!” and it only applies to FP1 and FP2.
Given that I am an older person who finds it difficult to get my head round some of this technical stuff, I don#t think I dare go into developer options.
I will try calling someone for help.
Thanks for all your endeavours. Have a nice day.

1 Like

You can contact Fairphone support, and try calling them. You’ll find information on their support page.

1 Like

I’ve been using Android File Transfer and OpenMTP on Mojave as it is the only option since Android 8 if I recall correctly so there is no way to access phone or MicroSD card data on newer Android devices via Finder any more. As I’ve upgraded to Catalina I think only OpetMTP works now, but will have to check and let you know.

You can also take a look into this topic:


Johnny’s right. This is what’s needed on the Mac side:

Android File Transfer is not working in Catalina any more, but OpenMTP is still working so it can be used. I’ve just tried it on my MBP and it works.


One more thing about Photos app on mac!
When this method of transferring photos to mac is used (via AFT or OpenMTP) the following bug is manifested in Photos application: when importing photos from file in Photos app, it takes date and time from file when file was copied to mac and not date when photo was captured. This means that in Photos timeline these photos will be with wrong date and time. So far the only way to correct this is by using exiftool app Manual correction on each photo can also be made in Photos, but I don’t recommend that as it is time consuming. After installing exiftool the following procedure is used to correct photos timestamps:

  1. copy photos from Android device to mac to separate folder. I recommend creating separate folder in Downloads e.g. photos (this also applies if you copy photos from any source e.g. USB stick, external cards, etc.)
  2. open terminal app and navigate to that folder:
    cd Downloads
    cd photos
  3. enter the following command:
    exiftool “-FileModifyDate<DateTimeOriginal” *
  4. Import all photos from that folder in Photos app

I don’t know who is to blame here for making this simple task so complicated: Apple or Google or both of them, but I hope someone will make use of this workaround.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.