Hotspot/tethering stop working randomly

Hi there,
I share my data connection with my FP3+.
And sometimes, it stops working on my computer (“connected, no internet”).
It can be after 10min or after 2h30… Everything is working on the phone but I have to stop and start the hotspot.

Do you have an idea how to fix it ?
I have a new provider (sosh) since today and same trouble.
With another phone and the same sim card, everything is fine…

Thanks !


Hi there,
Are you up-to-date? What is your build number?

Perhaps try re-adding manually your APNs (Access Point Names). You can find them under Settings→Network and Internet→Mobile data→(Advanced)→Access Point Names (APNs) (in french Paramètres→Réseau et Internet→Données mobiles→(Avancé)→Noms des points d’accès). You can find a french tutorial here about how you can configure APNs for sosh:

Otherwise, try a #dic:factorydatareset (:warning: Do a #dic:backup before! :warning:) .

1 Like

Hi @Alex.A
Thanks for replying.

Last week i had bouygues telecom, and same troubles.
I manually added apn, i did a network reset and then i did a factorydatareset but still the same. And I have the same today with sosh… And that’s weird it is so random…

my build number is 8901.3.A.0054.202000929
I’m up-to-date.

1 Like

Well, you already tried quite much. The next step might be reinstalling the OS manually, or installing a custom ROM such as /e/OS or LineageOS to see if there is any notable difference.
In any case I would advise you to #contactsupport.

1 Like

Hi there,
Just a quick update.
Now I have only one sim (Sosh) in slot 1.
If I share my connection, it works pretty good except if I use the phone.
If I don’t touch the phone, I don’t have any trouble.

Something interesting, I was calling a friend throught teams. Everytime I pressed the power button on my phone, just to see the time for exemple (without touching the screen), the connection on my pc was slow ^^

So I guess, using both the phone (app, internet) and hotstop makes the hotstop almost down…


During the last weeks I have been using this function a lot in my FP3 (not +), and in my case something similar happens: if I take the phone and download some video from WhatsApp, or surf the web directly from it, sometimes my PC loses the connection temporarily, until I stop using it. It is also true that I usually don’t have very good signal when I share my connection.

In any case, and knowing this, it is not a big problem for me. Certainly I don’t know if this behavior occurs also in other mobile phones.

Hello, same problem here: the wifi hotspot is in some ways unreliable (also Sosh).
It seems to loose the internet connection randomly, but an event that I’m pretty confident to associate with the issue is “me unlocking the phone”.

On the other hand, sharing the connection with USB works flawlessly.

EDIT: also, I don’t really need to restart everything to make it work again. Waiting a couple of minutes normally does the job.