High Disk I/O and CPU, but can't find process responsible

I’ve been having some serious performance problems with my fairphone (wait times of 1 minute or more before apps open or switching apps, and general lack of responsiveness).

I installed System Monitor Lite.

During times of poor peformance, it show’s CPU and Disk I/O getting maxed out, but no app seems to be responsible. Here’s some screenshots taken during poor performance moments.

As you can see, the system is getting maxed out, but I can’t see any process responsible.

The problem has gotten so bad lately that I’m even having trouble with battery life - the phone dies within an 1 hour.

How can I go about troubleshooting this and finding out the processes responsible?

Looks like infected phone to me

If your phone really is infected, you should probably do a hard reset.

Would you care to elaborate?

Are you running System Monitor Lite as Root/SuperUser? If it’s running without these privileges then it probably won’t be allowed to see some processes.


Jord is quite right here. We need to find out if the monitoring program is allowed to see all running processes.
If it is, then there are some hidden processes running. By my understanding, any process that hides itself from root is a malicious one.


Thanks Guys, It’s unclear if System Monitor Lite shows root processes. It
has a request root option, but only on it’s App Cache calculator page, so
it’s unclear if that is only applied to process monitoring also, or only
the Cache calculations.

Can anyone recommend a simple process monitor I could use that does monitor
root processes?

You could try OS Monitor and check the “Expert Mode” box in the settings. For me, it means that the number of checked processes rises from 45 to 160, so I guess that it captures all system (root) processes.

1 Like

you might try SystemPanel Lite

and maybe a scan with

Thanks everyone. I tried the monitoring tools, still no sign of the runaway process.
AVG also comes up clean.

Any other suggestions on how to trace this process? I’d prefer to figure out what it is and how it got there before I reset, lest I end up in the same place again a few months down the road.

Are there any tools that can give a breakdown of disk io per process?

1 Like

NSA got you :slight_smile: A complete sweep and reinstall might help, but nothing can stop them from entering your phone again.

1 Like

I suspect the NSA are sophisticated enough to not give away their presence by cranking up the CPU and thrashing the disk :stuck_out_tongue_winking_eye:


NSA might be, but they don’t write the software to do so :slight_smile:

Jokes aside I would say that HackAR is right - trying another analysing tool will probably not help. On the other hand, a complete sweep might not be necessary. I would probably try the following:

  1. uninstall the apps I’ve installed myself, one by one, and see what happens (probably necessary to reboot after each uninstall). A bit time-consuming, but with luck the culprit is found early.
  2. If this doesn’t help, try a hard reset (revert to factory settings). See https://fairphone.zendesk.com/hc/en-us/articles/201134418-How-to-perform-a-Hard-Reset-on-my-Fairphone
  3. If the problem persists, a fresh reinstall seems to be the only option: https://fairphone.zendesk.com/hc/en-us/articles/202478028-Manually-install-Fairphone-OS-software-update-version-Kola-Nut-1-8-5

Isn’t your option 2 more serious than your option 3? Installing the OS only “refreshes” the system files, whilst a hard reset also erases user data such as photos, music, etc. stored on the internal storage, or am I mistaken?

Yes, that sounds reaoonable. However, if the phone is infected so that hidden processes are running, the logical first step for me is to get rid of everything installed after the phone left the factory, i.e. a hard reset. If the problem still persists, the infection must have affected the system files, in which case reflashing ought to fix it.

1 Like

Doesn’t a hard reset practically reflash the system? I thought that during the hard reset some factory image gets flashed to the phone…

Pure guesswork from my side now (since I’m not knowledgeablem enough), but yes: if we suppose that there are some protected, read-only image files stored on the phone that cannot be corrupted, then of course a hard reset ought to be enough and my 3rd step above will be unneccessary.

I thought so. :blush: Well, let’s see how many of the three steps @Chris_Jensen needs to follow!

I don’t think so: AFAIR you can hard reset and keep GApps.