Headphone Jack/plug doesn't work


I’ve had a fairphone 3 for a few weeks. I’ve been having problems while listening to podcasts on my headphones. Every so often the headphones cut out leaving me with just some quiet clicking noises. This seems to happen when the podcast is paused and then restarted for some reason, either manually or when the headphones are disconnected and reconnected. My normal player is AntennaPod. Once the sound has cut out it affects all apps and different headphones. Restarting individual apps has no effect. I eventually discovered that restarting the phone fixed the problem.

Has anyone got any insight. Something less drastic than a phone restart would be good.



1 Like

Hi Matthew, welcome to the Fairphone Community Forum :slight_smile: I moved your post here as it seems obvious it’s about the same issue previous posters here have described. From what I have read in the forum, Fairphone is working on a firmware fix for some hard-to-explain audio issue in some FP3s. I don’t work for Fairphone and I cannot say if the aforementioned fix will affect your issue, but let’s hope so.

1 Like

Cheers. This does seem to be the same ballpark of issues. Hopefully the firmware fix will sort things out.

Hi, I got my FP3 last week and have been having the same issue with headphone audio working, and then stopping after about 10 minutes. Is there any more news on a fix?

Got mine for Christmas :slight_smile: Only issue is the audio jack. Plug headphones in and the audio continues to play out of the speaker ( and yes, it’s not the buffer). Looking forward to hearing when there’s a bug fix for this, I really don’t want to return it

1 Like

I finally got a response from FP. To be fair, they offered me both to replace the phone or ship me a top module, but by reading all the comments, this smells like a software issue. I will hang on to my FP3 (which I love in any other respect), and try to work through the diagnostics steps sent to me by support, to provide FP with a more detailed and solid issue log, hopefully being helpful in squashing this bug once and for all.

To anyone interested, here’s the troubleshooting steps sent to me today:

  1. Which build of the operative system are you using? If not sure, please send us a screenshot going to settings > about your phone > scroll all the way down till you see the build number and take a screenshot.
  2. Does the issue occur just when using a specific app? If yes which ones in particular?
  3. Does this issue happen even during calls?
  4. Which kind of headphones are you using? Please specify brand and type.
  5. Did you try with different headphones? If not please do it and let us know if you are still having the same issues. If so, specify which headphones (brand and type) don’t work.
  6. Are you using L-shaped Plug or I-shaped plug?
  7. Is the issue happening when using the bumper or without? Please test it in both cases and let us know.

Please, reboot your phone and test it again right away .
Does this solve the issue? If yes, approximately for how long?

Step 1:

When the sound stops, try raising the volume using the volume buttons.
Do you see a note icon or a bell icon?
Note icon : does raising the volume solved the issue?
Bell icon : raise the volume going to settings > sound > media volume . Go back to the app. Does it work?

Step 2:

Run the following test to diagnose the problem.

  1. Open the Phone App
  2. Dial *#*#66#*#* in the same way you are entering a phone number to make a phone call. Once the last character is introduced, the Service Menu appears showing you three sub-menus.
  3. Select Service tests > Test Single
  4. Press Earphone .
  5. Plug in the earphones to run the test. Once the earphones are inserted, you should hear a pre-recorded track. If you cannot hear it, that means it is not working correctly. To stop the test, tap Back navigation key. Choose FAIL or PASS accordingly.


After unplugging headphones, the audio is gone. Only after rebooting all is good again.

I’ve used different 4-segments plugs, i.e. a (headphones + microphone) combination. Happened with both.

FP3, Kernel version 4.9.112-perf+#2 Dec 17

Praise - and feature request

Superb phone, I really love it. Finally I could leave the S5 behind (the last L.OS fon with swappable battery. By now I had used up 5 recycled S5 lol.). Thank you very much for the FP3.
For truly sustainable phone concepts, please try to invent components which (not only replace with the same thing in case of broken but) actually UPGRADE the existing phone with more capabilities. I.e. a better camera, 2 years from now, which fits the same cam slot. Thanks for considering.

I moved your post here to avoid duplicate topics, please have a look around here.

Else … This is a community forum, not the company. Fairphone staff might read along here and engage occasionally, or not.

Please contact Fairphone support to submit your bug report and give feedback about the phone … https://support.fairphone.com/hc/en-us.

1 Like

Thanks for moving my post.

No, I won’t post this anywhere else now. But I’ve found this above: “From what I have read in the forum, Fairphone is working on a firmware fix for some hard-to-explain audio issue in some FP3s.

So I will just wait for that next update. Any idea when that might come? Since I have the phone, there was 1 update. How often do they come?


Hi guys,

I just got my new Fairphone 3 and wanted to use my Beyerdynamics Soul BYRD headphones to listen to spotify. The headphones have a build-in remote (with volume, pause and skip buttons) which worked fine on my old Huawei phone to skip tracks or change the volume while riding bicycle or something else. Unfortunately the remote doesn’t work and the headphones seem to crash the audio. So I have the same issue as well…

1 Like

Same problem. Seems to be the case that the system gets stuck in one mode (headphone or speaker), and stops detecting switches between the two. I’ve tested this and it will successfully continue playing audio in the old mode (and increase/decrease the volume accordingly when using the buttons), so it’s not that the jack or speaker are malfunctioning.

I wonder if it’s something to do with unplugging/re-plugging the headphone connector rapidly, as the somewhat loose jack connection means this happens quite frequently for me.

Also FWIW same solution: rebooting fixes it and is fast enough that this isn’t a critical problem, though irritating.


I have the same Problem, sometimes the Phone (FP3) is stuck in Headphone mode.

Now i found an acceptable solution: there are some Apps that give you the ability to toggle between Headphone and Speaker mode. It’s not optimal but way better than rebooting everytime it happens!
For me it is “Lesser AudioSwitch” but there are also other Apps.

Hope it helps some people until Fairphone realeases an Solution.


Thanks! I might try that as I have the same problem with the phone (FP3) being stuck in the headphone mode - unfortunately quite regularly, as I use headphones often…

1 Like

Thanks for sharing! I have the same problem.

Hi same problem here.

It actually fail when i use the “handfree” button on my earphones to pause the music or receive a call. I restart the phone and it works again. I think it might be that the jack plug is not made for that kind of handfree earphones. Doesn’t bother me so much. I won’t change it. Let’s see.

Hi there, I’m new so please excuse all the potential mistakes…

I have a new Fairphone 3 and I love it. But suddenly I couldn’t hear the other party when calling someone or receiving a call. Took me a while but I found out that the phone just didn’t realise that I unplugged the headphones. So the sound just goes to nowhere.

I tried plugging them back in, using other headphones, nothing… Only thing that works is restarting the phone. That is a temporary solution but I really don’t want to restart my phone everytime I listen to music and then want to call someone…

Does anyone have a similar problem and/or a solution?

Best, Angela

Welcome to the community forum!
I moved your post here to avoid duplicates. Please have a look around at the possible solutions suggested.

Thank you for moving my post! Although I find it a bit sad to find my request lined up with posts from a year ago with no valid solution… I started only using my Fairphone 3 headphones (sound quality is terrible btw especially given the price…) and will try to see if this solves it. But I think that it really is a software issue. Guess we’ll just have to wait on a software fix. Can’t take another year. Or can it…

I understand what you mean, and I understand it can be disappointing. Though you were asking:

You have your answer :slightly_smiling_face:

I think the best would be contacting Fairphone support. In any case, don’t hesitate.

1 Like

Hi there, same problem here!
Also the music sometimes stopped playing while headphones plugged in and phone was moving.

Following solution seems to work for me:
Inside the audioplug on the top is a metal piece. This was bent to the side so there was no firm connection to the audiojack anymore. I bent it back a little bit, now everything seems to work fine.

I opened the phone an took out the top module to fix it, but i think it can also be fixed without opening the phone.

See image attached illustrating the problem/metal thing: