Has anyone gotten rid of their random reboots?

Any comments on that?
I noticed that the battery symbol on the phone was still on charging, but it was unplagged, than I wan’t to kill battery charge limiter, but instead I got a soft reboot, I can send the whole log, but I only have dmesg.log

[14310.439736] 2728,14310439736;ILITEK LINE = 252: ilitek_i2c_transfer:252,  error, ret -107
[14310.498517] 2729,14310498517;ILITEK LINE = 1232: ilitek_i2c_suspend, 0x02 0x00 set tp suspend err, ret -107
[14330.521645] 72730,14330521645;init: Untracked pid 32707 killed by signal 1
[14330.572711] 72731,14330572711;init: starting service 'bootanim'...
[14330.598913] 72732,14330598913;init: property_set("ro.boottime.bootanim", "63434806567279") failed: property already set
[14330.618919] 72733,14330618919;healthd: battery l=94 v=4086 t=26.5 h=2 st=3 c=921 fc=2366000 cc=0 chg=
[14330.654330] 72734,14330654330;healthd: battery l=94 v=4084 t=26.4 h=2 st=3 c=1042 fc=2366000 cc=0 chg=
...
[14331.506186] 72761,14331506186;init: Service 'zygote' (pid 471) killed by signal 9
[14331.506280] 72762,14331506280;init: Sending signal 9 to service 'zygote' (pid 471) process group...
[14331.509406] 72763,14331509406;init: Successfully killed process cgroup uid 0 pid 471 in 2ms
[14331.594032] 72764,14331594032;init: Unable to open '/sys/android_power/request_state': No such file or directory
[14331.594255] 72765,14331594255;init: Unable to write to '/sys/power/state': Invalid argument
[14331.594405] 72766,14331594405;init: Sending signal 9 to service 'audioserver' (pid 482) process group...
[14331.599913] 72767,14331599913;healthd: battery l=94 v=4114 t=26.4 h=2 st=3 c=692 fc=2366000 cc=0 chg=
[14331.649122] 72768,14331649122;healthd: battery l=94 v=4113 t=26.4 h=2 st=3 c=734 fc=2366000 cc=0 chg=
[14331.683006] 72769,14331683006;healthd: battery l=94 v=4106 t=26.4 h=2 st=3 c=749 fc=2366000 cc=0 chg=
[14331.726725] 72770,14331726725;init: Successfully killed process cgroup uid 1041 pid 482 in 132ms
[14331.729502] 72771,14331729502;init: Command 'restart audioserver' action=onrestart (<Service 'zygote' onrestart>:3) returned 0 took 135ms.
...
[14331.921360] 72824,14331921360;init: starting service 'zygote'...
[14331.950181] 72825,14331950181;init: property_set("ro.boottime.zygote", "63436155478111") failed: property already set
[14331.951102] 72826,14331951102;init: starting service 'audioserver'...
[14331.951213] 72827,14331951213;init: Created socket '/dev/socket/zygote', mode 660, user 0, group 1000
[14332.018942] 72828,14332018942;init: property_set("ro.boottime.audioserver", "63436185498007") failed: property already set
1 Like

There is a quick and stunning simple way to get rid of those random reboots:
Switch oft FP2 and buy a Samsung A7. Works perfect and btw it solves many other FP2 issues.

Keep on rebooting, felliows!
KP

1 Like

There is a quick and stunning simple way to make sure you don’t come across as somebody who can’t even search the internet:

https://www.google.com/search?q=“samsung+a7”+reboots

5 Likes

Thx. I’ve been using 2 FP2 in the family with random reboots and many other issues. Ever since I use (as before the FP2) Samsung phones, I had none of these issues. Just because it can be found in the internet doesn’t mean I have to have these issues. With the FP2s we have all that stuff on both phones.

It quit wasting time in looking for hints, clues and workarounds to use a mobile phone. i want to USE it, not REPAIR it half the time.

All the best.

KP

I’m glad you found a phone which works out well for you.
But just because it works for you doesn’t mean it works well for everybody who buys one. Sadly.

And just because my Fairphone 2 works without random reboots for me doesn’t mean it works this way for everybody who buys one. Sadly.
Posting in problem topics something like “Get a working phone like mine, then!” doesn’t help much, whatever phone you want to recommend.
You can run into trouble with every smartphone potentially.

9 Likes

We are supporting the fruit of a movement here at the forum, everybody who likes to have support is welcome, even you @kpzeyen, if you want to come back some day. Just keep that in mind.

4 Likes

This is working for me…
Since upgrading to Android 7 I have been plagued with reboots and have tried most of the things suggested in the troubleshooter but couldn’t find anything to work. Then I remembered I had the same problem when I first got my FP2 about 3 years ago. A fellow android user (Samsung) said they had to clear their cache of the Gmail app because of known problems. I tried it then and it worked. I’ve tried it now and I’m on day 3 with no reboots. Hurrah! :crossed_fingers: I’m hopeful :wink:

4 Likes

Hmm… something I didn’t tried until now :thinking:
Done that! Will report her, how my phone reacts.

Edit: Nope, didn’t helped :frowning:

I’m seeing these random reboots since I installed 18.09.02
As far as I can tell they are not linked to any app. They do occur more often if the battery is full in my case.

I’m a bit sad that we don’t hear a lot from the Fairphone developers. These reboots are killing the Fairphone experience and it should be of the highest priority to fix these.

Not everybody has random reboots.
#contactsupport if you think it’s hardware. And …

Even if these random reboots affect only a part of the fairphones, it should be a high priority issue.

I do not think it is hardware, prior to upgrading to Android 7 it only occurred a few times and it was gone the moment i reseated the battery. I reported my issues in the bug tracking system, but very little feedback. But I will contact support anyway to see what they say.

I will read this thread later. I’m at work. I was just trying to console my wife who phoned with news of a death in her family, when my FP2 decided to reboot. Next time, it’s on eBay.

i have successfully fixed my reboot issues:

i cleaned the on/off switch with isopropyl alcohol now reboots are (mostly) gone

I left the switch in place and soaked it with alcohol. pressed it repeatedly. then sucked the alc off and blowed with compressed air (gently)

I guess at some point water with dirt made its way to the switch and stayed there to annoy me :slight_smile:

hope it helps…

4 Likes

that’s interesting! you’re talking about the power-button on the phone, not on the removable(?) part of case, that pushes that button right?

Ok - to update - my reboot situation has returned although perhaps not as frequent as before. I’d like to know more about how to clean the power switch.

I’ve been doing some tests with my Fairphone and the results look pretty bad.

  • I took out the SD-card, the SIM-card and the case of the phone and then just waited (used another phone in the meantime). Three days without a reboot (I usually get at least one reboot a day).

  • Put the SD-card back in, got a random reboot in under a day.

  • Took out the SD-card, put in the SIM-card in slot 1, random reboot in under a day.

  • Put the SIM-card in slot 2, reboot in under a day.

:sob:

How much is a new core module?

Maybe try the same experiment with a new SIM card (like one of those free ones they have at kiosks) before spending your money on a new core module. It could be an issue with the card rather than the phone, and a new SIM card from your carrier is a whole lot cheaper than a new core module.

1 Like

Yeah, I was gonna do that next but I’ve been using two different SIM-cards for a while now since I’m often in the UK (insert Brexit-joke here +_+), so I’m not really hopeful that it’s about the SIM-card … But yeah, I should definitely double-check that before thinking about buying a new core module ^___^

Welp, my UK SIM-card almost made it through three days in slot 1. So there definitely seems to be a problem with the simcard slots. Which is super annoying, I could live without an SD-card but a SIM-card would be nice to have :sweat: … Gonna test case(s) now, just to be sure and them maybe more SIM and/or SD-cards.

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.