GPS fix takes very long after update (with e.g. and GPSTest)

Try indeed GPSTest (or some similar app). Now don’t expect too much from those “assist data”, they only speed up the GPS fix and allow a better precision; If I understood your situation you’re kind beyond that… :frowning_face:

But running it will allow you to see what exactly the problem might be, to see if your phone is able to see any identifiable satellites, if yes if it can calculate a fix out of them, and if that fix is stable, or if it loses it immediately (before a navigation app could start making head or tail of it. Had this once, after a GPS date roll-over).
Knowing this might point to what has gone wrong.

1 Like

I don’t understand much about this topic but this trick helped me and the location fix is now relative fast and before I wasn’t able to even get one.

Note that it took a day or something like this after “clear assist data” until the first fix was fast (<1min). Maybe the data was corrupting or irritating the device. Really strange and unclear why this is necessary at all. Maybe it was related to the fact that I had to disable 5G after the Android 13 update (due to frequent crashes again).

1 Like

In this case it probably means it was just a coincidence…
Oh well, the important thing is that your GPS is working again!

You probably know how GPS works: Your receiver (phone in this case) receives signals from several GPS satellites with very well known orbits, and by calculating their distance (“it sent this at xx:00, I received it at xx:01, given the speed of light the satellite must be at x km from here”) it can calculate the distance between itself and those satellites.
Now having the distance of several satellites (you need > 3) allows it to calculate a “fix”, i.e. its position on the map. The more satellites it can identify and localize, the more precise will that fix be.

Now if the GPS receiver doesn’t know where on Earth it is right now, it will take a lot of time to identify the surrounding satellites and refine its position till it knows where it is for sure. That’s what those “assist files” (Assisted GNSS) are for, they help it get a fix faster.

Meaning that even without them, it should, eventually, understand which satellites it is seeing, and calculate a position. The worst thing which could happen is that, if for some reason those kickstart files gave gone stale and contain (now) incorrect information, trying to use them the GPS will take a very long time to get a fix. That’s why everybody suggests clearing them and reloading them (they are just smallish data files), just in case.
Hope that clears things up.

1 Like

at least in my case the problem seems to be fixed. It was apparently caused by weak signal strength. Inspired by another thread in the forum about high battery consumption by the mobile data app I disassembled my FP4 and noticed that the speaker module and the Camera module have small contact springs (3 at the speaker module and 2 at the camera module) at the rim which contact the antennas which are built in the housing. I carefully cleaned both the contact springs and the contact points at the housing, gave the springs a bit more tension and assembled the FP4 again.
Now it takes between 5 and 15 seconds to get a fix after switching on GPS :slightly_smiling_face: and it keeps correct GPS time.
Greets Robert


Sounds interesting. I have no idea how the antenna might look like. Is there some pictures/drawings or videos showing what to do? My FP4 suffers from bad GPS performance, maybe this is a solution.

Neither do I, but I guess it’s some part of the metallic ring around the edge of the phone, so as @melzrob said, look for some contact springs between the modules and the housing.

I marked the contact springs with red frames in the following pictures:

Greets Robert


Thanks for the picture, that’s great. I removed the components shown there, cleaned the springs and bend them sligthly.
As a result it looks like I have an improvement in the performance of the app (one test so far). Before I say its fixed I would like to run some more tests.

1 Like

Last week, I once again had a problem with GPS. This time, even Google Maps didn’t work. I tried injecting assist data (the time was correct) through GPSTest but it didn’t help. I eventually had to restart the phone and after a while it caught up. Which really isn’t ideal since I was in a hurry and really needed the navigation to just work. :unamused:

I recently had issues as well again, just tested it now and again no fix at all after minutes in the App GPSTest while the FP5 has a fix in seconds…and even a reboot does not help

So beside trying with the GPSTest app I did the GPS Test in the internal testing menu on both devices as well



While I also had a lot issues with the FP3 I never had so far with the FP5… Not sure if FP changed something to improve what they dont tell us or bad luck with FP3 and FP4 for me and a hardware issue…

Finally I have a fix after around 10 minutes, however very few sats and the Time is correct, so rather a different issue?

Hi yvmuell,

that’s what the testing tool shows at my FP4 (inside the house, no window open) after I cleaned contacts and bent the springs as described above:

So maybe it would also help with your problem?

greets Robert

1 Like

Thanks Robert I noted your post and at least opened the FP and took out the bottom port, maybe bent a bit the springs (I was overcautious as I tend to break such tiny little things :upside_down_face:) and put it back together. I did not take out the camera module though. I think after that it was also not very good. However today it found within seconds a fix with many satellites (same place, inside, even farer away from the window) and the FP4 was here at this same place since the failed test. So should that issue turn into a permanent one I might check that again, or contact support instead…

My problems are back. It seems that a normal application (browser, maps) requiring location is no longer able to get a GPS fix. I tried for over 30 minutes in different situations on different days and different apps (including restarting, waiting for the new update etc).

The only workaround that seems to work is to start GPSTest. It takes 1-2 minutes, but afterwards the location seems to work in all other applications too. So it seems to be a software issue. What a mess … :frowning:

I also have a lot of problems with GPS and my FP4. It’s very slow and/or unreliable.
I am running CalyxOS.