English

GPS doesn´t work on FP Open OS

I updated to 16.06. My OsmAnd~ is still unable to find my location in high accuracy, which means that neither the WIFI, mobile network or GPS are providing my location. SatStat shows 2 satellites and WIFI networks, though. (Will try outside of my building if I see more satellites so that GPS can get my location).
Is any of you able to find the location via WIFI or cell network? Are you only facing problems with the GPS?

I am able to acquire a signal via wifi and celltowers using UnifiedNLP (on FP Open OS 16.05). However, since GPS is not working at all, switching between “device only” and “high accuracy” seems to cause problems with last known position registered in system which leads to nonsense behaviour on high accuracy (which is in fact wifi and celltowers only for me)

Since 16.05 coarse location works for me. Osmand, satstat and a few other apps all get a location (correct one…). In 16.05 GPS did work for me (but I changed GPS.conf). Had not yet time to test gps, as in the house I can’t get a fix. Walls are too thick

Just installed 16.06. Osmand still not working with gps (I got NO openGAPPS)

With the versions 16.04 and 16.05 i had no gps.
Saturday i installed 16.06 and tested the cycling app komoot and it showed directly the correct position. After a restart of the phone i was stuck in the fairphone powered by android screen.

What I noticed and what I want you to think about:

The thread-topic contains two terms, which have not much to do with each other:

GPS and GAPPS

GPS is able to show your location via satellites, GAPPS via network. Both go together with the location-item “high accuracy”, but both work independent from each other.

The topic says “GPS doesn’t work”, so it would be better for solving the problem, if you all talk about “GPS” - that is “device only” in your settings and not mix both ways of location.

Set your phone to “device only”, go outside with it to a location under free sky and use eg. “Satstat” (F-droid). It will take up to 5 minutes at the first time to see satellites and you can follow the process with Satstat. If this app shows no satellites after that long time under free sky, then you can say: “GPS does definitely not work”.

Spielmops

3 Likes

Good point.

I created that topic title. At that point everybody who did have those problems with GPS used Open GAPPS.
Does GPS not work for anybody whos not using GAPPS?

:point_up_2:here! I installed microG instead of GAPPS. I got unifiedNlp working, but on ‘device only’ in the settings, there is no way I get my location

Have you been outside with your phone for 5 minutes under free sky with “device only” in the settings?

I do have openGAPPS installed, but I only use GPS for location (never used network before), and can confirm that GPS works on 16.06; at least with Oruxmaps (as it did on 16.04 as well; never tested on 16.05).

As I lost the changes I made to the gps.conf by updating the Fairphone to 16.06, I now made a copy of the gps.conf on my sd-card. So that I can copy the file, instead of making all the changes again.

What changes except intermediate pos did you make? You can easily change that with FasterGPS btw.

1 Like

These changes I also made.

1 Like

I had the problem with UnifiedNLP. It seemed to sometimes get stuck provide bogus/no values in “high accuracy” mode and did not let gps values through. When I uninstalled UnifiedNLP the problems disappeared. Sometimes it helped when i switched location mode from “high accuracy” to “device only”. I can attest to the fact that no gos.conf fiddling is required to get gps working on FPIS 16.05/16.06.

Gps not working as well here (fposos 16.06). Satellites can be found but it takes way too long (more than 5 minutes at least) and as soon as I turn off the display or just switch from osmand to another app the signal is lost again (gps symbol on the top bar disappears as well). Very annoying.

PS: Just to add a few details:
I have no NLP stuff installed, OS is not self-compiled, opengapps pico is installed but play store and google service are disabled. It seems to make no difference if I use gps on “high accuracy” or “device only”.

Same problem persists on my phone… it seems that there is no coherence how the problem appears… sometimes it takes 3min sometimes 15min to get a fix… I really doubt that there is any correlation to installed apps/software including unified nlp or Xposed. Probably to some missing. Somtimes I suspect the binblobs because of this intransparent behaviour of a gps-module which works and doesn’t work at the same time. Can’t say if its broken like for replacement or not…

I’m on Fairphone open 16.06. Installed µG unifiedNlp (NoGAPPS) from Fdroid.
GPS works on ‘device only’ and Osmand~ (takes about a minute to get my exact position).
Whait i did was change gps.conf “intermediate_pos=0 to 1” and the workaround described by ‘Unified NLP on Fairphone 2’




Have two backends installed ‘LocaGsmNlpBackend’ and ‘LocalWifiNlpBackend’.
First backend works but LocalWifiNlpBackend doesn’t seem to store any Acces points.

Same here. FPOS easily takes 10 minutes to find any location while satstat shows a 10/16 fix all the time. When I shut off the displaY it starts from scratch and takes another 5-10 minutes. Very frustrating, that is.
No gapps i stalled. No unified NLP installed, just gps enabled.

Have you downloaded a database? local = offline = needs a database

1 Like

Hello, It works now but the GPS needs to find your location first (can take a while) ,the moment the GPS has your
location then it starts recording the AP’s in your area so LocalWifiNlpBackend doesn’t need a database, it creates it’s own.
I think i was a little to impatient before.

For LocaGsmNlpBackend I made the phone build it’s own local database with Mozille Location Services enabled ( took about 2 hours to create it and you need a steady internet connection). Didn’t use Opencellid because it always gives an
error while building the database.

1 Like