GPS accuracy is not given

More details please.

What are your GPS settings? Wifi and/or/xor GPS?
I think most of the “GPS fix in seconds” cases are due to an active Wifi connection and localisation via GPS AND Wifi.

Have you excluded actually bad GPS signal? (No buildings/roof/trees/whatsoever around you).

Sorry for the maybe stupid standard questions.

Spielmops uses his FP2 with GPS only (standard) and compares the accuracy with a Garmin Etrex Vista (handheld navi). Fix is seconds later than the Garmin, accuracy ist ±2m within free area and good weather (same as Garmin).

I have an issue with GPS as well. But I’m running the OpenSource version of FPOS, self-compiled. And I patched the sources to use Unified NLP.

It takes a while to acquire the satellites. And I observed that once I stop the app requesting GPS data, and restart the app or start a different app using GPS, the GPS satellite acquisition starts over again.

I guess something is wrong with saving the last position, thus requiring a full reacquisition of satellites. And this takes quite a while.

Might this be similar to your problem?

1 Like

Hey folks,
first of all, many thanks for the fast replys.
Ok, more details are needed:

  • my FP2 is on Android 5.1, build no.: r4275.1_FP2_gms36_1.1.7, kernel: 3.4.0-gcd7fdcf
  • for a better accuracy normaly my WiFi is on (OS settings: high accuracy) - but in case of trouble to be inconsistent with one another I tried to change not only all OS settings but also each hardware setting, e.g. only GPS / GPS + WiFi / GPS + WiFi + mobile data / GPS + mobile data => without better results
  • for testing in the best case - actually I am on top of the Erz-Mountains without any clouds or buildings nearby. The best condition for trinangulation with 3 GPS satellites. Accuracy is +/- 40m.
  • @root: the problem is, that I couldn’t get any fix with any GPS app. And if I get a fix after 3-4 minutes, a few seconds later the fix crashing down -> with the same app.

I generate screenshoots with the two GPS checker apps: GPS Test + GPS Status, so that you can see the results of the apps.

“GPS Status” gets never a GPS position.

“GPS Test” holds the GPS position for seconds, but also the position crashed after seconds. Here you can see the accuracy in the right upper corner - its gray because of no signal - I was too slow with the screenshot. You can also see the measured GNSS signal strength of the satelites which are in view. Compared to my old Samsung Galaxy S2, the strength differs over 30dB and in the used satellites, which are between 4 and 8 in the S2.

UPDATE: I installed the GPS Test also at my girlsfriend smartphone (SGS3) and tried it at the same place, with the same settings and the same environment. Here the different screenshots:

“GPS Test” on SGS3

“GPS Test” on FP2

It would be great if anyone of you have still an idea whats going on.
thank you for your answers

Result after holding my FP2 out of the window for some seconds:

The sudden position crash occured once. But this is a known issue of “GPS Test” and not necessarily a problem of the phone itself.

Your very poor signal however. As I assume you dont cover your FP2 in tinfoil or attached a nfc sticker right above the GPS antenna - its maybe a defective module. I think the best is to contact support.

Hey bfb,

thanks a lot for your effort. Yes, your results seems obviousely better. I followed your advice and opened a ticket for the support. I hope they could help me.
If the support has an answer for this (and its general enough) I will post it here. Also I will give a notice if it was a special problem.

best wishes

1 Like

since I have experienced very similar issues as @uli, I just wanted to ask if there are any news or progress regarding the slow and poor gps-fixing issue?
My situation is a little different from @uli’s because I live in a city with a high density of buldings. Though I had better gps-experiences with my three previous devices.
What’s aching me most is the fact that some apps can’t make use of gps at all. Like Ventoo, a bike-computer app with simple logging and monitoring. I don’t get one fix during my whole 25mins ride to/from work. On Maverick, where found sattelites are always shown on a grid, I get fixes in about 2-4min while I wait for the kind of shy sattelites to appear

Hey Yataro,

on 28th March I wrote my support request about the above mentioned situation. On 13th April I’ve sent a request because of a missing answer. On the 19th of April I’ve got an standard answer (with an apology and they give hints to support articles) and the instruction to contact the the support again if any proposals won’t work.
On May 4th, at I contacted the support again with the issue: “I experience a problem / My product is broken”, but unfortunatelly with no answer until now .
Even I suggest that they send me an new GNSS-modul and I will change it by myself.

Thats the status quo. @anon48893843 can you help me?

Best Uli

Thanks for the quick answer. I sent a support-request today too, we’ll see…

When the battery of my FP1 started to bloat, the contact to the support was very quick, personal and satisfying. I can imagine that they’re just very busy right now. There must be loads of work to do at this moment.
Gute Nacht

Hey Uli, thanks for explaning and our apologies for not responding earlier. I’m going to make sure that you will be offered a solution (a working phone) today! Thanks for your patience.

Hey, replied to your message while I was at it too. Good to hear you had a former positive experience :slight_smile:

Let’s make it two :slight_smile:

Hi everybody!

Same problem here. I have FP2 with the latest Fairphone OS version 16.06 installed. The no fix problem has appeared after the last update, that I’ve done yesterday, before the GPS was working fine. Yesterday I went for a run and it was impossible to obtain any kind of GPS fix with Strava. GPS status was reporting up to 16 satellites available but I never got a fix. I waited almost 30 minutes. I’ve tried also to reset the AGPS data and clear cache but without any results.
Did you have received any suggestion from the support yet? I’ll try also today to get a fix, otherwise I’ll contact the support too.

Best regards,

Hi Claudio,

that seems that your problem occurs through a software update and less through a hardware error, like in my case. My situation was from the beginning of lifetime of my FP2.
Maybe there is a way to reset your last update and use the previous version as long there is no further update.

Best Uli

There’s a discussion of GPS not working properly in Fairphone Open OS, but that seems to be general to the 16.X line. Did you by chance you actually switch from regular Fairphone OS 1.x.x to this version in the update you mention? This post, which explains how to distinguish GPS and software problems using ‘device only’ location access, seems to be a relevant place to pick up on the discussion:

Hi Johannes!

Yes I switched from the standard Fairphone OS to the Open OS. I have used the Fairphone OS for almost a month (I’ve my Fairphone since mid-april). GPS was working flawlessly. Then switched over to the Open OS to get rid of much of the unused google apps and have root access. And since I cannot get a fix on my GPS. As a solution I’ve installed FasterGPS and tweaked my GPS settings as suggested in another topic on this forum (GPS doesn´t work on FP Open OS). I’ve set the NTP server for my country, changed the INTERMEDIATE_POS value to 1, and added XTRA_SERVER_1 to 3 .

After all that I could get a gps fix if I set my gps on device only and after waiting between 10 to 20 minutes. If I set the location option to High accuracy is impossible to get any kind of fix. At the hardware level I think that there are no problems because both GPS Status and GPS Test shows the positions of the available satellites. From the location where I tested my GPS there are always between 16 and 22 satellites available. From the same location my Garmin edge unit doesn’t take more than 2 minutes to get a lock.

Many thanks for yours replies,

Good save the patient users ![quote=“Claudio_Brenni, post:17, topic:15997”]
both GPS Status and GPS Test shows the positions of the available satellites
[/quote]but no position? Is so, then it must be a calculate error/bug …

A post was merged into an existing topic: GPS doesn´t work on FP Open OS

Problem solved with the upgrade to Fairphone Open OS 16.07.1 and with a new version of the pico GAPPS package (the 20160820).

now accuracy and fix occurs in maximum half a minute and goggle services doesn’t crash any more when the location is turned on.

I recommend to all having this problem to upgrade to the newer version, it resolves not only this bug, but improves on a lot more glitches and small problems that I was experiencing before. Since Saturday no more sudden freeze and screen glitches :grin: