Google sync lost after update

Same here.
Installed 1.8.7 5 days ago.
Installed Google apps as per every update
WiFi gray until new app installed
WiFi blue at present but ##426## still show not connected to GCM
No push notifications at all. Manual email sync required.
Tried all suggestions found online but no change.

Please get us some kind of official update on this problem.



I have the same problem.

If you want an official update, you need to contact support. This forum is not for official answers by the Fairphone Team. The community moderators (like me) are not employed by Fairphone.

1 Like

I am just reinstalling the google apps again, although I did this during the upgrade. Didn’t help.

Here’s a workaround, which helps until the next reboot:
Klick on the left “button”, go to “Manage Apps” and search for “Google Play services”. Then uninstall the updates. Then, the WiFi symbol gets blue again, and you receive a warning, that the gmail app won’t work if you do not update this app. So you update this app again.
Gms is responsible for this misbehaviour, and unfortunatelly sometimes something crashes and the WiFi symbol gets grey again.

Hi Stefan,

You misinterpreted my request: I was sending a general plea for a direct response from the Fairphone team. Since this certainly appears to be the “official” Fairphone community forum, hosted and maintained by Fairphone, it seemed reasonable to assume Fairphone might respond publicly in the case of recurring issues with major upgrades. However, since my assumption appears to be incorrect I retract the request.

I will contact support directly as you suggest.

Thanks for your clarification.


1 Like

But you did mean “an official answer” with “an official update”, didn’t you? :slight_smile:

You did not read the official Welcome Banner, which is displayed, when you first visit the forum: :wink:

My bad Stefan!

After almost 21 years of Internet services hosting, and various online activity, I really should have read the Banner :blush:


Never mind haha :slight_smile:

@all: I was just thinking: Did anyone of you try to run the Fairphone OS 1.8.7 update again (not just the Google Apps installer)?

To do so, go to the Fairphone Updater app > Advanced Mode > Android for Fairphone > Latest version > Install.

Does this solve the problem for any of you?

Edit: Apparently this does not solve the issue, as @Mark_Tiramani states here.

Hi Elise_Ross,

Your tip worked for me !!

Obviously this may not work for others, but it is the only thing that brought Gmail push notifications back to life for me! Many thanks!!

I went to “Apps” -> “Google Play services” -> “Uninstall updates” -> clicked “OK” then “OK” again at a second warning: “Do you want to replace this app with the factory version?”. The app is uninstalled and a notification appears stating that “Gmail won’t run unless you update Google Play services”. Touching this notification brings up the GPs screen to “UPDATE/OPEN” GPs. I updated GPs and the notifications were fixed. But after a reboot the WiFi icon is grey again and GPs has to be reinstalled to reactivate push notifications. For now this is at least a working fix since I rely on the push notifications for work.

The first time I did this the phone notification mentioned “Maps” the second time it mentioned “Gmail”. I have no idea if this is of any significance.


1 Like

I’ve tried this already and it didn’t work. Elise_Rose’s solution doesn’t seem to work for me either.

Found another thing that worked for me: apparently, sync was disabled for the ‘primary’ inbox after the update. To change this, go to settings for Gmail, then click your account, then ‘manage labels’, then ‘sync primary’. I receive updates from gmail again. However, I also noticed that ‘android device manager’ doesn’t ‘see’ my Fairphone anymore when I try to access it from a computer. Anyone with the same problem?

Could this be related to the loss of the Android-ID?

1 Like

This seems to work for me aswell! Thank you so much.

Hi. Basically I ran the updater again (Apps/(ALL)Fairphone Updater/… and as it was installed already the only thing I missed on the installation time was to press the red banner about GoogleApps. All seams to be back to normal.

Hope it helps.
Thanks Stefan

1 Like

Re-running the Fairphone 1.8.7 updater did not work. Do not do this if you already have push notifications working temporarily!
It actually broke push notifications again, and this time the Google Play services reinstall does not fix it. Bummer.

The SL Push Tester app works fine. The WiFi icon is blue. But no push notifications come through for Gmail.


It worked! It was simple… thanks a lot!

1 Like

I followed the instructions on, after another reinstall of the update and the gapps.
For now, android device manager works again, and I also receive push notifications from Gmail

Hello! I have the same problems and many more… I wrote an e-mail to the support many days ago, but no reply… So: Sync of my contacts/calendar etc. stopped working even before the latest system update. All my contacts and calendar entries got lost after the update (Kola Nut 1.8.7). Can’t import them from the cloud although sync is activated. Password is correct! Deinstalled and recreated the Google account several times. Made the system update a second time, didn’t change anything. Can’t download any apps because of the storage problem. (So my mail app doesn’t work any more anyway. And I already had to delete several important apps because of the alleged lack of storage.) Can’t do the repartitioning of the storage because I can’t make a backup of the phone because my computer can’t “see” the phone (I already tried several USB cables). I’m rather desperate and really don’t know anymore how to solve all these problems… PLEASE help me!!! :frowning: Thanks.


Do you use a Mac, Linux or Windows?

The trick with the Labels worked for me (my wife’s phone). :smiley:
In our case only the “sent mails”-label were synchronized… :confused: