Google play store won't update any application anymore

Hi it must be after the update but I haven’t seen it before yesterday:

When I go to the play store and try to update applications (which it should do automaticaly) it shows errors and failed dowloading.

Any ideas?

I have about 15 applications waiting to be updated…

Can you relate the specific error message? (I know it might be difficult because it vanishes quickly, but I think it is probably relevant to solve the problem.)

Nothing in particular… I press “update all” and then “error downloading apk” and then “application google store stopped functionning”

Did you restore your apps from a backup, or did you download them again from the Play Store?

If you used a backup, please tell us which app you used, and if you restored also the Google Apps from it, and if you restored your old Android ID.

BTW, are these paid apps, or are free ones among them? Did you try uninstalling/reinstalling one of them?

I downloaded them from the fairphone updater… and now I tried again but the updater stops functionning…weird

Did you check if your phone is still linked to your google account after the update?
(Settings > Accounts [ > Add account, if it’s not there])

Yes every other google apk worked fine… until now… I re-installed the upgrade and now I can’t install google apks… great!

Ok now nothing works… I did the fix for the google applications but the updater doesn’t install anything and crushes…


Would you be so kind to explicitly answer our questions, rather than just writing that “nothing works”?

We could probably help you if we knew more facts.

If you read me you’ll see I answered every question you asked…

Anyway, I did something that seems to be working: as I had manually upgraded last time (the upgrade that was very problematic so it was abandoned 1.8.2), I went back and used this manual upgrade. Then I reopened the upgrader and I upgraded a second time to the 1.8.5 and also installed the google apks from the fairphone upgrader. So far so good, everything seems to be working but I felt like I wanted to throw my phone out of the window!!!

Crossing my fingers now… :wink:

This topic was automatically closed after 5 days. New replies are no longer allowed.

I thought everything was working fine but I just realised that not one application is updated via Google play.

I had lots of trouble getting Google play to function but now I’m back to square one…

When I press “update all” I get "error downloading apk (any apk). All my apks are on the list to be updated.

I reopened your old topic and moved your new post here. Hope you’ll find a permanent solution soon.

Thanks… Maybe it has something to do with the storage update (I can’t download any application “not enough space” message).

I’m completely lost: have 1st edition phone, had done “storage update” routine that worked but since last update not enough space and not possible to update apks…


I know what happened… and I feel kind of stupid… As I had trouble updating to kola nut 1.8.5 I had 4 versions downloaded that used all available space!!

So everything is OK now (I think) :raised_hands:
sorry about my panic alert!

No… Not again!

It’s happening again!

None application is updated.

I push “update all” on Google play and I get the message “failed downloading…”. It’s not a storage problem this time. I don’t get it…

I don’t seem to have my phone working completely without problems…

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.

Help please!

I don’t understand what’s happening… :frowning_woman:

Ok did a final attempt to download google apps and it worked! I don’t know why and I don’t know how… just like last time!


Now I’m back to my old problem… I can’t update any application via playstore. It says there’s not enough storage space but there’s more than 550 MB available…

Just after the intallation of the google apps some of the apps got updated… and then it stopped again… :no_mouth:

I don’t get it… I’ve been struggling with this for months now…

Have you got a FP1 (First Edition), and if yes, have you already got a unified storage?
(Unified storage means that your phone storage is NOT split into a ‘phone storage’ and an ‘internal storage’)