Google Play not starting

I got my FP a few days ago. The first thing I did was the update then proceeded to install Google Play on it’s own.

I have successfully installed the app but it won’t start. I see a window open and quickly close again.

Any one else experience this?


1 Like

Hi, I did the same.
Same result. Even after I installed google play services (apk) it keeps crashing.

Is there a possibility to install/run only the Play Store without all that other (for me unnecessary) stuff that comes with the stock GApps-Installer?

Thanks in advance :wink:

I am currently using the amazon app as a work-around, but it does not have everything.

Hi all

There are numerous posts on this forum about issues with the Google Play store. I’ll list some, maybe there is some useful there. The problem could be related.

Kind regards


1 Like


I have read all of these before I posted and tried all that others have reported to have worked.

  • reinstalled a few times
  • cleared the cash
  • I have tried to install different versions of the APK file as well.

In the end my problem is slightly different from others as:

  • the install completes
  • the application starts
  • but the screen never stays on top

I have resolved this issue. I had to install ALL the of the Google apps which I was trying to avoid or do one at a time.

This is not a great problem but I wish there was a more fine-grained choice with the Google Apps. Now I have to investigate all ofthe ssecurity changes that have occurred.

Could someone explain all the changes that installing the Google App pak does. It seems to have changed some Fair phone settings as well.

1 Like