Google Play broken by the last update

Google Play worked. This morning, I ran the Fairphone Updater (I am now in Android 4.2.2). Now, Play displays “No connection” and a button “Retry” (my phone is in french, so these are approximate translations). I do have a connection and other Google apps like Gmail work fine. Clicking on Retry just brings the same message again.

There is also an annoying popup which displays my Gmail address and “use a code” (a promo code, apparently), “parameters” and “help” (a general Play help). I cannot get rid of it. Not sure it is related.

Is it part of a leftist plot to force me to use Fdroid and only free software? :slight_smile:

Hi there @bortzmeyer,

Perhaps you could post some screenshots of the issues (French is fine :slight_smile: ) so we can see the problem ourselves, this way it"ll probably be easier for us to help.

Kind regards,


I presume that you reinstalled the Google Play Store after updating? (If not. see )

I encountered something similar (‘No connection - Retry’) a few weeks ago (before updating from Fairphone 1.3). I solved this by clearing cache and data from the Play Store app. I had to do this twice, but then everything was back to normal.

More on the subject here:


Deleting and reinstalling Google Apps (first link sent by kgna) worked. Thanks to all.

1 Like

Glad you sorted.

This topic is now closed. New replies are no longer allowed.