Google Calendar problems

Hi all,

I’m not technologically minded, so need some dummy steps to help solve this:

I’ve tried all the suggested solutions here: and Sync Open OS calendar with Google Calendar

With no luck.

My problem is that I add events to my google calender on my phone, and they don’t show on my PC when i go to my google calendar. And visa versa.

This must be something that has happened recently, as older events and reminders were syncing…

The phone is a Fairphone 2 Android, with Fairphone Open Source OS. Phone has installed all FP2 updates. I have google play set up and working OK.

Further information can be provided…

Thanks for your help


I don’t use Google calendar, so I have not experienced this first hand. But it seems to pop up more often here.

I see you use the non-Google rom but you have installed some kind of GAPPS? Which Google services did you install? Have you checked all your synchronization settings? Do you use the Google calendar application for checking?

I think first you have to make sure it runs the way Google wants you to use it before you try to “work around” it.

What is a non-Google rom? I’ve installed google calendar and gmail,plus I use Play for all my apps. I’ve tried to find the sync settings, going through the instructions in the below link a couple of times, but with no luck.

It does not come with the Google services pre-installed. FP sends their Google roms to Google for testing to ensure all Google services work fine.

For the non-Google roms you need to install the Google services “GAPPS” (or mircoG later) if you want to use some extra features provided by the Google cloud stuff. Some things have open interfaces (mail) other get those removed more and more so this can cause issues (calendar)?

The link I posted describes the sync settings and how to get there. Do you have problems finding the sync settings or have you found them and they just do not work?

Quote from the source above

Check that calendar is synced
Open the Google Calendar app Google Calendar app icon.
In the top left, tap Menu .
In the top right, tap Settings .
Tap the name of the calendar that isn’t showing up. If you don’t see the calendar listed, tap Show more.
At the top of the page, make sure Sync is on (blue). You’ll only see the Sync setting for calendars you’ve created, but not your primary calendar (this is usually called “Events” unless you’ve changed its name).
Note: It might take some time for your events to show up after you turn on sync.

Hi Richard,

did you check if you are using the same Google account?
You can select which calendars are used in the settings of the calendar app.

Problem sorted, thanks for your help.

I logged onto the gmail app and enabled auto sync. This had been disabled when I went into power saving mode a few weeks ago, but not enabled again

Get Outlook for Android


This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.