Google Apps keep reinstalling/ reactivating

Assuming this is Linux …
If you used the adb command your Linux distribution already had installed or offered to install via packet manager or Software Center of some sort, please try again with the adb command from the current Android SDK Platform Tools.

Else …
“Uninstalled” Apps may still be listed in the App list with a note that they are not installed for the current user. If that would bother you …

Could anybody please explain me how to do this? Which buttons I have to press?
I can’t find that. Or is it just working on stock Android and not with the /e/OS Android?

I disabled some Google apps manually (in Settings -> Apps -> Single app -> Disable) a few months ago. Even when at first they keep reactivating many times, after one FP update, they stayed disabled for many months. One or two weeks ago I updated the phone, and a few days ago Chrome app reactivates itself one or twice a day, usually during night (when I set plane mode) and in the morning also it’s my predeterminated browser. The weird think is that this only happens with Chrome, even when I have Calculator, Duo, Gboard, Google, Google Play Movies and Youtube Music disabled :frowning: . It’s just me with this issue? :thinking:

I’m not really comfortable conecting the FP3 to the pc and activating debuggind mode… I think I should be able to decide which apps I want to use and which I don’t (even when I can’t delete it, at least deactivate it).

1 Like

Someone at Google headquarters just laughed out loud :slight_smile: .

5 Likes

I observed exactly the same behaviour and got so annoyed after a few days that I eventually enabled debug mode and uninstalled Chrome… It’s really an easy process and can only recommend to do the same.

2 Likes

Finally I didn’t try that, but I found a “solution” for this problem after looking for it in the internet:

I had the same issue, and found a solution that may work for you guys. When you go into settings to disable the app, only disable it. When it asks to replace the app with the factory version, press cancel. It should now stay disabled, however you will still have the same amount of storage taken by that app. It just will not appear on the home screen.

Source: https://support.google.com/googleplay/thread/11820446?hl=en&msgid=17309848

After a few days with Chrome app just deactivated, but “updated”, it keeps deactivated :blush:

3 Likes

Hello ung00gle,
sorry for the late answer. I was very busy the past weeks.
If you are using e, you should not have the problems discussed in this thread. Because e is not using these Google apps, that we all want to get rid of.

Otherwise - if you run into the situation described above for whatever reason, that an app you have uninstalled using this command

is still shown in the App list but with the remark

then just tap on this app. The App-Info will open. One of the buttons should be labeled “Uninstall”. Just tap it. If there is no “Uninstall” button, just tap “Force quit” first. This should change the “Deactivate” label of the other button into “Uninstall”.
You have to repeat this procedure for every installed update.
Finally - after a reboot the app, that was “not installed for the current user” will have been removed from the app list.

Good luck

2 Likes

I installed Microsofgt Edge and set it as default browser.
Then i uninstall/deactivate Google Chrome
After 24h Chrome is again activeted and updated with over 200MB also if APP updates are NOT SET to automatical. How to fix this Google “bug”?

1 Like

Welcome to the community forum.
I moved your post here to avoid duplicate topics, you will find a permanent way to uninstall stock Apps here.

The easy way (but probably less effective in terms of privacy) is this. A month and a half ago I just selected disable it, but didn’t delete all the updates. The Chrome app stayed disabled :slight_smile:

Any information about if and which google apps get reinstalled with the new Android 10 update? Didn’t received the upadate yet, so couldn’t check for myself. But might be good information to share in this thread.

I only had disabled the search bar on the homescreen via adb (the bar is still visible but doesn’t do anything). And that was still disabled after the Android 10 upgrade.

Do you have similar problems as me with Android 10 (with the/your uninstalled packages above) and the app overview?

I’m running /e/ now, not the stock OS anymore, so I can’t help with this.

The problem was caused by the uninstalled Android stock launcher (com.android.launcher3). So I’d recommend to not remove this package.

@AnotherElk
Maybe you would like to edit your posting above?

1 Like

Did you install a different launcher before you did this?

Yes, I installed and used Lawnchair as start app and then uninstalled the Android Stock Launcher via adp. All worked fine since Feb 2020 until the Android 10 update. After the successful OTA update the Recents Screen didn’t worked.

PS: After the factory reset all works fine with Android 10 with untouched stock launcher.

I have just received the update, and this is what’s on now:

FP3:/ $ pm list packages | grep 'google'
package:com.google.android.overlay.gmsgsaconfig
package:com.google.android.overlay.modules.permissioncontroller
package:com.google.android.deskclock
package:com.google.android.permissioncontroller
package:com.google.android.overlay.modules.ext.services
package:com.google.android.dialer
package:com.google.android.captiveportallogin
package:com.google.android.overlay.gmsconfig
package:com.google.android.modulemetadata
package:com.google.android.webview
package:com.google.android.networkstack
package:com.google.android.packageinstaller
package:com.google.android.gms
package:com.google.android.gsf
package:com.google.android.ims
package:com.google.android.overlay.modules.permissioncontroller.forframework
package:com.google.android.documentsui
package:com.google.android.networkstack.permissionconfig
package:com.google.android.projection.gearhead
package:com.google.android.gms.location.history
package:com.google.android.overlay.searchlauncherconfig

even though I was down to gms, gsf, ims, webview and dialer on Android 9.

Any experiences on what can safely go? This whole .overlay class seems newish, while location.history looks likely to be removed immediately :slight_smile:

The fingerprint software is also back, btw

1 Like

Thank you very much for your detailled description! I had most google apps replaced and deactivated before, but now I used your post to get rid of them completely.

The effect is huge! Before every single download took me ages while being connected to a wifi compared with mobile data download rates. Now a 100 MB download just takes a couple of seconds. Does anyone have an explanation for this?

I had a similar issue after trying to remove google searchbar on my FP3+ with a custom launcher (bliss).
The removing was not permanent. All my default apps were reseted on reboot.
The reason for this issue was that the launcher and some other apps were stored on the sd-card which was formatted as system storage. At reboot these apps were only available after signing into android. So android ‘decided’ to launch the original ‘google’ apps instead.
I simply formatted the sd-card as removable storage and re-installed all apps which were stored on the card.
The option to move single apps to the sd-card or back would help solving this issue but this option is missing in the settings of my Android 10 0077